Bug 101323 - perl-compress-zlib requires wrong perl version
Summary: perl-compress-zlib requires wrong perl version
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: perl-Compress-Zlib   
(Show other bugs)
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Chip Turner
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-07-30 21:13 UTC by Kaj J. Niemi
Modified: 2007-04-18 16:56 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-17 16:46:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Kaj J. Niemi 2003-07-30 21:13:17 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030719
Mozilla Firebird/0.6

Description of problem:

Requires perl >= 0:5.004 but should actually require >= 3:5.8.1.

% rpm -qp perl-Compress-Zlib-1.16-12.i386.rpm --requires
libc.so.6
libc.so.6(GLIBC_2.0)
libc.so.6(GLIBC_2.1)
libc.so.6(GLIBC_2.1.3)
libz.so.1
perl >= 0:5.004
perl(AutoLoader)
perl(Carp)
perl(DynaLoader)
perl(Exporter)
perl(IO::Handle)
perl(constant)
perl(strict)
perl(warnings)
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(VersionedDependencies) <= 3.0.3-1

% rpm -qpl perl-Compress-Zlib-1.16-12.i386.rpm
/usr/lib/perl5/vendor_perl/5.8.1/i386-linux-thread-multi/Compress/Zlib.pm
/usr/lib/perl5/vendor_perl/5.8.1/i386-linux-thread-multi/auto/Compress/Zlib/Zlib.bs
/usr/lib/perl5/vendor_perl/5.8.1/i386-linux-thread-multi/auto/Compress/Zlib/Zlib.so
/usr/lib/perl5/vendor_perl/5.8.1/i386-linux-thread-multi/auto/Compress/Zlib/autosplit.ix
/usr/share/man/man3/Compress::Zlib.3pm.gz

Previous versions of perl (excluding some 5.8.0s with patches from rawhide)
won't be looking in ./vendor_perl/5.8.1/

Version-Release number of selected component (if applicable):
perl-Compress-Zlib-1.16-12

How reproducible:
Always

Steps to Reproduce:
1. Get perl version <= 5.8.1
2. Install perl-Compress-Zlib
3. perl -e 'use Compress::Zlib;'
    

Actual Results:  Fails

Expected Results:  Should require 5.8.1 (since it was built against it) and work.

Additional info:

Right?

Comment 1 Kaj J. Niemi 2004-02-17 16:46:23 UTC
I'll just close this since 1.33-1 is available. 


Note You need to log in before you can comment on or make changes to this bug.