Bug 1013237 - pkcon get-updates throws an error: Error Type: <type 'exceptions.UnicodeEncodeError'>
pkcon get-updates throws an error: Error Type: <type 'exceptions.UnicodeEncod...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-28 12:58 EDT by kealthou
Modified: 2013-11-22 05:43 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-22 05:43:23 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description kealthou 2013-09-28 12:58:27 EDT
Description of problem:
I ran 'pkcon get-updates', and got an error.

% pkcon get-updates

更新の取得中            [=========================]
キューで待機中         [=========================]
開始中                     [=========================]
重大なエラー: Error Type: <type 'exceptions.UnicodeEncodeError'>
Error Value: 'ascii' codec can't encode characters in position 168-173: ordinal not in range(128)
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 3587, in <module>
    main()
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 3584, in main
    backend.dispatcher(sys.argv[1:])
  File : /usr/lib/python2.7/site-packages/packagekit/backend.py, line 710, in dispatcher
    self.dispatch_command(args[0], args[1:])
  File : /usr/lib/python2.7/site-packages/packagekit/backend.py, line 610, in dispatch_command
    self.get_updates(filters)
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 2687, in get_updates
    self._check_init()
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 3115, in _check_init
    repo.repoXML
  File : /usr/lib/python2.7/site-packages/yum/yumRepo.py, line 1666, in <lambda>
    repoXML = property(fget=lambda self: self._getRepoXML(),
  File : /usr/lib/python2.7/site-packages/yum/yumRepo.py, line 1662, in _getRepoXML
    self._loadRepoXML(text=self.ui_id)
  File : /usr/lib/python2.7/site-packages/yum/yumRepo.py, line 1653, in _loadRepoXML
    return self._groupLoadRepoXML(text, self._mdpolicy2mdtypes())
  File : /usr/lib/python2.7/site-packages/yum/yumRepo.py, line 1627, in _groupLoadRepoXML
    if self._commonLoadRepoXML(text):
  File : /usr/lib/python2.7/site-packages/yum/yumRepo.py, line 1447, in _commonLoadRepoXML
    if self._latestRepoXML(local):
  File : /usr/lib/python2.7/site-packages/yum/yumRepo.py, line 1425, in _latestRepoXML
    repomd = self.metalink_data.repomd
  File : /usr/lib/python2.7/site-packages/yum/yumRepo.py, line 910, in <lambda>
    metalink_data = property(fget=lambda self: self._getMetalink(),
  File : /usr/lib/python2.7/site-packages/yum/yumRepo.py, line 892, in _getMetalink
    print "Could not get metalink $s error was\n$s: $s" $ (url, e.args[0], misc.to_unicode(e.args[1]))



Version-Release number of selected component (if applicable):
PackageKit-0.8.9-6.fc19.x86_64


How reproducible:
Tried, but couldn't reproduce it.

Additional info:
My LANG is ja_JP.utf8.
Comment 1 Richard Hughes 2013-11-22 05:43:23 EST
I've fixed a load of unicode bugs in the last 2 releases. Can you repoen if this happens again please. Thanks.

Note You need to log in before you can comment on or make changes to this bug.