Bug 1013266 - No input from Sony Playstation 3 DualShock 3 gamepad after Bluetooth pairing (possibly wrong hid driver is used)
No input from Sony Playstation 3 DualShock 3 gamepad after Bluetooth pairing ...
Product: Fedora
Classification: Fedora
Component: bluez (Show other bugs)
Unspecified Linux
unspecified Severity medium
: ---
: ---
Assigned To: Don Zickus
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2013-09-28 18:52 EDT by Sergey Kondakov
Modified: 2015-02-17 12:23 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2015-02-17 12:23:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

External Trackers
Tracker ID Priority Status Summary Last Updated
Linux Kernel 62301 None None None Never

  None (edit)
Description Sergey Kondakov 2013-09-28 18:52:03 EDT
Description of problem:
When i pair my Dualshock 3 controller on Fedora 19 it doesn't provide any input with all axes stuck at "-32767" value and buttons on "off", as opposed to being connected via USB cord, when it works as expected, after pressing PS-button.

Version-Release number of selected component (if applicable):
kernel-3.11.1-200.fc19.x86_64, bluez-4.101-9.fc19, bluedevil-1.3.2-1.fc19

How reproducible:

Steps to Reproduce:
1. pair the controller
2. jstest /dev/input/js<number>
3. break its miniUSB port while uncomfortably playing with a cord

Actual results:
connected via USB:
[51505.042488] usb 4-4: new full-speed USB device number 2 using ohci-pci
[51505.243364] usb 4-4: New USB device found, idVendor=054c, idProduct=0268
[51505.243373] usb 4-4: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[51505.243378] usb 4-4: Product: PLAYSTATION(R)3 Controller
[51505.243382] usb 4-4: Manufacturer: Sony
[51505.877888] sony 0003:054C:0268.0004: Fixing up Sony Sixaxis report descriptor
[51505.925055] input: Sony PLAYSTATION(R)3 Controller as /devices/pci0000:00/0000:00:12.0/usb4/4-4/4-4:1.0/input/input15
[51505.925638] sony 0003:054C:0268.0004: input,hiddev0,hidraw3: USB HID v1.11 Joystick [Sony PLAYSTATION(R)3 Controller] on usb-0000:00:12.0-4/input0

connected via BT:
[51564.526624] hid-generic 0005:0000:0000.0005: unknown main item tag 0x0
[51564.526730] input: PLAYSTATION(R)3 Controller as /devices/pci0000:00/0000:00:13.0/usb5/5-1/5-1:1.0/bluetooth/hci0/hci0:1/input16
[51564.526918] hid-generic 0005:0000:0000.0005: input,hidraw3: BLUETOOTH HID v0.00 Joystick [PLAYSTATION(R)3 Controller] on 00:11:67:d6:16:90

Expected results:
hid-sony should be used, according to https://iwilcox.me.uk/2012/sixaxis-ubuntu

Additional info:
Comment 1 buaku69 2013-09-30 20:28:03 EDT
I've noticed this too, and thought I'd share my experience.

I tried patching  bluez-4.101-9.fc19 according to the website listed, but it only sort of worked. It did indeed trigger the hid-sony module, but after a few seconds it died with the following error:
sony: probe of 0005:054C:0268.005 failed with error -5

After that message if I go to /dev/input I see no js* devices.

This all did work at one time though.
Fedora 16 with bluez 4.96-3.fc16, bluedevil 1.2.3-1.fc16 and kernel 3.6.11-f.fc16 worked great!
All I had to do to make it work was plug in the controller via usb, unhook it, press the PS button, authorize the connection and I was good to go!
Comment 2 Sergey Kondakov 2013-10-12 08:46:36 EDT
Indeed, it's a regression.
And in the worst possible time too, when Linux Gaming gets practically handed to us.
Comment 3 dustin.moline 2013-12-28 19:28:38 EST
I have a weird problem where bluetooth worked find with Bluez 5 in the Fedora 20 Beta but now I can't get it to work again in Fedora 20 release. I don't believe I didn't anything differently; I paired the controller with sixpair and used bluetoothctl to scan for devices. In the Beta this worked but now I can't get the controller to connect. Bluetoothctl sees the mac address but never is able to connect.
Comment 4 buaku69 2013-12-30 01:30:54 EST
I sort of noticed the same thing.

With bluez 5.10 bluetooth worked fine. With 5.12 it doesn't work.

I'm doing this all from run-level 3 though and not using any GUI's.

The way it worked in bluez 5.10 was I'd plug it in via usb and it would create a file in /var/lib/bluetooth/<btadapteraddress>/cache

I'd then unplug the ps3 controller from the usb cable, hit the PS button and it would work (i.e. create a device as /dev/input/js0).

With bluez 5.12 It doesn't create the file anymore in /var/lib/bluetooth/...
and then when I unplug the cable and hit the PS button I get an error saying something like it can't find the path to something.

There was a new bluez packaged pushed out not too long ago that claims to fix a lot of problems, but I haven't had a chance to try it yet.

I figure I'd have to open a new bug report since this bug is bluez 4 and these new issues are bluez 5.
Comment 5 Fedora End Of Life 2015-01-09 15:01:23 EST
This message is a notice that Fedora 19 is now at end of life. Fedora 
has stopped maintaining and issuing updates for Fedora 19. It is 
Fedora's policy to close all bug reports from releases that are no 
longer maintained. Approximately 4 (four) weeks from now this bug will
be closed as EOL if it remains open with a Fedora 'version' of '19'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 19 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 6 Fedora End Of Life 2015-02-17 12:23:58 EST
Fedora 19 changed to end-of-life (EOL) status on 2015-01-06. Fedora 19 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.