Bug 1013324 - systemctl start httpd.service Permission denied
systemctl start httpd.service Permission denied
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: httpd (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jan Kaluža
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-29 05:39 EDT by orti1980
Modified: 2015-07-22 08:29 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-07-22 08:29:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description orti1980 2013-09-29 05:39:37 EDT
[root@localhost orti]# systemctl start httpd.service
Job for httpd.service failed. See 'systemctl status httpd.service' and 'journalctl -xn' for details.
[root@localhost orti]# journalctl -xn
-- Logs begin at Do 2013-09-26 22:08:02 CEST, end at So 2013-09-29 11:37:01 CEST. --
Sep 29 11:37:01 localhost.localdomain httpd[1586]: (13)Permission denied: AH02291: Cannot access directory '/win/www/reklam/' for error log of vhost defined at /etc/httpd/conf.d/vhost.conf:177
Sep 29 11:37:01 localhost.localdomain httpd[1586]: (13)Permission denied: AH02291: Cannot access directory '/win/www/up/' for error log of vhost defined at /etc/httpd/conf.d/vhost.conf:144
Sep 29 11:37:01 localhost.localdomain httpd[1586]: (13)Permission denied: AH02291: Cannot access directory '/win/www/up/' for error log of vhost defined at /etc/httpd/conf.d/vhost.conf:109
Sep 29 11:37:01 localhost.localdomain httpd[1586]: (13)Permission denied: AH02291: Cannot access directory '/win/www/log/amtracker/' for error log of vhost defined at /etc/httpd/conf.d/vhost.conf:79
Sep 29 11:37:01 localhost.localdomain httpd[1586]: (13)Permission denied: AH02291: Cannot access directory '/win/www/wing/' for error log of vhost defined at /etc/httpd/conf.d/vhost.conf:48
Sep 29 11:37:01 localhost.localdomain httpd[1586]: (13)Permission denied: AH02291: Cannot access directory '/win/www/p5w/' for error log of vhost defined at /etc/httpd/conf.d/vhost.conf:19
Sep 29 11:37:01 localhost.localdomain httpd[1586]: AH00014: Configuration check failed
Sep 29 11:37:01 localhost.localdomain systemd[1]: httpd.service: control process exited, code=exited status=1
Sep 29 11:37:01 localhost.localdomain systemd[1]: Failed to start The Apache HTTP Server.
-- Subject: Unit httpd.service has failed
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- Documentation: http://www.freedesktop.org/wiki/Software/systemd/catalog/be02cf6855d2428ba40df7e9d022f03d
-- 
-- Unit httpd.service has failed.
-- 
-- The result is failed.
Sep 29 11:37:01 localhost.localdomain systemd[1]: Unit httpd.service entered failed state.
[root@localhost orti]# 






httpd -k start working
Comment 1 Jaroslav Reznik 2015-03-03 10:06:47 EST
This bug appears to have been reported against 'rawhide' during the Fedora 22 development cycle.
Changing version to '22'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora22
Comment 3 Fedora Admin XMLRPC Client 2015-03-14 21:40:05 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 4 Mosaab Alzoubi 2015-03-24 23:25:08 EDT
Not a "system-config-httpd" bug!
Comment 5 Jan Kaluža 2015-03-25 03:44:16 EDT
Is SELinux enabled (Check output of "sestatus")? If it is, I would say this is caused by wrong SELinux context of the /win/www/up/. Send the output of ls -Z /win/www.
Comment 6 Jan Kaluža 2015-07-22 08:29:59 EDT
I presume it has been caused by the wrong selinux context as I described in Comment 6. If not, please provide the information described in Commnet 6 and reopen the bug.

Note You need to log in before you can comment on or make changes to this bug.