Bug 1013337 - git push to node.js-0.10 scalable app fails with supervisor PID does not match after migration
git push to node.js-0.10 scalable app fails with supervisor PID does not matc...
Status: CLOSED NOTABUG
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Fotios Lindiakos
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-29 07:36 EDT by Yan Du
Modified: 2015-05-14 19:29 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-30 01:47:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yan Du 2013-09-29 07:36:16 EDT
Description of problem:
git push to node.js app fails with supervisor PID does not match after migration



Version-Release number of selected component (if applicable):
devenv_3644
rhc-1.15.3



How reproducible:
always



Steps to Reproduce:

1.create a nodjs-0.10 scalable app
2. upgrade the server
3. touch .openshift/marker/hot_deploy and make some change in index.html
4. git push



Actual results:

root@openshift-ubuntu:~/test/nodejs10s# touch .openshift/markers/hot_deploy
root@openshift-ubuntu:~/test/nodejs10s# git add .; git commit -amp; git push
[master 46ba6ed] p
 Committer: root <root@openshift-ubuntu.(none)>
<------------------------------------------------snip--------------------------------->
Compressing objects: 100% (4/4), done.
Writing objects: 100% (4/4), 370 bytes, done.
Total 4 (delta 2), reused 0 (delta 0)
remote: Not stopping cartridge cron because hot deploy is enabled
remote: Not stopping cartridge haproxy because hot deploy is enabled
remote: Not stopping cartridge nodejs because hot deploy is enabled
remote: Saving away previously installed Node modules
remote: Building NodeJS cartridge
remote: npm info it worked if it ends with ok
remote: npm info using npm@1.2.17
remote: npm info using node@v0.10.5
remote: npm info preinstall OpenShift-Sample-App@1.0.0
remote: npm info build /var/lib/openshift/524795aa18568ca6340005aa/app-root/runtime/repo
remote: npm info linkStuff OpenShift-Sample-App@1.0.0
remote: npm info install OpenShift-Sample-App@1.0.0
remote: npm info postinstall OpenShift-Sample-App@1.0.0
remote: npm info prepublish OpenShift-Sample-App@1.0.0
remote: npm info ok 
remote: Starting application nodejs10s
remote: Not starting cartridge cron because hot deploy is enabled
remote: Not starting cartridge haproxy because hot deploy is enabled
remote: Application will not be stopped during gear sync to to presence of hot_deploy marker
remote: SSH_CMD: ssh 5247fcca18568c146700001a@10.4.29.190
remote: ++ date
remote: + echo 'Syncing to gear: 5247fcca18568c146700001a@10.4.29.190:nodejs @ ' Sun Sep 29 06:21:27 EDT 2013
remote: Syncing to gear: 5247fcca18568c146700001a@10.4.29.190:nodejs @  Sun Sep 29 06:21:27 EDT 2013
remote: + for subd in '"${OPENSHIFT_SYNC_GEARS_DIRS[@]}"'
remote: + '[' -d /var/lib/openshift/524795aa18568ca6340005aa/nodejs//../app-root/repo ']'
remote:  + rsync -v --delete-after -az  /var/lib/openshift/524795aa18568ca6340005aa/nodejs//../app-root/repo/  5247fcca18568c146700001a@10.4.29.190:nodejs/../app-root/repo/
remote: building file list ... done
remote: ./
remote: README.md
remote: deplist.txt
remote: index.html
remote: package.json
remote: server.js
remote: .openshift/
remote: .openshift/action_hooks/
remote: .openshift/action_hooks/README.md
remote: .openshift/cron/
remote: .openshift/cron/README.cron
remote: .openshift/cron/daily/
remote: .openshift/cron/daily/.gitignore
remote: .openshift/cron/hourly/
remote: .openshift/cron/hourly/.gitignore
remote: .openshift/cron/minutely/
remote: .openshift/cron/minutely/.gitignore
remote: .openshift/cron/minutely/date.sh
remote: .openshift/cron/monthly/
remote: .openshift/cron/monthly/.gitignore
remote: .openshift/cron/weekly/
remote: .openshift/cron/weekly/README
remote: .openshift/cron/weekly/chrono.dat
remote: .openshift/cron/weekly/chronograph
remote: .openshift/cron/weekly/jobs.allow
remote: .openshift/cron/weekly/jobs.deny
remote: .openshift/markers/
remote: .openshift/markers/.gitkeep
remote: .openshift/markers/hot_deploy
remote: node_modules/
remote: node_modules/.gitkeep
remote: deleting date.log
remote: 
remote: sent 1430 bytes  received 593 bytes  1348.67 bytes/sec
remote: total size is 14107  speedup is 6.97
remote: + for subd in '"${OPENSHIFT_SYNC_GEARS_DIRS[@]}"'
remote: + '[' -d /var/lib/openshift/524795aa18568ca6340005aa/nodejs//node_modules ']'
remote:  + rsync -v --delete-after -az  /var/lib/openshift/524795aa18568ca6340005aa/nodejs//node_modules/  5247fcca18568c146700001a@10.4.29.190:nodejs/node_modules/
remote: building file list ... done
remote: ./
remote: deleting .node_modules
remote: 
remote: sent 879 bytes  received 15 bytes  596.00 bytes/sec
remote: total size is 519  speedup is 0.58
remote: + for subd in '"${OPENSHIFT_SYNC_GEARS_DIRS[@]}"'
remote: + '[' -d /var/lib/openshift/524795aa18568ca6340005aa/nodejs//virtenv ']'
remote: + for subd in '"${OPENSHIFT_SYNC_GEARS_DIRS[@]}"'
remote: + '[' -d /var/lib/openshift/524795aa18568ca6340005aa/nodejs//../.m2 ']'
remote: + for subd in '"${OPENSHIFT_SYNC_GEARS_DIRS[@]}"'
remote: + '[' -d /var/lib/openshift/524795aa18568ca6340005aa/nodejs//.openshift ']'
remote: + for subd in '"${OPENSHIFT_SYNC_GEARS_DIRS[@]}"'
remote: + '[' -d /var/lib/openshift/524795aa18568ca6340005aa/nodejs//deployments ']'
remote: + for subd in '"${OPENSHIFT_SYNC_GEARS_DIRS[@]}"'
remote: + '[' -d /var/lib/openshift/524795aa18568ca6340005aa/nodejs//perl5lib ']'
remote: + for subd in '"${OPENSHIFT_SYNC_GEARS_DIRS[@]}"'
remote: + '[' -d /var/lib/openshift/524795aa18568ca6340005aa/nodejs//phplib ']'
remote: + for rpccall in '"${OPENSHIFT_SYNC_GEARS_POST[@]}"'
remote: + ssh 5247fcca18568c146700001a@10.4.29.190 'gear remotedeploy --hot-deploy=true'
remote: Starting application nodejs10s
remote: Starting Cron cartridge
remote: CLIENT_RESULT: cron scheduling service is already enabled for gear 5247fcca18568c146700001a
remote: Starting NodeJS cartridge
remote:  hot_deploy marker found. Switching to using supervisor. Subsequent  pushes won't require restart until the marker is removed.
remote: Exit code: 0
remote: Not starting cartridge nodejs because hot deploy is enabled
remote:  hot_deploy marker found. Switching to using supervisor. Subsequent  pushes won't require restart until the marker is removed.
remote: Stopping NodeJS cartridge
remote:  Warning: Application 'nodejs10s' supervisor PID does not match  '$OPENSHIFT_NODEJS_PID_DIR/supervisor.pid'.  Use force-stop to kill.
remote: An error occurred executing 'gear postreceive' (exit code: 141)
remote: Error message: Failed to execute: 'control post-deploy' for /var/lib/openshift/524795aa18568ca6340005aa/nodejs
remote: 
remote: For more details about the problem, try running the command again with the '--trace' option.
To ssh://524795aa18568ca6340005aa@nodejs10s-migration2.dev.rhcloud.com/~/git/nodejs10s.git/
   b3c5ec5..46ba6ed  master -> master



Expected results:
should git push successfully



Additional info:

1.Test ok with nodejs-0.10 non-scalable app.
2.Test ok with new nodejs-0.10 app, issue just can be reproduced with the app after migtation
3. Test ok with nodejs-0.6 app
Comment 1 Yan Du 2013-09-30 01:47:29 EDT
Retest migration test from devenv_stage_478 to devenv_3844, can not reproduce the issue, maybe it is a random issue.

Note You need to log in before you can comment on or make changes to this bug.