Bug 1013348 - User guide does not describe how to configure Katello into a working state
User guide does not describe how to configure Katello into a working state
Status: CLOSED DUPLICATE of bug 1225166
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Docs User Guide (Show other bugs)
Nightly
All All
high Severity high (vote)
: Unspecified
: 6.0
Assigned To: Hayley Hudgeons
David O'Brien
: Reopened, Triaged
Depends On:
Blocks: GSS_Sat6Beta_Tracker/GSS_Sat6_Tracker
  Show dependency treegraph
 
Reported: 2013-09-29 09:10 EDT by Magnus Glantz
Modified: 2015-05-26 14:22 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-05-26 14:22:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Magnus Glantz 2013-09-29 09:10:12 EDT
Document URL: 
https://fedorahosted.org/katello/wiki/UserGuide

Section Number and Name: 
All sections

Describe the issue: 
The userguide does not describe how to configure Katello into a working state, so it can be used to install and manage servers and applications with it.

Without any knowledge of Puppet, Pulp, general "RHN Satellite" design, etc, it is difficult to even know where to start. Most of the documentation that is not missing is outdated which is confusing when you try to make sense out of your installed Katello server. 

Suggestions for improvement:
Create documentation on how to configure Katello into a working state, so it can be used to install and manage servers and applications.

Additional information:
This is a blocker for most people that want to evaluate or use Katello. A proper set of docs is the foundation for both adoption and contribution on a wider scale.

I've seen that the UserGuide is marked "Under Construction" on the Wiki and that a proper guide on "howto get Katello working" is listed at https://fedorahosted.org/katello/wiki/FeatureRequests but I thought I'd make it even more visible and create a bug as well.
Comment 1 manjiri tapaswi 2013-10-15 12:10:21 EDT
Updated the userguide with a link to installation instructions and youtube video tutorials. 

https://fedorahosted.org/katello/wiki/UserGuide

Feedback welcome.
Comment 2 Magnus Glantz 2013-10-15 17:24:36 EDT
Thanks Manjiri for improving on the installation instructions, but two of the Youtube videos are based on a Katello from 1 year ago and the two other videos are of Katello versions that are 6 and 7 months old.

For example, the "Initial Setup" video uses Fedora 16 with Katello, as far as I know, that's not even supported.. not sure how much use these do.
Comment 3 manjiri tapaswi 2013-10-16 10:55:32 EDT
Thanks Magnus for the feedback, working on them.
Comment 5 Bryan Kearney 2014-01-21 14:07:01 EST
Moving to Sat6 to be tracked there. Upstream bugs are moving to redmine.
Comment 6 RHEL Product and Program Management 2014-01-21 14:19:09 EST
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.
Comment 11 David O'Brien 2014-11-26 00:51:31 EST
Mike,
What's the status of this? Does the existing User Guide address this properly?
Comment 12 Mike McCune 2014-12-09 17:40:37 EST
This is addressed in the Provisioning Guide:

https://access.redhat.com/documentation/en-US/Red_Hat_Satellite/6.0/html-single/Provisioning_Guide/index.html

going to CLOSE:CURRENTRELEASE this.

Magnus, please take a look at the Provisioning Guide I linked to here, it discusses the steps necessary to configure Satellite 6 to provision and connect clients.

Feel free to re-open with additional commentary as to what additional docs we need.
Comment 13 Magnus Glantz 2014-12-10 08:41:41 EST
Hey Mike, I've had a look, I am missing more detailed documentation regarding Puppet modules. 

So far, the documentation reads:

"The next step is to upload a Puppet Module to the Puppet Module repository. You can also use the forge.puppetlabs.com as the URL to mirror Puppet Forge locally. This means that all of the content from Puppet Forge will be available on your Satellite. However, this requires downloading over 2700 modules and can take considerable time, depending on available bandwidth. This example uses the motd module because it is simple, and has no dependencies on other modules.
⁠

Procedure 3.4. To Upload a Puppet Module to the Repository:

    Download the motd puppet module from https://forge.puppetlabs.com/jeffmccune/motd. The file that you download will have a .tar.gz extension.
    Click Content → Products and then click Custom Products in the Name field.
    On the Repositories tab, click Puppet Modules to modify the Puppet Modules repository.
    In the Upload Puppet Module section, click Browse, and navigate to the motd module that you downloaded.
    Click Upload. Satellite displays Content successfully uploaded after the upload completes successfully.
"

But it does not detail the creation of your own Puppet modules. If it's the Puppet Forge way that is the correct one, I would expect a link to their documentation regarding the matter. Maintaining a Puppet Forge module without the proper tooling is also difficult, so perhaps you should say something about that, if it's not covered by Puppet Forge.
Comment 16 RHEL Product and Program Management 2015-04-21 12:11:28 EDT
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.
Comment 17 Karl Abbott 2015-04-30 09:56:47 EDT
May I ask why we have changed this from 6.1.0+ to 6.1.0?

Karl
Comment 19 Hayley Hudgeons 2015-05-26 14:21:57 EDT
Magnus,

Thank you for submitting this request. 

Since it looks like the request has changed a bit since the bug was originally filed, I am going to close this bug and I have opened a new one specifically for the request about adding specific info on puppet modules to the Provisioning Guide. That new bug can be found here:

https://bugzilla.redhat.com/show_bug.cgi?id=1225166

Please follow that new bug for updates on this. 

Regards,
Hayley Hudgeons
Comment 20 Hayley Hudgeons 2015-05-26 14:22:33 EDT

*** This bug has been marked as a duplicate of bug 1225166 ***

Note You need to log in before you can comment on or make changes to this bug.