Bug 1013355 - [RFE]: LDAP authentication for user accounts
[RFE]: LDAP authentication for user accounts
Status: CLOSED WORKSFORME
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
Nightly
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: Adam Saleh
Katello QA List
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-29 10:24 EDT by Magnus Glantz
Modified: 2014-09-18 13:02 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-16 11:05:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Magnus Glantz 2013-09-29 10:24:18 EDT
Description of problem:
The webui does not feature the ability to select LDAP authentication for users accounts. This is a "must have" feature for a companies that requires things such as PCI DSS compliance (all userIDs must be unique, which requires integration to for example a LDAP service).

Version-Release number of selected component (if applicable):
Katello 1.4.8-1.git.4.c940d43.el6

How reproducible:
N/A

Steps to Reproduce:
Add a new user: Administer > Users > Add new user.

Actual results:
Create a new user, there are no options to select a LDAP authentication source.

Expected results:
Option to select a LDAP authentication source when adding new users.

Additional info:
This is a blocker for companies that requires for example PCI DSS compliance.
Comment 1 Magnus Glantz 2013-09-29 10:45:31 EDT
Changed Severity to "Urgent" as it's a blocker for the many companies with demand on unique user id's.
Comment 3 Mike McCune 2013-10-10 13:59:30 EDT
moved this to our downstream product to align to a future release.

moving to severity high as Urgent is reserved for "we have 24 hours to resolve this issue" type bugs where *nothing* is functional.
Comment 6 Bryan Kearney 2014-01-08 16:23:00 EST
This will be delivered in MDP3.
Comment 8 Adam Saleh 2014-05-16 11:05:12 EDT
Works for me with local 389DS and single user. Added through the gui https://qetello02.usersys.redhat.com/auth_source_ldaps. Was able to login.

Note You need to log in before you can comment on or make changes to this bug.