Bug 1013364 - xscreensaver blanks the screen when video is running without respecting the settings in .xscreensaver
xscreensaver blanks the screen when video is running without respecting the s...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xscreensaver (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Mamoru TASAKA
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-29 12:06 EDT by Piruthiviraj Natarajan
Modified: 2013-11-30 13:09 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-30 13:09:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
.xscreensaver (7.84 KB, text/plain)
2013-09-29 12:06 EDT, Piruthiviraj Natarajan
no flags Details
.config for mplayer (105 bytes, text/plain)
2013-09-29 12:10 EDT, Piruthiviraj Natarajan
no flags Details
.xsession-errors (898 bytes, text/plain)
2013-09-29 12:13 EDT, Piruthiviraj Natarajan
no flags Details
xscreensaver -verbose -log (2.00 KB, text/plain)
2013-09-30 07:25 EDT, Piruthiviraj Natarajan
no flags Details
case 1 (2.42 KB, text/plain)
2013-09-30 19:26 EDT, Piruthiviraj Natarajan
no flags Details
case 2 (2.51 KB, text/plain)
2013-09-30 19:34 EDT, Piruthiviraj Natarajan
no flags Details
xscreensaver -verbose -log (1.24 KB, text/plain)
2013-10-07 22:07 EDT, Piruthiviraj Natarajan
no flags Details
.config for mplayer (210 bytes, text/plain)
2013-10-07 22:08 EDT, Piruthiviraj Natarajan
no flags Details
.xscreensaver (7.86 KB, text/plain)
2013-10-07 22:09 EDT, Piruthiviraj Natarajan
no flags Details

  None (edit)
Description Piruthiviraj Natarajan 2013-09-29 12:06:17 EDT
Created attachment 804737 [details]
.xscreensaver

Description of problem:

When I am playing video through VLC,totem, smplayer I am not able to watch the video without xscreensaver blanking the screen.
Version-Release number of selected component (if applicable):
Name        : xscreensaver
Arch        : x86_64
Epoch       : 1
Version     : 5.22
Release     : 1.fc20.2


How reproducible:

All the time
Steps to Reproduce:
1.play a video through one of the players mentioned above.
2.xscreensaver blanks the screen not respecting the setting


Expected results:
Xscreensaver should not be blanking and should respect the setting made in the xscreensaver-demo. 

Additional info:
Comment 1 Piruthiviraj Natarajan 2013-09-29 12:10:23 EDT
Created attachment 804738 [details]
.config for mplayer
Comment 2 Piruthiviraj Natarajan 2013-09-29 12:13:29 EDT
Created attachment 804739 [details]
.xsession-errors
Comment 3 Piruthiviraj Natarajan 2013-09-29 12:22:28 EDT
I have set VlC media player with the default option with disable the screensaver checked.

Now when I uncheck the quick Power-off in Blank Only Mode in Xscreesaver, my smplayer works without the blanking, but with VLC, xscreensaver still blanks when playing a video.
Comment 4 Mamoru TASAKA 2013-09-30 01:27:58 EDT
I cannot figure out what media player you are using here exactly
(you say "smplayer / mplayer / vlc / totem", I am not sure
 what you are exactly doing).

Please specify in detail, seperately, the procedure you were doing,
thank you.

Note that anyway it is up to how these media player handles xscreensaver,
and I guess there is nothing xscreensaver side should be fixed.
I can check xscreensaver if it is said that "this media player surely emits
`xscreensaver-command -deactivate` periodically, however xscreensaver
ignores it", however generally for external media players, i have to
say "I don't know, sorry".
Comment 5 Mamoru TASAKA 2013-09-30 01:30:41 EDT
Note that your ~/.xscreensaver surely says to "blank", so xscreensaver
actually is repecting your settings.
Comment 6 Mamoru TASAKA 2013-09-30 03:12:53 EDT
Additional questions

* For sure, would you attach the result of "rpm -qa | grep screensaver" ?
* Also "ps auwwx | grep screensaver" ?
* What happens if you
  - launch a terminal
  - execute (as bash) "while true ; do sleep 30 ; xscreensaver-command -deactivate & done"
  ?
Comment 7 Piruthiviraj Natarajan 2013-09-30 03:23:37 EDT
1.rpm -qa | grep screensaver
xscreensaver-base-5.22-1.fc20.2.x86_64


2.ps auwwx | grep screensaver
freedom   1010  0.0  0.0 159136  2600 ?        S    12:31   0:00 xscreensaver -no-splash
freedom   1746  0.1  0.1 517568 14600 ?        Sl   12:40   0:01 xscreensaver-demo
freedom   1977  0.0  0.0 112736   928 pts/0    S+   12:50   0:00 grep --color=auto screensaver

3.[freedom@localhost ~]$ while true ; do sleep 30 ; xscreensaver-command -deactivate & done[1] 1983
xscreensaver-command: not active: idle timer reset.

[1]+  Done                    xscreensaver-command -deactivate
[1] 1985
xscreensaver-command: not active: idle timer reset.
Comment 8 Piruthiviraj Natarajan 2013-09-30 03:27:57 EDT
3.(continued)
After one minute the screen goes to blank mode.
Comment 9 Mamoru TASAKA 2013-09-30 05:06:31 EDT
(In reply to Piruthiviraj Natarajan from comment #8)
> 3.(continued)
> After one minute the screen goes to blank mode.

Do you make it sure that the above script is kept running? (i.e.
don't kill the script even if once "xscreensaver-command -deactivate" is 
executed), i.e. output messages should show like;

$ while true ; do sleep 30 ; xscreensaver-command -deactivate & done
[1] 17139
xscreensaver-command: not active: idle timer reset.

[1]+  終了                  xscreensaver-command -deactivate
[1] 17158
xscreensaver-command: not active: idle timer reset.

[1]+  終了                  xscreensaver-command -deactivate
[1] 17175
xscreensaver-command: not active: idle timer reset.

[1]+  終了                  xscreensaver-command -deactivate
[1] 17191
xscreensaver-command: not active: idle timer reset.

.....
Comment 10 Piruthiviraj Natarajan 2013-09-30 05:13:55 EDT
Yes. Mine does show like yours. 

What next?
Comment 11 Piruthiviraj Natarajan 2013-09-30 06:31:48 EDT
But as you have said, how to check if VLC emits
`xscreensaver-command -deactivate` periodically?

Where shall  I look for that?
Comment 12 Mamoru TASAKA 2013-09-30 07:06:23 EDT
Ah, reproduced using your ~/.xscreensaver , let me investigate further
(perhaps takes a few days due to some $DAYLY work).

(In reply to Piruthiviraj Natarajan from comment #11)
> But as you have said, how to check if VLC emits
> `xscreensaver-command -deactivate` periodically?
> 
> Where shall  I look for that?

You can check if xscreensaver receives commands or not when
you launch xscreensaver with verbose mode like

$ xscreensaver -verbose -log some_log_file.txt &

, however anyway as I said I will investigate.
Comment 13 Piruthiviraj Natarajan 2013-09-30 07:22:58 EDT
Thanks for testing and the wonderful answers!
If you need anything more, I am here.
If its of any help I have attached my verbose-log while playing a video.
Comment 14 Piruthiviraj Natarajan 2013-09-30 07:25:42 EDT
Created attachment 805136 [details]
xscreensaver -verbose -log
Comment 15 Mamoru TASAKA 2013-09-30 10:06:14 EDT
Ah, I have completely forgotton one thing... Actually that screensaver got blank was due to dpms which xscreensaver sets.

Would you try

$  while true ; do sleep 30 ; xscreensaver-command -dea & xset dpms s reset & done

? If the above works, would you try setting mplayer .config similarly?
Comment 16 Piruthiviraj Natarajan 2013-09-30 10:58:27 EDT
[freedom@localhost ~]$ while true ; do sleep 30 ; xscreensaver-command -dea & xset dpms s reset & done[1] 2436
[2] 2437
xscreensaver-command: not active: idle timer reset.

[1]-  Done                    xscreensaver-command -dea
[2]+  Done                    xset dpms s reset
[1] 2441
[2] 2442
xscreensaver-command: not active: idle timer reset.

[1]-  Done                    xscreensaver-command -dea
[2]+  Done                    xset dpms s reset
[1] 2446
[2] 2447
xscreensaver-command: not active: idle timer reset.

[1]-  Done                    xscreensaver-command -dea
[2]+  Done                    xset dpms s reset
[1] 2451
[2] 2452
xscreensaver-command: not active: idle timer reset.

[1]-  Done                    xscreensaver-command -dea
[2]+  Done                    xset dpms s reset
[1] 2456
[2] 2457
xscreensaver-command: not active: idle timer reset.

Thanks.
It works.Sorry If I sound stupid.
1.But what command to set in .config for mplayer?
I already have this .config
heartbeat-cmd="xscreensaver-command -deactivate > /dev/null"

2.What to do with VLC?
Comment 17 Mamoru TASAKA 2013-09-30 11:05:56 EDT
Well, I don't know well, however
- As far as I checked mplayer source code, mplayer seems to launch
  heartbeat-cmd with just system(3), so I guess just writing

heartbeat-cmd="xscreensaver-command -deactivate > /dev/null & xset dpms s reset &"

  will work (again I guess).

- For vlc, for now I am not sure (I have to read vlc readme or source code,
  however these are out of xscreensaver scope).
Comment 18 Piruthiviraj Natarajan 2013-09-30 11:17:05 EDT
thanks for helping me out. It  works now for smplayer. But not VLC. I guess I will have to figure it out. 

I have never seen a such a patient Developer like you before. Keep up the Good work!
Comment 19 Piruthiviraj Natarajan 2013-09-30 11:31:45 EDT
Oh no. I restarted the system and its back to square one. It doesn't work.
Comment 20 Mamoru TASAKA 2013-09-30 11:48:39 EDT
(In reply to Piruthiviraj Natarajan from comment #19)
> Oh no. I restarted the system and its back to square one. It doesn't work.

What do you mean by "square one"? Anyway I will recheck xscreensaver code, after
that I will judge if I fix / modify this bug or not.
Comment 21 Piruthiviraj Natarajan 2013-09-30 11:52:46 EDT
I followed what you asked to put me in the .config and I did and screen was not blanking but after I did a restart of the computer and when I tried to play a video on smplayer(front-end for mplayer) after the restart the screensaver started to blank again. 

my .config contents:

heartbeat-cmd="xscreensaver-command -deactivate > /dev/null & xset dpms s reset &"
Comment 22 Mamoru TASAKA 2013-09-30 18:05:15 EDT
(In reply to Piruthiviraj Natarajan from comment #21)
>  but after I did a restart of the computer and when I tried to
> play a video on smplayer(front-end for mplayer) after the restart the
> screensaver started to blank again. 

In this case:
- What does xscreensaver verbose mode
  (i.e. once killing xscreensaver by $ xscreensaver-command -exit
   , relaunching with
   $ xscreensaver -verbose -log some_log.txt
   and showing some_log.txt
  ) says?

  (Note that once killing xscreensaver and relaunching with verbose mode
   is enough. In this case the content of some_log.txt is needed )

- Again trying 
  "while true ; do sleep 30 ; xscreensaver-command -dea & xset dpms s reset & done" 
  from a terminal (instead of executing smplayer) works?
Comment 23 Piruthiviraj Natarajan 2013-09-30 19:26:27 EDT
Created attachment 805627 [details]
case 1
Comment 24 Piruthiviraj Natarajan 2013-09-30 19:28:17 EDT
No blanking in case 1
Comment 25 Piruthiviraj Natarajan 2013-09-30 19:34:22 EDT
Created attachment 805628 [details]
case 2

no blanking in case 2 too following your instructions without starting any player.
Comment 26 Mamoru TASAKA 2013-09-30 20:53:36 EDT
Well, for now one more thing:

(In reply to Piruthiviraj Natarajan from comment #25)
> Created attachment 805628 [details]
> case 2
> 
> no blanking in case 2 too following your instructions without starting any
> player.

Does this work even after reboot and then _not_ relauching xscreensaver
(i.e., reboot -> login -> (perhaps xscreensaver is running) -> launch terminal
  -> continuously running "while true, ....." ) ?
Comment 27 Piruthiviraj Natarajan 2013-09-30 21:04:39 EDT
If I restart and launch terminal and run "while true ; do sleep 30 ; xscreensaver-command -dea & xset dpms s reset & done" continuously, The screen doesn't blank.

I 'm not sure if this Is that what you ask me to do?
Comment 28 Mamoru TASAKA 2013-09-30 21:25:29 EDT
Then I will guess that after reboot smplayer sometimes does not read
your .config file ...??
Comment 29 Piruthiviraj Natarajan 2013-09-30 21:39:51 EDT
probable. But why all video players  at the same time?

I have the same version of xscreensaver in Gentoo and it works fine as expected. But some implementation in fedora has changed and it doesn't work as expected. It maybe something other than xscreensaver which I couldn't recognize and hence I filed this report. If you have any suggestions of places where I could look for like any other package which might result in this behavior, I would be happy to look for.
Comment 30 Piruthiviraj Natarajan 2013-09-30 22:28:15 EDT
Well I just moved to cinnamon-desktop and the cinnamon-screensaver works fine with smplayer.
Comment 31 Mamoru TASAKA 2013-09-30 22:43:44 EDT
So maybe you were using GNOME 3? If so, in other desktop environments
(like LXDE, xfce) your monitors run as expected (with xscreensaver)?
(make sure that xscreensaver is running on that desktop environment).
Comment 32 Piruthiviraj Natarajan 2013-09-30 22:58:08 EDT
I was running all this time with xfce, but just now moved to cinnamon where I doubt we can use xscreensaver.

But as you suggested I tested lxde which works as expected and no blanking while playing videos in smplayer.
Comment 33 Piruthiviraj Natarajan 2013-09-30 23:35:45 EDT
smplayer works in XFCE too without any blanking after multiple restarts.
I dont know what to say. At least it is working!
Comment 34 Mamoru TASAKA 2013-10-01 00:32:21 EDT
Well, I now tried vlc, and 
- the first time I tried vlc, screen got blank after one minutes
- now the second time, screen no longer gets blank..
(At least for me). Do you see similar issue?
Comment 35 Piruthiviraj Natarajan 2013-10-01 00:47:25 EDT
No its different. VLC now works fine for me. No blanking.
I find it very interesting that since I switched to 3.12RC3 kernel for the last few hours Even VLC works as expected.

Maybe it has got something to do with kernel. What kernel version are you running?

uname -a
Linux localhost.localdomain 3.12.0-0.rc3.git0.2.fc21.x86_64 #1 SMP Mon Sep 30 16:54:49 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
Comment 36 Mamoru TASAKA 2013-10-01 01:07:45 EDT
Well, no longer reproducible for me (i.e. even vlc now works)...
Not sure what actually "fixed" / "changed" the behavior of vlc
for me...

Now how do you think? Is it okay that I might close this bug
(although I am still unsure about the behavior of smplayer or vlc)?
Comment 37 Piruthiviraj Natarajan 2013-10-01 01:15:41 EDT
I would suggest Its better to close this bug. This one has wasted enough time for both of us already.

You have done an amazing job to work on this bug in Fedora and its the best support from fedora bugzilla ever for me.

Thanks for all your efforts :)
Comment 38 Piruthiviraj Natarajan 2013-10-07 11:18:14 EDT
The bug started to reappear again. Do you see the same behavior?
Comment 39 Mamoru TASAKA 2013-10-07 21:24:27 EDT
Would you be more specific?

- Please write in detail what you did (what media player you used,
  what config you have on both xscreensaver and the media player).
- Please attach the result of xscreensaver verbose mode.
- Also again try repeating "while true ; do sleep 30 ; xscreensaver-command -dea & xset dpms s reset &
Comment 40 Piruthiviraj Natarajan 2013-10-07 22:06:12 EDT
I used smplayer and I use XFCE. I did not change any config for .mplayer or xscreensaver. But still I am attaching the configs.
The screen consistently blanks every-time while playing the video through smplayer. The screen blanks even with the following command is running without smplayer running too. 
[freedom@rawhide ~]$ while true ; do sleep 30 ; xscreensaver-command -dea & xset dpms s reset & done
[1] 2189
[2] 2190
xscreensaver-command: not active: idle timer reset.

[1]-  Done                    xscreensaver-command -dea
[2]+  Done                    xset dpms s reset
[1] 2197
[2] 2198
xscreensaver-command: not active: idle timer reset.

[1]-  Done                    xscreensaver-command -dea
[2]+  Done                    xset dpms s reset
[1] 2212
[2] 2213
xscreensaver-command: not active: idle timer reset.

[1]-  Done                    xscreensaver-command -dea
[2]+  Done                    xset dpms s reset
[1] 2219
[2] 2220
xscreensaver-command: not active: idle timer reset.

[1]-  Done                    xscreensaver-command -dea
[2]+  Done                    xset dpms s reset
[1] 2225
[2] 2226
xscreensaver-command: not active: idle timer reset.
Comment 41 Piruthiviraj Natarajan 2013-10-07 22:07:45 EDT
Created attachment 809048 [details]
xscreensaver -verbose -log
Comment 42 Piruthiviraj Natarajan 2013-10-07 22:08:50 EDT
Created attachment 809049 [details]
.config for mplayer
Comment 43 Piruthiviraj Natarajan 2013-10-07 22:09:33 EDT
Created attachment 809050 [details]
.xscreensaver
Comment 44 Piruthiviraj Natarajan 2013-10-07 23:48:50 EDT
I found an interesting thing which may be relevant here. I found that in settings>session and startup>application autostart has two entries of xscreensaver with screensaver and xscreensaver-autostart and since then  I unchecked(removed) the xscreensaver-autostart option I am able to have xscreensaver work as expected, which means no blanking while playing video through smplayer.
Comment 45 Piruthiviraj Natarajan 2013-10-07 23:50:37 EDT
I also made sure xscreensaver was running after I unchecked xscreensaver-autostart option while playing the video.
Comment 46 Mamoru TASAKA 2013-10-09 23:45:05 EDT
(In reply to Piruthiviraj Natarajan from comment #44)
> I found an interesting thing which may be relevant here. I found that in
> settings>session and startup>application autostart has two entries of
> xscreensaver with screensaver and xscreensaver-autostart and since then  I
> unchecked(removed) the xscreensaver-autostart option I am able to have
> xscreensaver work as expected, which means no blanking while playing video
> through smplayer.

Well, if this issue still happens (i.e. enable both autostart menu,
repeatly executing "while true; do ...."), what does the following say?

$ ps auwwx | grep screensaver

Currently I have almost no clue to resolve this as I have no idea how
to reproduce this.
Comment 47 Mamoru TASAKA 2013-10-09 23:59:31 EDT
Ah.....

(In reply to Piruthiviraj Natarajan from comment #44)
> I found an interesting thing which may be relevant here. I found that in
> settings>session and startup>application autostart has two entries of
> xscreensaver with screensaver and xscreensaver-autostart and since then  I
> unchecked(removed) the xscreensaver-autostart option I am able to have
> xscreensaver work as expected, which means no blanking while playing video
> through smplayer.

(In reply to Piruthiviraj Natarajan from comment #41)
> Created attachment 809048 [details]
> xscreensaver -verbose -log

Okay, actually 2 xscreensaver is running, one is from xscreensaver.desktop (in xfce-session ) and one is from xscreensaver-autostart.desktop.

However xscreensaver-autostart.desktop has "OnlyShowIn=GNOME", which means
that by default "xscreensaver-autostart" is off by default on XFCE session.

Would you create a new fresh account and check if even on a fresh account 
both xscreensaver.desktop (from xfce-session) and 
xscreensaver-autostart.desktop (from xscreensaver-base) are enabled?
Comment 48 Piruthiviraj Natarajan 2013-10-10 04:55:08 EDT
Acutually I got impatient and reinstalled rawhide. But temporarily no issues until now with smplayer and vlc. Since I reinstalled I am not sure if this will help.

[bugzilla@localhost ~]$ ps auwwx | grep screensaver
bugzilla  4414  0.0  0.0 159140  2664 ?        S    13:47   0:00 xscreensaver -no-splash
bugzilla  4568  0.0  0.1 288052 14512 ?        S    13:48   0:00 xscreensaver-demo
bugzilla  6322  0.0  0.0 112972   984 pts/2    S+   14:22   0:00 grep --color=auto screensaver
[bugzilla@localhost ~]$
Comment 49 Mamoru TASAKA 2013-10-10 05:09:55 EDT
(In reply to Piruthiviraj Natarajan from comment #48)
> [bugzilla@localhost ~]$ ps auwwx | grep screensaver
> bugzilla  4414  0.0  0.0 159140  2664 ?        S    13:47   0:00
> xscreensaver -no-splash
> bugzilla  4568  0.0  0.1 288052 14512 ?        S    13:48   0:00
> xscreensaver-demo
> bugzilla  6322  0.0  0.0 112972   984 pts/2    S+   14:22   0:00 grep
> --color=auto screensaver
> [bugzilla@localhost ~]$

Well, this is expected behavior (i.e. _one_ xscreensaver is running),
and if currently bug does not seem reproducible, it is okay.
Comment 50 Piruthiviraj Natarajan 2013-11-29 22:06:34 EST
Actually I got this bug and since we have wasted too much time and not able to track it properly I quit using xscreensaver and moved to using mate-screensaver in mate DE. But when I returned to XFCE few days back I again got this bug and some how mplayer settings work, but VLC was constantly blanking and I found a post in the fedora forums as a workaround which seems to work for fedora and gentoo as well. I have no idea why this following solution works for VLC, maybe you would know.

http://forums.fedoraforum.org/showpost.php?p=1549825&postcount=20

 Create a file called /etc/X11/xorg.conf.d/00-system-dpms.conf and have the contents of the file as follows


Section "ServerFlags"
   Option "BlankTime" "0"
   Option "StandbyTime" "0"
   Option "SuspendTime" "0"
EndSection
Comment 51 Piruthiviraj Natarajan 2013-11-29 22:09:18 EST
Actually I got this bug again when I started using xscreensaver and in the  version 5.23 too and since we have wasted too much time and not able to track it properly I quit using xscreensaver and moved to using mate-screensaver in mate DE. But when I returned to XFCE few days back I again got this bug and some how mplayer settings worked with no screen blanking, but VLC was constantly blanking and I found a post in the fedora forums as a workaround which seems to work for fedora and gentoo as well. I have no idea why this following solution works for VLC, maybe you would know.

http://forums.fedoraforum.org/showpost.php?p=1549825&postcount=20

 Create a file called /etc/X11/xorg.conf.d/00-system-dpms.conf and have the contents of the file as follows


Section "ServerFlags"
   Option "BlankTime" "0"
   Option "StandbyTime" "0"
   Option "SuspendTime" "0"
EndSection
Comment 52 Mamoru TASAKA 2013-11-30 13:09:22 EST
Once closing as not a bug for xscreensaver.

Note You need to log in before you can comment on or make changes to this bug.