Bug 1013376 - SELinux is preventing /usr/bin/qemu-system-x86_64 from 'create' accesses on the rawip_socket .
SELinux is preventing /usr/bin/qemu-system-x86_64 from 'create' accesses on t...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
20
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:9ff1d87c2a94709f48c79fa13c2...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-29 13:49 EDT by Francisco de la Peña
Modified: 2014-02-09 19:35 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-30 08:46:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Francisco de la Peña 2013-09-29 13:49:37 EDT
Description of problem:
Using gnome-boxes
SELinux is preventing /usr/bin/qemu-system-x86_64 from 'create' accesses on the rawip_socket .

*****  Plugin catchall_boolean (89.3 confidence) suggests   ******************

If desea allow virt to use rawip
Then usted debe decir a SELinux sobre esto habilitando el booleano 'virt_use_rawip'.
Puede leer la página man de 'None' para más detalles.
Do
setsebool -P virt_use_rawip 1

*****  Plugin catchall (11.6 confidence) suggests   **************************

If cree que de manera predeterminada, qemu-system-x86_64 debería permitir acceso create sobre   rawip_socket.     
Then debería reportar esto como un error.
Puede generar un módulo de política local para permitir este acceso.
Do
permita el acceso momentáneamente executando:
# grep qemu-system-x86 /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                unconfined_u:system_r:svirt_t:s0:c563,c592
Target Context                unconfined_u:system_r:svirt_t:s0:c563,c592
Target Objects                 [ rawip_socket ]
Source                        qemu-system-x86
Source Path                   /usr/bin/qemu-system-x86_64
Port                          <Desconocido>
Host                          (removed)
Source RPM Packages           qemu-system-x86-1.6.0-8.fc20.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-83.fc20.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.11.1-libre.300.fc20.gnu.x86_64
                              #1 SMP Sun Sep 15 17:05:18 EDT 2013 x86_64 x86_64
Alert Count                   2
First Seen                    2013-09-29 10:52:53 CST
Last Seen                     2013-09-29 10:52:58 CST
Local ID                      445b871f-de65-483c-bcc0-87726bf6442d

Raw Audit Messages
type=AVC msg=audit(1380473578.61:811): avc:  denied  { create } for  pid=3873 comm="qemu-system-x86" scontext=unconfined_u:system_r:svirt_t:s0:c563,c592 tcontext=unconfined_u:system_r:svirt_t:s0:c563,c592 tclass=rawip_socket


type=SYSCALL msg=audit(1380473578.61:811): arch=x86_64 syscall=socket success=no exit=EACCES a0=2 a1=80002 a2=1 a3=3 items=0 ppid=1 pid=3873 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 ses=1 tty=(none) comm=qemu-system-x86 exe=/usr/bin/qemu-system-x86_64 subj=unconfined_u:system_r:svirt_t:s0:c563,c592 key=(null)

Hash: qemu-system-x86,svirt_t,svirt_t,rawip_socket,create

Additional info:
reporter:       libreport-2.1.7
hashmarkername: setroubleshoot
kernel:         3.11.1-libre.300.fc20.gnu.x86_64
type:           libreport

Potential duplicate: bug 1009433
Comment 1 Daniel Walsh 2013-09-30 08:46:00 EDT
*****  Plugin catchall_boolean (89.3 confidence) suggests   ******************

If desea allow virt to use rawip
Then usted debe decir a SELinux sobre esto habilitando el booleano 'virt_use_rawip'.
Puede leer la página man de 'None' para más detalles.
Do
setsebool -P virt_use_rawip 1
Comment 2 Rahul Sundaram 2014-02-09 17:12:29 EST
Why is this closed as not a bug?  I was merely using GNOME Boxes with nothing unusual.
Comment 3 Daniel Walsh 2014-02-09 19:35:45 EST
Since we do not want to allow virtual machines to be able to use rawip, we disable this by default.  VMs using Rawip could listen to other VMS on the network, which is something we are trying to prevent.  Turning on the boolean would fix your problem, but most VM's would never need this access.

Note You need to log in before you can comment on or make changes to this bug.