Bug 1013399 - [RFE]: Katello cmdline not to require '--org ORG' when only one organization is configured.
[RFE]: Katello cmdline not to require '--org ORG' when only one organization ...
Status: CLOSED WONTFIX
Product: Katello
Classification: Community
Component: Infrastructure (Show other bugs)
1.X
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Katello Bug Bin
Katello QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-29 18:40 EDT by Magnus Glantz
Modified: 2013-10-10 12:02 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-10 12:02:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Magnus Glantz 2013-09-29 18:40:39 EDT
Description of problem:
When using the katello cmdline tool, you often have to provide --org 'NAME_OF_ORG', even when you only have one organization configured. This is a pain when working a lot in the cmdline.

Version-Release number of selected component (if applicable):
1.4.8-1.git.4.c940d43.el6

How reproducible:
N/A

Steps to Reproduce:
N/A

Actual results:
For example:
# katello -u admin -p PASSWORD activation_key list --org ACME_Corporation

Expected results:
For example:
# katello -u admin -p PASSWORD activation_key list

Additional info:
If normal use of RHN Satellite 5 reflects normal Katello usage - people will usually not configure more than one organization.
Comment 1 Og Maciel 2013-09-29 20:38:25 EDT
You could use the "remember" option so that you don't have to keep typing the org name.

ex: katello -u admin -p admin client remember --option org --value $ORG
Comment 2 Mike McCune 2013-10-10 12:02:41 EDT
Closing as NOTABUG since there is a solution mentioned in comment #1

Note You need to log in before you can comment on or make changes to this bug.