Bug 1013408 - [su] In RHEL6.5-20130925.2 run "su $user -c cmd" return 132 (SIGILL)
[su] In RHEL6.5-20130925.2 run "su $user -c cmd" return 132 (SIGILL)
Status: CLOSED DUPLICATE of bug 996190
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: coreutils (Show other bugs)
6.5
All Linux
urgent Severity urgent
: rc
: ---
Assigned To: Ondrej Vasik
qe-baseos-daemons
: Regression
Depends On:
Blocks: 840898 993793
  Show dependency treegraph
 
Reported: 2013-09-29 20:09 EDT by Yin.JianHong
Modified: 2013-10-08 09:23 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-08 09:23:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yin.JianHong 2013-09-29 20:09:54 EDT
Description of problem:
In RHEL6.5-20130925.2 run "su $user -c cmd" return 132 (SIGILL)
run in RHEL6.4 it's OK.

Version-Release number of selected component (if applicable):
=> rel-eng/RHEL6.5-20130925.2 -> {http://download.devel.redhat.com/rel-eng/RHEL6.5-20130925.2/6.5/Server/x86_64/os/Packages}
coreutils-8.4-28.el6.x86_64.rpm
coreutils-libs-8.4-28.el6.x86_64.rpm
policycoreutils-2.0.83-19.37.el6.x86_64.rpm
policycoreutils-gui-2.0.83-19.37.el6.x86_64.rpm
policycoreutils-newrole-2.0.83-19.37.el6.x86_64.rpm
policycoreutils-python-2.0.83-19.37.el6.x86_64.rpm
policycoreutils-sandbox-2.0.83-19.37.el6.x86_64.rpm
kernel-2.6.32-420.el6.x86_64.rpm

How reproducible:
100% in special case

Steps to Reproduce:
1. run beaker test case /CoreOS/nfs-utils/initscript:
   bkr workflow-simple --task=/CoreOS/nfs-utils/initscript --distro=RHEL6.5-20130925.2 --whiteboard " xxx " 
2.
3.

Actual results:
{19:33:02 root@ /tmp/tmp.4mKUAJBBfe}# su testuserqa -c 'service nfs stop'
:: [   FAIL   ] :: Insufficient rights, stopping service under nonprivileged user must fail (Expected 4, got 132)   <<<---SIGILL

Expected results:
{19:41:07 root@ /tmp/tmp.70g7YRW5uE}# su testuserqa -c 'service nfs stop'
:: [   PASS   ] :: Insufficient rights, stopping service under nonprivileged user must fail (Expected 4, got 4)

Additional info:
  run in RHEL6.4 is OK;
Comment 5 Ondrej Vasik 2013-10-08 06:56:50 EDT
Most probably duplicate of FailedQA for #996190.
Comment 6 Ondrej Vasik 2013-10-08 09:23:44 EDT
Closing duplicate, as I moved the culprit back to assigned with blocker+.

*** This bug has been marked as a duplicate of bug 996190 ***

Note You need to log in before you can comment on or make changes to this bug.