Bug 1013410 - Update the translations build to match the english functionality
Update the translations build to match the english functionality
Status: CLOSED CURRENTRELEASE
Product: PressGang CCMS
Classification: Community
Component: DocBook-builder (Show other bugs)
1.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 1.9
Assigned To: Lee Newson
Misha H. Ali
:
: 1121862 (view as bug list)
Depends On:
Blocks: 1036976
  Show dependency treegraph
 
Reported: 2013-09-29 21:05 EDT by Lee Newson
Modified: 2014-08-31 21:20 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-31 21:20:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lee Newson 2013-09-29 21:05:45 EDT
Currently a reasonable amount of work has been done on the english index page for the docbuilder, but none of this has been carried across to the translations index pages. The missing functionality right now is:

- The ability to filter on: Topic Ids, Obsolete Specs and Frozen specs.
- The ability to download the built book as a ZIP.
- The ability to easily see what builds have failed/succeeded.
- The overlay that shows details about each topic (this should probably be excluded since unless we could provide data from Zanata then this may not be of much help to the translators).

Future Recommendations:

Ensure that when updating the core/english functionality it is replicated to the translation pages as well.
Comment 1 Matthew Casperson 2014-01-20 18:17:21 EST
Committed changes to build_books.sh in devel that will build the HTML and remarks versions of the books.
Comment 2 Lee Newson 2014-07-22 01:33:36 EDT
*** Bug 1121862 has been marked as a duplicate of this bug. ***
Comment 3 Matthew Casperson 2014-07-24 17:36:21 EDT
As noted in BZ#1117541, the index pages currently display all translated books as available because this script doesn't provide information on whether the books have built or failed.
Comment 4 Lee Newson 2014-07-31 20:14:50 EDT
- The ability to filter on: Topic Ids, Obsolete Specs and Frozen specs.

We should not show the obsolete or frozen options as that information is of no use to translators.
Comment 5 Lee Newson 2014-08-01 02:01:58 EDT
Fixed in 1.9-SNAPSHOT (see the devel-rewrite branch).

The docbuilder-translation shell script has been removed and replaced by a node.js application that does pretty much the same thing.

Additionally a lot of the config has been cleaned up so that constants don't exist, assumptions about the protocol and port are no longer done, etc... So in future src/config.js will be the only file that needs altering by the administrator.
Comment 7 Misha H. Ali 2014-08-21 01:50:31 EDT
Tried for JP in chrome.

Translation builds show build success/failure (graphic), last build time (mouse over graphic), options of remarks build, ZIP download and the filter option available when clicked.

Note You need to log in before you can comment on or make changes to this bug.