Bug 1013466 - SELinux is preventing /usr/bin/wine-preloader from 'mmap_zero' accesses on the memprotect.
Summary: SELinux is preventing /usr/bin/wine-preloader from 'mmap_zero' accesses on th...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 20
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Paul Moore
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:7774f653e3da691a306c93c01e6...
: 1047417 (view as bug list)
Depends On:
Blocks: 1070827 1070859
TreeView+ depends on / blocked
 
Reported: 2013-09-30 07:11 UTC by s-worm
Modified: 2014-09-10 17:01 UTC (History)
28 users (show)

Fixed In Version: kernel-3.14.2-200.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1070827 1070859 (view as bug list)
Environment:
Last Closed: 2014-05-01 22:30:28 UTC
Type: ---


Attachments (Terms of Use)

Description s-worm 2013-09-30 07:11:59 UTC
Description of problem:
starting Mikrotik winebox.exe
SELinux is preventing /usr/bin/wine-preloader from 'mmap_zero' accesses on the memprotect .

*****  Plugin mmap_zero (53.1 confidence) suggests   *************************

If вы считаете, что /usr/bin/wine-preloader не должен выполнять mmap при недостатке памяти в ядре.
Then возможно, вы подверглись хакерской атаке. Это обращение представляет риск безопасности.
Do
о проблеме сообщите администратору.

*****  Plugin catchall_boolean (42.6 confidence) suggests   ******************

If вы хотите выполнить следующее: allow mmap to low allowed
Then you must tell SELinux about this by enabling the 'mmap_low_allowed' boolean.
Дополнительная документация на 'None' ман странице.
Do
setsebool -P mmap_low_allowed 1

*****  Plugin catchall (5.76 confidence) suggests   **************************

If вы считаете, что wine-preloader следует разрешить доступ mmap_zero к  memprotect по умолчанию.
Then рекомендуется создать отчет об ошибке.
Чтобы разрешить доступ, можно создать локальный модуль политики.
Do
чтобы разрешить доступ, выполните:
# grep wine-preloader /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1
                              023
Target Context                unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1
                              023
Target Objects                 [ memprotect ]
Source                        wine-preloader
Source Path                   /usr/bin/wine-preloader
Port                          <Неизвестно>
Host                          (removed)
Source RPM Packages           wine-core-1.7.2-1.fc20.i686
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-83.fc20.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.11.1-300.fc20.x86_64 #1 SMP Sat
                              Sep 14 15:01:23 UTC 2013 x86_64 x86_64
Alert Count                   4
First Seen                    2013-09-30 11:09:58 MSK
Last Seen                     2013-09-30 11:10:12 MSK
Local ID                      9f7fab06-d4d9-4eeb-8961-e1eeb8b2b5d7

Raw Audit Messages
type=AVC msg=audit(1380525012.640:637): avc:  denied  { mmap_zero } for  pid=2647 comm="wine-preloader" scontext=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 tcontext=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 tclass=memprotect


type=SYSCALL msg=audit(1380525012.640:637): arch=i386 syscall=chmod success=no exit=EACCES a0=ffeee78c a1=10000 a2=ffeee78c a3=5a items=0 ppid=1 pid=2647 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 ses=1 tty=(none) comm=wine-preloader exe=/usr/bin/wine-preloader subj=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 key=(null)

Hash: wine-preloader,unconfined_t,unconfined_t,memprotect,mmap_zero

Additional info:
reporter:       libreport-2.1.7
hashmarkername: setroubleshoot
kernel:         3.11.1-300.fc20.x86_64
type:           libreport

Potential duplicate: bug 665665

Comment 1 Daniel Walsh 2013-09-30 12:51:36 UTC
Did you read the alert?


*****  Plugin mmap_zero (53.1 confidence) suggests   *************************

If вы считаете, что /usr/bin/wine-preloader не должен выполнять mmap при недостатке памяти в ядре.
Then возможно, вы подверглись хакерской атаке. Это обращение представляет риск безопасности.
Do
о проблеме сообщите администратору.

*****  Plugin catchall_boolean (42.6 confidence) suggests   ******************

If вы хотите выполнить следующее: allow mmap to low allowed
Then you must tell SELinux about this by enabling the 'mmap_low_allowed' boolean.
Дополнительная документация на 'None' ман странице.
Do
setsebool -P mmap_low_allowed 1

http://danwalsh.livejournal.com/66379.html

Comment 2 Dan Mossor [danofsatx] 2013-12-29 22:32:19 UTC
re-opening in accordance with the SELinux Alert Browser, wherein it states: 

If you believe that wine-preloader should be allowed mmap_zero access on the memprotect by default.

You should report this as a bug.


I have generated the local policy module for this error on every system I maintain, but it remains that it needs to be generated for anyone running wine-preloader.

Bug is present in selinux-policy-3.12.1-106.fc20 and selinux-policy-3.13.1-10.fc21

Comment 3 Daniel Walsh 2014-01-02 17:31:41 UTC
BTW Did the application work properly even with this avc?

Comment 4 Dan Mossor [danofsatx] 2014-01-02 20:36:18 UTC
I forgot to note that part. As far as I can determine, the application does work properly even with the AVC denial.  I see no other issues with the app after it is started and running, other than glitches that may just be bad code on the application's part - but nothing blocking basic usability.

Comment 5 Anqas 2014-01-06 11:45:55 UTC
Description of problem:
nrg2iso free ware running on wine

Additional info:
reporter:       libreport-2.1.10
hashmarkername: setroubleshoot
kernel:         3.12.5-302.fc20.x86_64
type:           libreport

Comment 6 Vinicius Reis 2014-01-08 03:49:47 UTC
Description of problem:
Try to exec some autorun applications on wine. In this case, Dungeon Keeper 2

Additional info:
reporter:       libreport-2.1.10
hashmarkername: setroubleshoot
kernel:         3.12.6-300.fc20.x86_64
type:           libreport

Comment 7 dgwaafc 2014-01-13 21:06:51 UTC
Description of problem:
on opening wine installer - message was generated

Additional info:
reporter:       libreport-2.1.11
hashmarkername: setroubleshoot
kernel:         3.12.6-300.fc20.x86_64
type:           libreport

Comment 8 Fedora Update System 2014-01-13 22:54:44 UTC
selinux-policy-3.12.1-116.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/selinux-policy-3.12.1-116.fc20

Comment 9 Fedora Update System 2014-01-15 05:56:24 UTC
Package selinux-policy-3.12.1-116.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing selinux-policy-3.12.1-116.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-0806/selinux-policy-3.12.1-116.fc20
then log in and leave karma (feedback).

Comment 10 Fedora Update System 2014-01-16 07:08:55 UTC
selinux-policy-3.12.1-116.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Benjamin Ariel Nava Martinez 2014-01-24 07:42:00 UTC
Problem persists in selinux-policy-3.12.1-119.fc20 on fedora x86_64
It happens whenever I try to launch a Windows app, no matter what app it is.
I would gladly upload any info required.

Comment 12 Anton 2014-01-27 17:22:44 UTC
The same problem on my system with selinux-policy-3.12.1-119.fc20.noarch.
Any app I try to run through the wine lead to the alert

"SELinux is preventing /usr/bin/wine-preloader from mmap_zero access on the memprotect"

Actually apps work fine after and alert is an annoying warning.

Comment 13 Robert Hancock 2014-02-13 20:33:22 UTC
This bug does NOT appear to be fixed and should be reopened. Using selinux-policy-3.12.1-122.fc20.

Comment 14 Robert Hancock 2014-02-13 20:34:44 UTC
Also note that there is an SELinux boolean, wine_mmap_zero_ignore, that is supposed to shut up these warnings, but it does not appear to work in current versions.

Comment 15 Daniel Walsh 2014-02-14 17:48:14 UTC
Could you attach the current AVC you are seeing?

Comment 16 Benjamin Ariel Nava Martinez 2014-02-14 19:48:08 UTC
This is the complete alert + suggestion (selinux-policy-3.12.1-122.fc20):

SELinux is preventing /usr/bin/wine-preloader from mmap_zero access on the memprotect .

*****  Plugin mmap_zero (53.1 confidence) suggests   *************************

If no cree que /usr/bin/wine-preloader debería necesitar realizar un mmap sobre la baja memoria en el kernel.
Then podría estar siendo víctima de un ataque, este es un acceso muy peligroso.
Do
póngase en contacto con su administrador de seguridad y reporte este problema.

*****  Plugin catchall_boolean (42.6 confidence) suggests   ******************

If desea allow mmap to low allowed
Then usted debe decir a SELinux sobre esto habilitando el booleano 'mmap_low_allowed'.
Puede leer la página man de 'None' para más detalles.
Do
setsebool -P mmap_low_allowed 1

*****  Plugin catchall (5.76 confidence) suggests   **************************

If cree que de manera predeterminada, wine-preloader debería permitir acceso mmap_zero sobre   memprotect.     
Then debería reportar esto como un error.
Puede generar un módulo de política local para permitir este acceso.
Do
permita el acceso momentáneamente executando:
# grep wine-preloader /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1
                              023
Target Context                unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1
                              023
Target Objects                 [ memprotect ]
Source                        wine-preloader
Source Path                   /usr/bin/wine-preloader
Port                          <Unknown>
Host                          c700.personal
Source RPM Packages           wine-core-1.7.8-1.fc20.i686
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-122.fc20.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     c700.personal
Platform                      Linux c700.personal 3.12.10-300.fc20.x86_64 #1 SMP
                              Thu Feb 6 22:11:48 UTC 2014 x86_64 x86_64
Alert Count                   108
First Seen                    2014-01-30 19:27:26 CST
Last Seen                     2014-02-14 13:46:41 CST
Local ID                      36ac8fa3-611c-4711-a112-3fb3dd0dc5cd

Raw Audit Messages
type=AVC msg=audit(1392407201.455:438): avc:  denied  { mmap_zero } for  pid=16331 comm="wine-preloader" scontext=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 tcontext=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 tclass=memprotect


type=SYSCALL msg=audit(1392407201.455:438): arch=i386 syscall=chmod success=no exit=EPERM a0=ffa5338c a1=10000 a2=ffa5338c a3=5a items=0 ppid=16311 pid=16331 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 ses=1 tty=pts0 comm=wine-preloader exe=/usr/bin/wine-preloader subj=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 key=(null)

Hash: wine-preloader,unconfined_t,unconfined_t,memprotect,mmap_zero

Comment 17 Daniel Walsh 2014-02-14 20:38:30 UTC
Well this is actually a kernel issue. The kernel should not be checking the mmap_zero check for SELinux at all, since it would be blocked by a DAC Check.

Paul do you know the bugzilla for this?

Comment 18 Paul Moore 2014-02-14 21:17:04 UTC
(In reply to Daniel Walsh from comment #17)
> Well this is actually a kernel issue. The kernel should not be checking the
> mmap_zero check for SELinux at all, since it would be blocked by a DAC Check.
> 
> Paul do you know the bugzilla for this?

BZ #1047417

I haven't had the chance to fix it yet, but it is on my todo list.

Comment 19 Andreas Tunek 2014-02-25 19:05:02 UTC
Why is this bug closed, shouldn't it be open? I got the problem today....

Comment 20 Paul Moore 2014-02-26 22:12:25 UTC
*** Bug 1047417 has been marked as a duplicate of this bug. ***

Comment 21 Paul Moore 2014-02-26 22:20:09 UTC
A bit of a recap from BZ #1047417 ... the suspected cause is that the SELinux/MAC check is happening before the normal DAC check, causing an unnecessary AVC denial.  Dan and Eric believe the correct solution is to move the LSM hook below the DAC check, which is what I'm looking into now.

Comment 22 Paul Moore 2014-02-27 14:38:11 UTC
Patch posted upstream:

 * http://marc.info/?l=selinux&m=139351174702148&w=2

Comment 23 Peter H. Jones 2014-03-01 23:47:49 UTC
Got it today:
"SELinux is preventing /usr/bin/wine-preloader from mmap_zero access on the memprotect .

*****  Plugin mmap_zero (53.1 confidence) suggests   *************************

If you do not think /usr/bin/wine-preloader should need to mmap low memory in the kernel.
Then you may be under attack by a hacker, this is a very dangerous access.
Do
contact your security administrator and report this issue.

*****  Plugin catchall_boolean (42.6 confidence) suggests   ******************

If you want to allow mmap to low allowed
Then you must tell SELinux about this by enabling the 'mmap_low_allowed' boolean.
You can read 'None' man page for more details.
Do
setsebool -P mmap_low_allowed 1

*****  Plugin catchall (5.76 confidence) suggests   **************************

If you believe that wine-preloader should be allowed mmap_zero access on the  memprotect by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep wine-preloader /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1
                              023
Target Context                unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1
                              023
Target Objects                 [ memprotect ]
Source                        wine-preloader
Source Path                   /usr/bin/wine-preloader
Port                          <Unknown>
Host                          localhost.localdomain
Source RPM Packages           wine-core-1.7.13-1.fc20.i686
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-122.fc20.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     localhost.localdomain
Platform                      Linux localhost.localdomain 3.13.5-200.fc20.x86_64
                              #1 SMP Mon Feb 24 16:51:35 UTC 2014 x86_64 x86_64
Alert Count                   9
First Seen                    2014-02-25 09:39:31 EST
Last Seen                     2014-03-01 18:29:01 EST
Local ID                      ae92c41c-4f55-42b3-b6eb-a3e2ba5c052f

Raw Audit Messages
type=AVC msg=audit(1393716541.378:400): avc:  denied  { mmap_zero } for  pid=1891 comm="wine-preloader" scontext=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 tcontext=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 tclass=memprotect


type=SYSCALL msg=audit(1393716541.378:400): arch=i386 syscall=chmod success=no exit=EACCES a0=fff287dc a1=10000 a2=fff287dc a3=5a items=0 ppid=1 pid=1891 auid=3000 uid=3000 gid=3000 euid=3000 suid=3000 fsuid=3000 egid=3000 sgid=3000 fsgid=3000 ses=1 tty=(none) comm=wine-preloader exe=/usr/bin/wine-preloader subj=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 key=(null)

Hash: wine-preloader,unconfined_t,unconfined_t,memprotect,mmap_zero
"

Comment 24 Peter H. Jones 2014-03-01 23:49:48 UTC
I didn't do anything with wine today.

Comment 25 evgeny 2014-03-02 03:28:45 UTC
Additional info:
reporter:       libreport-2.1.12
hashmarkername: setroubleshoot
kernel:         3.13.4-200.fc20.i686
type:           libreport

Comment 26 Josh Boyer 2014-03-04 18:40:20 UTC
(In reply to Paul Moore from comment #22)
> Patch posted upstream:
> 
>  * http://marc.info/?l=selinux&m=139351174702148&w=2

Seems as if the patch went over well.  I'll grab it for Fedora shortly.

Comment 27 Josh Boyer 2014-03-04 19:06:18 UTC
Fixed in git.

Comment 28 Paul Moore 2014-03-04 19:42:02 UTC
(In reply to Josh Boyer from comment #27)
> Fixed in git.

Thanks.

Comment 29 Peter H. Jones 2014-03-06 22:56:48 UTC
Got it today trying to open http://kojipkgs.fedoraproject.org//work/tasks/2932/6602932/livecd.log in a new tab in midori-0.5.7 under kernel-3.13.5-202.fc20.x86_64 and libreport-2.1.12-3.fc20.x86_64. I'll be watching for a selinux update. The details from AVC are:
"SELinux is preventing /usr/bin/wine-preloader from mmap_zero access on the memprotect .

*****  Plugin mmap_zero (53.1 confidence) suggests   *************************

If you do not think /usr/bin/wine-preloader should need to mmap low memory in the kernel.
Then you may be under attack by a hacker, this is a very dangerous access.
Do
contact your security administrator and report this issue.

*****  Plugin catchall_boolean (42.6 confidence) suggests   ******************

If you want to allow mmap to low allowed
Then you must tell SELinux about this by enabling the 'mmap_low_allowed' boolean.
You can read 'None' man page for more details.
Do
setsebool -P mmap_low_allowed 1

*****  Plugin catchall (5.76 confidence) suggests   **************************

If you believe that wine-preloader should be allowed mmap_zero access on the  memprotect by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep wine-preloader /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1
                              023
Target Context                unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1
                              023
Target Objects                 [ memprotect ]
Source                        wine-preloader
Source Path                   /usr/bin/wine-preloader
Port                          <Unknown>
Host                          localhost.localdomain
Source RPM Packages           wine-core-1.7.13-1.fc20.i686
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-122.fc20.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     localhost.localdomain
Platform                      Linux localhost.localdomain 3.13.5-202.fc20.x86_64
                              #1 SMP Mon Mar 3 19:08:00 UTC 2014 x86_64 x86_64
Alert Count                   3
First Seen                    2014-03-06 11:43:38 EST
Last Seen                     2014-03-06 17:40:42 EST
Local ID                      1459a3ac-766f-4f4e-a301-f26aedc8b36a

Raw Audit Messages
type=AVC msg=audit(1394145642.984:393): avc:  denied  { mmap_zero } for  pid=1661 comm="wine-preloader" scontext=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 tcontext=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 tclass=memprotect


type=SYSCALL msg=audit(1394145642.984:393): arch=i386 syscall=chmod success=no exit=EACCES a0=ffafb66c a1=10000 a2=ffafb66c a3=5a items=0 ppid=1 pid=1661 auid=3000 uid=3000 gid=3000 euid=3000 suid=3000 fsuid=3000 egid=3000 sgid=3000 fsgid=3000 ses=1 tty=(none) comm=wine-preloader exe=/usr/bin/wine-preloader subj=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 key=(null)

Hash: wine-preloader,unconfined_t,unconfined_t,memprotect,mmap_zero"

Comment 30 Peter H. Jones 2014-03-06 23:01:28 UTC
The tab I had tried to open was empty and would not refresh. I was able to go back to the http://koji.fedoraproject.org/koji/taskinfo?taskID=6602932 and open livec.log as a new tab without incident.

Comment 31 Peter H. Jones 2014-03-06 23:09:34 UTC
When I checked the Help/About menu item in the log window that had opened in comment 30, I was surprised to find that the application that midori had opened was in fact Notepad under wine! That explains the references to wine in the details messages. I suppose it would be better if midori were to use a linux binary display program to open .log (and presumably files with extensions unknown to midori). I'ld like to nominate "vi -r" for that.

Comment 32 Josh Boyer 2014-03-07 14:11:15 UTC
You should probably file a bug against midori if it's doing that.  This bug is fixing the kernel issue.

Comment 33 Fedora Update System 2014-03-07 22:52:19 UTC
kernel-3.13.6-100.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/kernel-3.13.6-100.fc19

Comment 34 Fedora Update System 2014-03-07 22:53:33 UTC
kernel-3.13.6-200.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/kernel-3.13.6-200.fc20

Comment 35 Fedora Update System 2014-03-09 04:39:33 UTC
Package kernel-3.13.6-100.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.13.6-100.fc19'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-3651/kernel-3.13.6-100.fc19
then log in and leave karma (feedback).

Comment 36 Fedora Update System 2014-03-10 06:50:32 UTC
kernel-3.13.6-200.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 37 Fedora Update System 2014-03-15 15:24:19 UTC
kernel-3.13.6-100.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 38 Mikhail 2014-04-23 17:02:12 UTC
This bug returned again with 3.14.1-200 kernel

Comment 39 Josh Boyer 2014-04-23 17:16:06 UTC
Thanks.  Inadvertently dropped the patch that fixed it with the 3.14 rebase.

Paul, this might be worth sending for 3.14.y stable.

Comment 40 Paul Moore 2014-04-23 20:56:09 UTC
(In reply to Josh Boyer from comment #39)
> Thanks.  Inadvertently dropped the patch that fixed it with the 3.14 rebase.
> 
> Paul, this might be worth sending for 3.14.y stable.

Since this is more of an annoyance and not really a critical bug, I'm not comfortable sending this to the stable folks.

Comment 41 Fedora Update System 2014-04-28 20:59:51 UTC
kernel-3.14.2-200.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/kernel-3.14.2-200.fc20

Comment 42 Fedora Update System 2014-04-30 04:10:21 UTC
Package kernel-3.14.2-200.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.14.2-200.fc20'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-5808/kernel-3.14.2-200.fc20
then log in and leave karma (feedback).

Comment 43 Fedora Update System 2014-05-01 22:30:28 UTC
kernel-3.14.2-200.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 44 sheepdestroyer 2014-09-10 17:01:30 UTC
Had this bug today while using pipelight, a wine wrapper of the windows flash plugin for Firefox
I am on fedora 20 with last updates


Note You need to log in before you can comment on or make changes to this bug.