Bug 1013504 - change kernel crashkernel=auto logic in RHEL7 to not scale memory based on physical memory present in the system
change kernel crashkernel=auto logic in RHEL7 to not scale memory based on ph...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: kexec-tools (Show other bugs)
7.0
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Baoquan He
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-30 04:50 EDT by Baoquan He
Modified: 2013-11-04 03:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-04 03:10:40 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Baoquan He 2013-09-30 04:50:32 EDT
Description of problem:
Currently in rhel7, cyclic mode is set by default in makedumpfile. We need to rewrite memory requirement bits section completely as now with cyclic mode we will not append 2 bits per physical page logic and it's obsolete.

That means we should change kernel crashkernel=auto logic in rhel7 to not scale memory based on physical memory present in the system.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Dave Young 2013-11-04 03:10:40 EST
Per discussion in kdump team. Let's keep the original logic, because for large memory machine adding a bit crash memory will probably improve the speed. Also there's could require more memory if multiple-cpu is supported in future.

Note You need to log in before you can comment on or make changes to this bug.