Bug 1013520 - Miss some console info to show status by using "ovirt-node-upgrade" to upgrade ovirt-node
Miss some console info to show status by using "ovirt-node-upgrade" to upgrad...
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-node (Show other bugs)
unspecified
Unspecified Unspecified
medium Severity medium
: ---
: 3.6.0
Assigned To: Douglas Schilling Landgraf
bugs@ovirt.org
node
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-30 05:30 EDT by haiyang,dong
Modified: 2016-02-10 14:39 EST (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-04-24 10:18:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Node
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description haiyang,dong 2013-09-30 05:30:01 EDT
Description of problem:
After check the console print info and /var/log/ovirt-node-upgrade.log, didn't find the information to
show Upgrade ovirt-node Completed or not.
so the users didn't know using  "ovirt-node-upgrade" to upgrade ovirt-node success or not 

[root@dhcp-9-230 data]# ovirt-node-upgrade --iso=ovirt-node-iso-3.1.0-0.999.999.20130927125518git5de7215.789.fc18.iso 
ovirt-node-upgrade.UpgradeTool: INFO     Temporary Directory is: /data/tmpTSrdu9
ovirt-node-upgrade.LockFile: INFO     Acquiring Lock
ovirt-node-upgrade.UpgradeTool: INFO     Running pre-upgrade hooks
ovirt-node-upgrade.UpgradeTool: INFO     pre-upgrade hooks completed
ovirt-node-upgrade.UpgradeTool: INFO     hooks: False

[root@dhcp-9-230 data]# cat /var/log/ovirt-node-upgrade.log 
2013-09-30 09:15:33,170 - INFO     - ovirt-node-upgrade - Temporary Directory is: /data/tmpTSrdu9
2013-09-30 09:15:33,171 - DEBUG    - ovirt-node-upgrade - {'iso_file': 'ovirt-node-iso-3.1.0-0.999.999.20130927125518git5de7215.789.fc18.iso', 'skip_existing_hooks': 'False', 'reboot': 0}
2013-09-30 09:15:33,172 - INFO     - ovirt-node-upgrade - Acquiring Lock
2013-09-30 09:15:33,172 - DEBUG    - ovirt-node-upgrade - ('mount', '-o', 'loop', 'ovirt-node-iso-3.1.0-0.999.999.20130927125518git5de7215.789.fc18.iso', '/live')
2013-09-30 09:15:33,408 - DEBUG    - ovirt-node-upgrade - []
2013-09-30 09:15:33,408 - DEBUG    - ovirt-node-upgrade - 
2013-09-30 09:15:33,409 - DEBUG    - ovirt-node-upgrade - ('mount', '-o', 'loop', '/live/LiveOS/squashfs.img', '/data/tmpTSrdu9/squashfs')
2013-09-30 09:15:33,427 - DEBUG    - ovirt-node-upgrade - []
2013-09-30 09:15:33,427 - DEBUG    - ovirt-node-upgrade - 
2013-09-30 09:15:33,428 - DEBUG    - ovirt-node-upgrade - ('mount', '-o', 'loop', '/data/tmpTSrdu9/squashfs/LiveOS/ext3fs.img', '/data/tmpTSrdu9/rootfs')
2013-09-30 09:15:33,529 - DEBUG    - ovirt-node-upgrade - []
2013-09-30 09:15:33,529 - DEBUG    - ovirt-node-upgrade - 
2013-09-30 09:15:33,559 - INFO     - ovirt-node-upgrade - Running pre-upgrade hooks
2013-09-30 09:15:33,565 - INFO     - ovirt-node-upgrade - pre-upgrade hooks completed
2013-09-30 09:15:33,565 - INFO     - ovirt-node-upgrade - hooks: False


Version-Release number of selected component (if applicable):
ovirt-node-iso-3.1.0-0.999.999.20130927125518git5de7215.789.fc18.iso


How reproducible:
100%
 
Steps to Reproduce:


Actual result:


Expect result:

Additional info:
Comment 1 Sandro Bonazzola 2014-03-04 04:22:46 EST
This is an automated message.
Re-targeting all non-blocker bugs still open on 3.4.0 to 3.4.1.
Comment 2 Sandro Bonazzola 2014-06-11 02:50:57 EDT
This is an automated message:
This bug has been re-targeted from 3.4.2 to 3.5.0 since neither priority nor severity were high or urgent. Please re-target to 3.4.3 if relevant.
Comment 3 Douglas Schilling Landgraf 2015-04-24 10:18:30 EDT
Hi,

This report is from 2013 and since this time the ovirt-node-upgrade tool has been improved and integrated to vdsm (we created a wrapper to vdsm-upgrade call it). From my tests (bellow), the tool is working as excepted in these days, so for now I will close this bug as current release. Hadong, fell free to re-open in case you have a different view.

Thanks!
 
# cat /etc/redhat-release 
oVirt Node Hypervisor 3.5 (0.999.201504231358.el6) (Edited)

Successfully scenario
=======================
# ovirt-node-upgrade --reboot=0 --iso=/data/updates/ovirt-node-image.iso 
ovirt-node-upgrade.UpgradeTool: INFO     Temporary Directory is: /data/tmpw_B0oq
ovirt-node-upgrade.LockFile: INFO     Acquiring Lock
ovirt-node-upgrade.UpgradeTool: INFO     Running pre-upgrade hooks
ovirt-node-upgrade.UpgradeTool: INFO     Running: 01-vdsm
ovirt-node-upgrade.UpgradeTool: INFO     Running: 03-persist-multipath-wwids
ovirt-node-upgrade.UpgradeTool: INFO     pre-upgrade hooks completed
ovirt-node-upgrade.UpgradeTool: INFO     Running pre-upgrade hooks
ovirt-node-upgrade.UpgradeTool: INFO     Running: 01-vdsm
ovirt-node-upgrade.UpgradeTool: INFO     Running: 03-persist-multipath-wwids
ovirt-node-upgrade.UpgradeTool: INFO     pre-upgrade hooks completed
ovirt-node-upgrade.UpgradeTool: INFO     hooks: False
ovirt-node-upgrade.UpgradeTool: INFO     Installing Bootloader
ovirt-node-upgrade.UpgradeTool: INFO     Running post-upgrade hooks
ovirt-node-upgrade.UpgradeTool: INFO     Running: 01-sanlock-check
ovirt-node-upgrade.UpgradeTool: INFO     post-upgrade hooks completed
ovirt-node-upgrade.UpgradeTool: INFO     Running post-upgrade hooks
ovirt-node-upgrade.UpgradeTool: INFO     Running: 01-sanlock-check
ovirt-node-upgrade.UpgradeTool: INFO     post-upgrade hooks completed
ovirt-node-upgrade.UpgradeTool: INFO     Upgrade Completed 
ovirt-node-upgrade.UpgradeTool: INFO     Cleaning up temporary directory

I can see the "Upgrade Completed" and seems accurate since there is no issue in the upgrade.


Scenario of "issue"
======================
# ovirt-node-upgrade --reboot=0 --iso=/data/updates/ovirt-node-image.iso 
ovirt-node-upgrade.UpgradeTool: INFO     Temporary Directory is: /data/tmpN4jcMU
Traceback (most recent call last):
  File "/usr/sbin/ovirt-node-upgrade", line 383, in <module>
    u.run()
  File "/usr/sbin/ovirt-node-upgrade", line 338, in run
    raise RuntimeError("Previous upgrade completed, you must reboot")
RuntimeError: Previous upgrade completed, you must reboot

Note You need to log in before you can comment on or make changes to this bug.