Bug 1013557 - Second host installation fails on "Invalid CPU type"
Second host installation fails on "Invalid CPU type"
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-hosted-engine-setup (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity urgent
: ---
: 3.3.0
Assigned To: Sandro Bonazzola
Leonid Natapov
integration
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-30 06:38 EDT by Leonid Natapov
Modified: 2015-09-22 09 EDT (History)
5 users (show)

See Also:
Fixed In Version: ovirt-hosted-engine-setup-1.0.0-0.5.beta1.el6ev
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 11:53:56 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 19681 None None None Never
oVirt gerrit 19688 None None None Never

  None (edit)
Description Leonid Natapov 2013-09-30 06:38:27 EDT
Please indicate a pingable gateway IP address: 10.35.109.254
 The following CPU types are supported by this host:
- model_Conroe: Intel Conroe Family
[ ERROR ] Failed to execute stage 'Environment customization': Invalid CPU type specified: None
[ INFO  ] Stage: Clean up
[ INFO  ] Stage: Pre-termination
[ INFO  ] Stage: Termination

the log file says the following:

2013-09-30 11:38:18 DEBUG otopi.plugins.otopi.dialog.human dialog.__logString:215 DIALOG:SEND                 The following CPU types are supported by this host:
2013-09-30 11:38:18 DEBUG otopi.plugins.otopi.dialog.human dialog.__logString:215 DIALOG:SEND                    - model_Conroe: Intel Conroe Family
2013-09-30 11:38:18 DEBUG otopi.context context._executeMethod:137 method exception
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/otopi/context.py", line 127, in _executeMethod
    method['method']()
  File "/usr/share/ovirt-hosted-engine-setup/scripts/../plugins/ovirt-hosted-engine-setup/vdsmd/cpu.py", line 174, in _customization
    ohostedcons.VDSMEnv.VDSM_CPU
RuntimeError: Invalid CPU type specified: None
2013-09-30 11:38:18 ERROR otopi.context context._executeMethod:146 Failed to execute stage 'Environment customization': Invalid CPU type specified: None
Comment 1 Sandro Bonazzola 2013-09-30 09:42:05 EDT
patch merged upstream master and 1.0 branch
Comment 3 Leonid Natapov 2013-10-17 06:43:38 EDT
fixed. ovirt-hosted-engine-setup-1.0.0-0.5.2.beta1.local.el6.noarch
Comment 4 Charlie 2013-11-27 20:19:19 EST
This bug is currently attached to errata RHBA-2013:15257. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to 
minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 5 Sandro Bonazzola 2013-12-05 05:41:19 EST
hosted engine is a new package, does not need errata for specific bugs during its development.
Comment 6 errata-xmlrpc 2014-01-21 11:53:56 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0083.html

Note You need to log in before you can comment on or make changes to this bug.