Bug 1013563 - Error while monitoring engine: Could not start sanlock because of wrong service path in sudoers file
Error while monitoring engine: Could not start sanlock because of wrong servi...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-hosted-engine-ha (Show other bugs)
unspecified
Unspecified Unspecified
urgent Severity urgent
: ---
: 3.3.0
Assigned To: Sandro Bonazzola
Leonid Natapov
integration
: Reopened
: 1018706 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-30 06:47 EDT by Leonid Natapov
Modified: 2014-01-21 11:50 EST (History)
6 users (show)

See Also:
Fixed In Version: ovirt-hosted-engine-ha-0.1.0-0.3.1.beta1.el6ev
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 11:50:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 19772 None None None Never
oVirt gerrit 20164 None None None Never

  None (edit)
Description Leonid Natapov 2013-09-30 06:47:04 EDT
/etc/sudoers.d/60_ovirt-ha had /usr/sbin/service as hardcoded path and the path is different on different OS.

For example it's fin for Fedora but I have RHEL 6.5 and it's in  /sbin/service not /usr/sbin/services 
---------------
MainThread::ERROR::2013-09-30 12:20:50,461::hosted_engine::326::HostedEngine::(_cond_start_service) Starting sanlock
MainThread::WARNING::2013-09-30 12:20:56,014::hosted_engine::238::HostedEngine::(start_monitoring) Error while monitoring engine: Could not start sanlock: sudo: no tty present and no askpass program specified

MainThread::WARNING::2013-09-30 12:20:56,015::hosted_engine::241::HostedEngine::(start_monitoring) Unexpected error
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/ovirt_hosted_engine_ha/agent/hosted_engine.py", line 228, in start_monitoring
    self._initialize_sanlock()
  File "/usr/lib/python2.6/site-packages/ovirt_hosted_engine_ha/agent/hosted_engine.py", line 351, in _initialize_sanlock
    self._cond_start_service('sanlock')
  File "/usr/lib/python2.6/site-packages/ovirt_hosted_engine_ha/agent/hosted_engine.py", line 335, in _cond_start_service
    .format(service_name, res[1]))
Exception: Could not start sanlock: sudo: no tty present and no askpass program specified
Comment 1 Doron Fediuck 2013-09-30 09:57:16 EDT
Sandro is this handled by the setup?
Please check if related to RHEL 6.5.
Comment 3 Sandro Bonazzola 2013-10-01 05:42:25 EDT
(In reply to Doron Fediuck from comment #1)
> Sandro is this handled by the setup?
> Please check if related to RHEL 6.5.

No it's not handled by setup, it's provided by ha package.
It's a packaging issue: the configure script should detect `service` path and configure the sudoers file accordingly to that path.
Comment 4 Sandro Bonazzola 2013-10-01 05:44:40 EDT
Reassigning to Greg.
Greg if you have more urgent issues to fix, I can take care of it tomorrow.
Comment 6 Sandro Bonazzola 2013-10-04 03:09:57 EDT
patch merged upstream master
Comment 8 Sandro Bonazzola 2013-10-14 05:18:48 EDT
It seems that built package still have this issue. Need to figure out why.
Comment 9 Sandro Bonazzola 2013-10-14 05:19:51 EDT
*** Bug 1018706 has been marked as a duplicate of this bug. ***
Comment 10 Greg Padgett 2013-10-14 11:09:28 EDT
Merged Change-Id: I1e069cefbd55a4aa7a85abd48beded57846ce78f
Comment 11 Leonid Natapov 2013-11-04 03:40:08 EST
fixed.
Comment 12 Charlie 2013-11-27 20:42:00 EST
This bug is currently attached to errata RHEA-2013:15591. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to 
minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 13 Sandro Bonazzola 2013-12-05 05:57:58 EST
hosted engine is a new package, does not need errata for specific bugs during its development.
Comment 14 errata-xmlrpc 2014-01-21 11:50:13 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0080.html

Note You need to log in before you can comment on or make changes to this bug.