Bug 1013565 - virtio-blk Win7 guest fail to create partition with prewhql-72 driver
virtio-blk Win7 guest fail to create partition with prewhql-72 driver
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virtio-win (Show other bugs)
7.0
Unspecified Unspecified
high Severity high
: rc
: 7.0
Assigned To: Vadim Rozenfeld
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-30 06:48 EDT by Xiaoqing Wei
Modified: 2014-08-10 14:01 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-10 14:01:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
pic (186.70 KB, image/png)
2013-09-30 06:48 EDT, Xiaoqing Wei
no flags Details
guest pic (111.13 KB, image/png)
2013-12-05 03:00 EST, Xiaoqing Wei
no flags Details

  None (edit)
Description Xiaoqing Wei 2013-09-30 06:48:38 EDT
Created attachment 805109 [details]
pic

Description of problem:

virtio-blk Win7 guest fail to create partition with prewhql-72 driver

Version-Release number of selected component (if applicable):
virtio-win-prewhql-72

How reproducible:
1/10

Steps to Reproduce:
1./home/pc/staf-kvm-devel/autotest-devel/client/tests/virt/qemu/qemu -monitor stdio \
    -S \
    -name 'virt-tests-vm1' \
    -nodefaults \
    -chardev socket,id=qmp_id_qmpmonitor1,path=/tmp/monitor-qmpmonitor1-20130930-183339-83VXKXBo,server,nowait \
    -mon chardev=qmp_id_qmpmonitor1,mode=control \
    -chardev socket,id=serial_id_serial1,path=/tmp/serial-serial1-20130930-183339-83VXKXBo,server,nowait \
    -device isa-serial,chardev=serial_id_serial1 \
    -chardev socket,id=seabioslog_id_20130930-183339-83VXKXBo,path=/tmp/seabios-20130930-183339-83VXKXBo,server,nowait \
    -device isa-debugcon,chardev=seabioslog_id_20130930-183339-83VXKXBo,iobase=0x402 \
    -device ich9-usb-uhci1,id=usb1,bus=pci.0,addr=0x4 \
    -drive file='/home/pc/staf-kvm-devel/autotest-devel/client/tests/virt/shared/data/images/win7-32-virtio.qcow2',index=0,if=none,id=drive-virtio-disk1,media=disk,cache=unsafe,snapshot=off,format=qcow2,aio=native \
    -device virtio-blk-pci,bus=pci.0,addr=0x5,drive=drive-virtio-disk1,bootindex=0 \
    -device virtio-net-pci,netdev=idpLx4er,mac='9a:f1:f2:f3:f4:f5',bus=pci.0,addr=0x3,id='idi33H61' \
    -netdev tap,id=idpLx4er,vhost=on \
    -m 2048 \
    -smp 2,maxcpus=2,cores=1,threads=1,sockets=2 \
    -cpu 'Opteron_G5',hv_relaxed \
    -M pc \
    -drive file='/home/pc/staf-kvm-devel/autotest-devel/client/tests/virt/shared/data/isos/ISO/Windows7/en_windows_7_ultimate_with_sp1_x86_dvd_u_677460.iso',index=1,if=none,id=drive-ide0-0-0,media=cdrom,format=raw \
    -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0 \
    -drive file='/home/pc/staf-kvm-devel/autotest-devel/client/tests/virt/shared/data/isos/windows/winutils.iso',index=2,if=none,id=drive-ide0-0-1,media=cdrom,format=raw \
    -device ide-drive,bus=ide.0,unit=1,drive=drive-ide0-0-1 \
    -drive file='/home/pc/staf-kvm-devel/autotest-devel/client/tests/virt/shared/data/isos/windows/virtio-win.latest_prewhql.iso',index=3,if=none,id=drive-ide0-1-0,media=cdrom,format=raw \
    -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0 \
    -drive file='/home/pc/staf-kvm-devel/autotest-devel/client/tests/virt/shared/data/images/win7-32/answer.vfd',if=none,id=fdc0-0-0,media=disk,readonly=off,format=raw \
    -global isa-fdc.driveA=fdc0-0-0 \
    -device usb-tablet,id=usb-tablet1,bus=usb1.0,port=1 \
    -vnc :10 \
    -vga std \
    -rtc base=localtime,clock=host,driftfix=slew  \
    -boot order=cdn,once=d,menu=off  \
    -enable-kvm

2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 Vadim Rozenfeld 2013-09-30 08:53:24 EDT
Does it happen during unattended install only?
Thanks,
Vadim.
Comment 3 Xiaoqing Wei 2013-10-01 12:23:43 EDT
(In reply to Vadim Rozenfeld from comment #2)
> Does it happen during unattended install only?
> Thanks,
> Vadim.

For now, Yes, I only met it on unattended_install,

Regards,
Xiaoqing.
Comment 4 Vadim Rozenfeld 2013-10-01 18:34:44 EDT
Thanks Xiaoqing.

Could you please post the unattended installation file?

Vadim.
Comment 6 RHEL Product and Program Management 2013-10-13 21:52:02 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 7 Vadim Rozenfeld 2013-10-14 02:00:14 EDT
Hi Xiaoqing,
Do you create a new image every time or reuse an existing one?
Thanks,
Vadim.
Comment 8 Xiaoqing Wei 2013-10-14 02:20:43 EDT
(In reply to Vadim Rozenfeld from comment #7)
> Hi Xiaoqing,
> Do you create a new image every time or reuse an existing one?
> Thanks,
> Vadim.

Hi Vadim,

all images were newly created before vm booting.

Regards,
Xiaoqing
Comment 9 Xiaoqing Wei 2013-12-05 03:00:33 EST
Created attachment 833035 [details]
guest pic

Met on Win2008-64
Error code: 0x80300025
Comment 11 Ronen Hod 2014-03-25 06:56:22 EDT
Looks like a specific problem with the unattended install.
Comment 13 Ronen Hod 2014-08-07 03:58:35 EDT
Xiaoqing Wei,
Does the problem still exist?
Comment 14 Xiaoqing Wei 2014-08-08 01:03:26 EDT
(In reply to Ronen Hod from comment #13)
> Xiaoqing Wei,
> Does the problem still exist?

no, I didn't met this for a while.
Comment 15 Ronen Hod 2014-08-10 14:01:10 EDT
(In reply to Xiaoqing Wei from comment #14)
> (In reply to Ronen Hod from comment #13)
> > Xiaoqing Wei,
> > Does the problem still exist?
> 
> no, I didn't met this for a while.

Thanks. Closing it for now.

Note You need to log in before you can comment on or make changes to this bug.