Bug 1013590 - Repo Discovery: when no previous product exists in org, the radio button should default to New Product
Repo Discovery: when no previous product exists in org, the radio button shou...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.0.2
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: Eric Helms
Sachin Ghai
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-30 08:02 EDT by Kedar Bidarkar
Modified: 2014-07-02 10:05 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-02 10:05:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
In discovery repo when no prd, radio button should default to new product (58.47 KB, image/png)
2013-09-30 08:02 EDT, Kedar Bidarkar
no flags Details
'New Product' radio button is selected on repo discovery (35.75 KB, image/png)
2014-06-09 06:01 EDT, Sachin Ghai
no flags Details

  None (edit)
Description Kedar Bidarkar 2013-09-30 08:02:08 EDT
Created attachment 805158 [details]
In discovery repo when no prd, radio button  should default to new product

Description of problem:

If no previous products exists while discovering repo, it should default to New Product and should disable the selection of "existing product" radio button.

Version-Release number of selected component (if applicable):
Satellite-6.0.2-RHEL-6-20130925.0

How reproducible:
Try creating repo via repo-discovery, in an org without any prod/provider.

Steps to Reproduce:
1.
2.
3.

Actual results:

Throws error saying, ["undefined method `editable?' for nil:NilClass"]

Expected results:
The radio button, Should automatically default to "New Product", if the org has no product.

Additional info:
Comment 1 RHEL Product and Program Management 2013-09-30 08:08:37 EDT
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.
Comment 3 Eric Helms 2013-10-07 12:53:06 EDT
Upstream tracking - https://github.com/Katello/katello/pull/3103
Comment 6 Kedar Bidarkar 2013-10-17 08:04:20 EDT
The radio button does not default to "New Product", looks like it's failing related to this bug https://bugzilla.redhat.com/show_bug.cgi?id=1018132
Comment 7 Mike McCune 2013-10-21 23:09:49 EDT
we can move this to MDP3, not critical
Comment 8 Eric Helms 2014-05-29 12:25:08 EDT
Sending back to QA as this appears from my local testing to have been resolved.
Comment 10 Sachin Ghai 2014-06-09 06:00:44 EDT
Verified with sat6 beta snap8 compose 2 (Satellite-6.0.3-RHEL-6-20140605.0)

when no product is already created in an org, and discovering a repo automatically selects 'New Product' radio button option.
Comment 11 Sachin Ghai 2014-06-09 06:01:54 EDT
Created attachment 904598 [details]
'New Product' radio button is selected on repo discovery
Comment 12 Bryan Kearney 2014-07-02 10:05:12 EDT
This was delivered with 6.0.3, which is the Satellite 6 Beta.

Note You need to log in before you can comment on or make changes to this bug.