Bug 101364 - nautilus crashes when stop button pressed during loading list of smb servers
nautilus crashes when stop button pressed during loading list of smb servers
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux Beta
Classification: Retired
Component: nautilus (Show other bugs)
beta1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-31 05:38 EDT by Pavel
Modified: 2015-01-07 19:06 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-04 09:35:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavel 2003-07-31 05:38:12 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5b) Gecko/20030730

Description of problem:
When nautilus tried to load list of SMB servers in domain and I pressed  Stop
button - nautilus crashed.

Version-Release number of selected component (if applicable):
2.2.4-4 (gnome-vfs-extras-0.2.0-6)

How reproducible:
Sometimes

Steps to Reproduce:
1. press stop while nautilus loads list of servers in a domain
2.
3.
    

Actual Results:  nautilus crashes

Expected Results:  don't crash

Additional info:

Crash dump:
Crash dump:

(no debugging symbols found)...0x002676f0 in waitpid ()
   from /lib/libpthread.so.0
#0  0x002676f0 in waitpid () from /lib/libpthread.so.0
#1  0x0020d5ba in libgnomeui_module_info_get () from
/usr/lib/libgnomeui-2.so.0
#2  0x002663fd in __pthread_sighandler () from /lib/libpthread.so.0
#3  <signal handler called>
#4  0x00d0c181 in _init () from
/usr/lib/gnome-vfs-2.0/modules/libsmb.so
#5  0x00d0cbf6 in _init () from
/usr/lib/gnome-vfs-2.0/modules/libsmb.so
#6  0x00d0d30c in get_file_type ()
   from /usr/lib/gnome-vfs-2.0/modules/libsmb.so
#7  0x00d0d59d in get_file_type ()
   from /usr/lib/gnome-vfs-2.0/modules/libsmb.so
#8  0x00d0ded1 in get_file_type ()
   from /usr/lib/gnome-vfs-2.0/modules/libsmb.so
#9  0x00474c8e in gnome_vfs_get_file_info_uri_cancellable ()
   from /usr/lib/libgnomevfs-2.so.0
#10 0x0047cada in _gnome_vfs_job_go () from /usr/lib/libgnomevfs-2.so.0
#11 0x0047d26a in _gnome_vfs_job_execute () from
/usr/lib/libgnomevfs-2.so.0
#12 0x0047ab09 in _gnome_vfs_job_queue_shutdown ()
   from /usr/lib/libgnomevfs-2.so.0
#13 0x0048be9e in _gnome_vfs_thread_pool_init ()
   from /usr/lib/libgnomevfs-2.so.0
#14 0x0051f8c1 in g_static_private_free () from
/usr/lib/libglib-2.0.so.0
#15 0x00260636 in pthread_start_thread () from /lib/libpthread.so.0

Thread 7 (Thread 81926 (LWP 22988)):
#0  0x00262d30 in __pthread_sigsuspend () from /lib/libpthread.so.0
No symbol table info available.
#1  0x002625b5 in __pthread_wait_for_restart_signal ()
   from /lib/libpthread.so.0
No symbol table info available.
#2  0x0025ed44 in pthread_cond_wait@GLIBC_2.0 () from
/lib/libpthread.so.0
No symbol table info available.
#3  0x0048be36 in _gnome_vfs_thread_pool_init ()
   from /usr/lib/libgnomevfs-2.so.0
No symbol table info available.
#4  0x0048be8f in _gnome_vfs_thread_pool_init ()
   from /usr/lib/libgnomevfs-2.so.0
No symbol table info available.
#5  0x0051f8c1 in g_static_private_free () from
/usr/lib/libglib-2.0.so.0
No symbol table info available.
#6  0x00260636 in pthread_start_thread () from /lib/libpthread.so.0
No symbol table info available.

Thread 6 (Thread 65541 (LWP 22987)):
#0  0x002676f0 in waitpid () from /lib/libpthread.so.0
No symbol table info available.
#1  0x0020d5ba in libgnomeui_module_info_get () from
/usr/lib/libgnomeui-2.so.0
No symbol table info available.
#2  0x002663fd in __pthread_sighandler () from /lib/libpthread.so.0
No symbol table info available.
#3  <signal handler called>
No symbol table info available.
#4  0x00d0c181 in _init () from
/usr/lib/gnome-vfs-2.0/modules/libsmb.so
No symbol table info available.
#5  0x00d0cbf6 in _init () from
/usr/lib/gnome-vfs-2.0/modules/libsmb.so
No symbol table info available.
#6  0x00d0d30c in get_file_type ()
   from /usr/lib/gnome-vfs-2.0/modules/libsmb.so
No symbol table info available.
#7  0x00d0d59d in get_file_type ()
   from /usr/lib/gnome-vfs-2.0/modules/libsmb.so
No symbol table info available.
#8  0x00d0ded1 in get_file_type ()
   from /usr/lib/gnome-vfs-2.0/modules/libsmb.so
No symbol table info available.
#9  0x00474c8e in gnome_vfs_get_file_info_uri_cancellable ()
   from /usr/lib/libgnomevfs-2.so.0
No symbol table info available.
#10 0x0047cada in _gnome_vfs_job_go () from /usr/lib/libgnomevfs-2.so.0
No symbol table info available.
#11 0x0047d26a in _gnome_vfs_job_execute () from
/usr/lib/libgnomevfs-2.so.0
No symbol table info available.
#12 0x0047ab09 in _gnome_vfs_job_queue_shutdown ()
   from /usr/lib/libgnomevfs-2.so.0
No symbol table info available.
#13 0x0048be9e in _gnome_vfs_thread_pool_init ()
   from /usr/lib/libgnomevfs-2.so.0
No symbol table info available.
#14 0x0051f8c1 in g_static_private_free () from
/usr/lib/libglib-2.0.so.0
No symbol table info available.
#15 0x00260636 in pthread_start_thread () from /lib/libpthread.so.0
No symbol table info available.

Thread 5 (Thread 49156 (LWP 22986)):
#0  0x00262d30 in __pthread_sigsuspend () from /lib/libpthread.so.0
No symbol table info available.
#1  0x002625b5 in __pthread_wait_for_restart_signal ()
   from /lib/libpthread.so.0
No symbol table info available.
#2  0x0025ed44 in pthread_cond_wait@GLIBC_2.0 () from
/lib/libpthread.so.0
No symbol table info available.
#3  0x0048be36 in _gnome_vfs_thread_pool_init ()
   from /usr/lib/libgnomevfs-2.so.0
No symbol table info available.
#4  0x0048be8f in _gnome_vfs_thread_pool_init ()
   from /usr/lib/libgnomevfs-2.so.0
No symbol table info available.
#5  0x0051f8c1 in g_static_private_free () from
/usr/lib/libglib-2.0.so.0
No symbol table info available.
#6  0x00260636 in pthread_start_thread () from /lib/libpthread.so.0
No symbol table info available.

Thread 4 (Thread 32771 (LWP 22983)):
#0  0x00262d30 in __pthread_sigsuspend () from /lib/libpthread.so.0
No symbol table info available.
#1  0x002625b5 in __pthread_wait_for_restart_signal ()
   from /lib/libpthread.so.0
No symbol table info available.
#2  0x0025ed44 in pthread_cond_wait@GLIBC_2.0 () from
/lib/libpthread.so.0
No symbol table info available.
#3  0x0048be36 in _gnome_vfs_thread_pool_init ()
   from /usr/lib/libgnomevfs-2.so.0
No symbol table info available.
#4  0x0048be8f in _gnome_vfs_thread_pool_init ()
   from /usr/lib/libgnomevfs-2.so.0
No symbol table info available.
#5  0x0051f8c1 in g_static_private_free () from
/usr/lib/libglib-2.0.so.0
No symbol table info available.
#6  0x00260636 in pthread_start_thread () from /lib/libpthread.so.0
No symbol table info available.

Thread 3 (Thread 16386 (LWP 22982)):
#0  0x00262d30 in __pthread_sigsuspend () from /lib/libpthread.so.0
No symbol table info available.
#1  0x002625b5 in __pthread_wait_for_restart_signal ()
   from /lib/libpthread.so.0
No symbol table info available.
#2  0x0025ed44 in pthread_cond_wait@GLIBC_2.0 () from
/lib/libpthread.so.0
No symbol table info available.
#3  0x0048be36 in _gnome_vfs_thread_pool_init ()
   from /usr/lib/libgnomevfs-2.so.0
No symbol table info available.
#4  0x0048be8f in _gnome_vfs_thread_pool_init ()
   from /usr/lib/libgnomevfs-2.so.0
No symbol table info available.
#5  0x0051f8c1 in g_static_private_free () from
/usr/lib/libglib-2.0.so.0
No symbol table info available.
#6  0x00260636 in pthread_start_thread () from /lib/libpthread.so.0
No symbol table info available.

Thread 2 (Thread 32769 (LWP 22981)):
#0  0x030db130 in poll () from /lib/libc.so.6
No symbol table info available.
#1  0x0025fa83 in __pthread_manager () from /lib/libpthread.so.0
No symbol table info available.

Thread 1 (Thread 16384 (LWP 22978)):
#0  0x030db130 in poll () from /lib/libc.so.6
No symbol table info available.
#1  0x00509e16 in g_main_loop_get_context () from
/usr/lib/libglib-2.0.so.0
No symbol table info available.
#2  0x00509246 in g_main_context_dispatch () from
/usr/lib/libglib-2.0.so.0
No symbol table info available.
#3  0x0050999f in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#4  0x010c79ef in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#5  0x0806fe93 in main ()
No symbol table info available.
#6  0x03026a94 in __libc_start_main () from /lib/libc.so.6
No symbol table info available.
#0  0x002676f0 in waitpid () from /lib/libpthread.so.0
Comment 1 Alexander Larsson 2004-10-04 09:35:56 EDT
smb support is rewritten since then. This is likely fixed. Closing.

Note You need to log in before you can comment on or make changes to this bug.