Bug 1013658 - Brand new applet-less cards not recognized.
Brand new applet-less cards not recognized.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: coolkey (Show other bugs)
6.5
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Bob Relyea
Asha Akkiangady
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-30 10:28 EDT by Roshni
Modified: 2013-11-21 18:06 EST (History)
5 users (show)

See Also:
Fixed In Version: coolkey-1.1.0-31.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 18:06:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix to no applet problem in coolkey (cards were looking like they were piv cards) (657 bytes, patch)
2013-09-30 17:54 EDT, Bob Relyea
no flags Details | Diff

  None (edit)
Description Roshni 2013-09-30 10:28:02 EDT
Description of problem:
Brand new Gemalto 64K cards not recognized.

Version-Release number of selected component (if applicable):
coolkey-1.1.0-30.el6

How reproducible:
always

Steps to Reproduce:
1. Install coolkey and esc on RHEL 6.5 machine
2. Insert brand new Gemalto 64K card

Actual results:
ESC does not prompt for home phone URL, the card is not detected.

Expected results:
The brand new card should be detected.

Additional info:
The card was being detected when the coolkey was downgraded to coolkey-1.1.0-20.el6
Comment 3 Bob Relyea 2013-09-30 14:17:17 EDT
Roshi, can you send me one of those cards?

bob
Comment 4 Jack Magne 2013-09-30 15:19:04 EDT
Bob:

I have one right here and was able to reproduce.
Comment 5 Bob Relyea 2013-09-30 17:20:00 EDT
updating the description. It looks like any card without an applet is failing, which makes a lot more sense than a specific card.
Comment 6 Bob Relyea 2013-09-30 17:54:01 EDT
Created attachment 805567 [details]
Fix to no applet problem in coolkey (cards were looking like they were piv cards)

Cards that had no applets were looking like PIV cards. I've tested that my suit of flavors of PIV and CAC cards are still recognized.

As soon as this bug get blocker+ I can check in the patch.

bob
Comment 8 Roshni 2013-10-03 12:38:20 EDT
Applet less cards are recognized using build coolkey-1.1.0-31.el6
Comment 10 Bob Relyea 2013-11-11 20:09:52 EST
This bug was caused by an intermediate patch in 6.5 and should not have affected any customers, so no doc are required.
Comment 11 errata-xmlrpc 2013-11-21 18:06:18 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1699.html

Note You need to log in before you can comment on or make changes to this bug.