Bug 1013704 - Build fails for s-ramp-demos-mvn-integration-artifacts
Build fails for s-ramp-demos-mvn-integration-artifacts
Status: CLOSED CURRENTRELEASE
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: DT Governance, Examples (Show other bugs)
6.0.0 GA
Unspecified Unspecified
unspecified Severity urgent
: ER4
: 6.0.0
Assigned To: Kurt T Stam
Jiri Sedlacek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-30 11:52 EDT by Stefan Bunciak
Modified: 2015-08-02 19:45 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker DTGOV-85 Major Closed build for s-ramp-demos-mvn-integration-artifacts is failing 2014-03-05 10:45:56 EST

  None (edit)
Description Stefan Bunciak 2013-09-30 11:52:46 EDT
Description of problem:

Version-Release number of selected component (if applicable):
6.0.0.ER3

How reproducible:


Steps to Reproduce:
1. Install FSW 6.0.0.ER3
2. cd to jboss-eap-6.1/quickstarts/sramp/s-ramp-demos-mvn-integration/s-ramp-demos-mvn-integration-artifacts
3. execute mvn -Pdemo clean deploy

Actual results:

* http://pastebin.test.redhat.com/167107

Expected results:


Additional info:
Comment 2 Kurt T Stam 2013-09-30 15:14:11 EDT
Do you have a running S-RAMP server (this is a requirement).
Comment 3 Stefan Bunciak 2013-09-30 16:59:29 EDT
Of course I have. My guess is that the maven is missing sramp wagon build extension.
Comment 4 Kurt T Stam 2013-10-02 12:50:26 EDT
Turns out the version id was left at 1.0.0 in the s-ramp-demos-mvn-integration-artifacts and s-ramp-demos-mvn-integration-application poms. The project version is used in the definition of the SrampWagon which then could not be found. This fix should go in the ER4-2 tag
Comment 5 JBoss JIRA Server 2013-10-02 13:12:50 EDT
Kurt Stam <kurt.stam@jboss.com> updated the status of jira DTGOV-85 to Resolved
Comment 6 JBoss JIRA Server 2013-10-02 13:12:57 EDT
Kurt Stam <kurt.stam@jboss.com> updated the status of jira DTGOV-85 to Closed
Comment 7 JBoss JIRA Server 2013-10-02 13:46:17 EDT
Kurt Stam <kurt.stam@jboss.com> updated the status of jira DTGOV-85 to Reopened
Comment 8 JBoss JIRA Server 2013-10-02 13:46:37 EDT
Kurt Stam <kurt.stam@jboss.com> updated the status of jira DTGOV-85 to Resolved
Comment 9 JBoss JIRA Server 2013-10-02 13:46:40 EDT
Kurt Stam <kurt.stam@jboss.com> updated the status of jira DTGOV-85 to Closed
Comment 10 Stefan Bunciak 2013-10-09 10:08:30 EDT
Verified in FSW 6.0.0.ER4
Comment 11 JBoss JIRA Server 2014-03-05 10:40:55 EST
Eric Wittmann <eric.wittmann@redhat.com> updated the status of jira DTGOV-85 to Reopened
Comment 12 JBoss JIRA Server 2014-03-05 10:45:56 EST
Eric Wittmann <eric.wittmann@redhat.com> updated the status of jira DTGOV-85 to Closed

Note You need to log in before you can comment on or make changes to this bug.