Bug 1013769 - USB3 doesn't retry
USB3 doesn't retry
Status: CLOSED ERRATA
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests) (Show other bugs)
1.6.5
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Greg Nichols
Red Hat Kernel QE team
:
Depends On:
Blocks: 1001233 1013866
  Show dependency treegraph
 
Reported: 2013-09-30 14:08 EDT by Rob Landry
Modified: 2013-11-13 04:58 EST (History)
3 users (show)

See Also:
Fixed In Version: hwcert-client 1.6.5-22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1013866 (view as bug list)
Environment:
Last Closed: 2013-11-13 04:58:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
usb test patch to allow retry after wrong version device is plugged-in (833 bytes, patch)
2013-09-30 20:45 EDT, Greg Nichols
no flags Details | Diff

  None (edit)
Description Rob Landry 2013-09-30 14:08:13 EDT
Description of problem:

When running the USB3 test, if the device is plugged into a USB2 port the test just fails.  It should tell the user that usb2 was detected and ask the user if they want to retry or not.

Version-Release number of selected component (if applicable):

hwcert-client-1.6.5-16.el6.noarch

How reproducible:

Everytime


Steps to Reproduce:
1. run hwcert-backend run --test USB3
2. respond with 1 USB3 port (as this system only has 1)
3. plug USB3 device (already confirmed in the USB3 port with the USB3 test) into one of the USB2 ports.

Actual results:

The test reports a fail and immediately launches the info test.

Expected results:

The test would report USB2 has been used and not pass, but inform the user and ask if they want to try again.  If not, then record as a fail; if so, try again for the number of ports similar to how the usb test used to do.

Additional info:
Comment 1 Greg Nichols 2013-09-30 20:45:08 EDT
Created attachment 805666 [details]
usb test patch to allow retry after wrong version device is plugged-in
Comment 3 Brian Brock 2013-10-10 17:17:34 EDT
verified in -22.el6

USB3 correctly test detects usb2 device inserted into a usb3 socket, complains appropriately, and asks the user to retry with usb3.  Subsequent tests (after "n") do not mention the usb2 device, but the previous message is still on the screen.
Comment 5 errata-xmlrpc 2013-11-13 04:58:53 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1515.html

Note You need to log in before you can comment on or make changes to this bug.