Bug 1013787 - hwcert-backend submit traceback on submit
hwcert-backend submit traceback on submit
Status: CLOSED ERRATA
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (harness) (Show other bugs)
1.6.5
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Greg Nichols
Red Hat Kernel QE team
:
Depends On:
Blocks: 1013862 1001233
  Show dependency treegraph
 
Reported: 2013-09-30 15:02 EDT by Brian Brock
Modified: 2013-11-13 04:59 EST (History)
2 users (show)

See Also:
Fixed In Version: hwcert-client 1.6.5-18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1013862 (view as bug list)
Environment:
Last Closed: 2013-11-13 04:59:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
batch fixing traceback (1.42 KB, patch)
2013-09-30 20:05 EDT, Greg Nichols
no flags Details | Diff

  None (edit)
Description Brian Brock 2013-09-30 15:02:28 EDT
`hwcert-backend submit` fails

hwcert-client-1.6.5-17.el6.noarch

happens reliably on at least ppc64 with failing results for 1GigEthernet test

expected submit command to succeed


Results stored on ibm-js22-04.rhts.eng.brq.redhat.com,
 submitting to https://hardware.redhat.com:

 Arch: ppc64  OS: RHEL 6.5:

    1 -> localhost 09-30-2013 at: 17:56
         failed: 1GigEthernet, 1GigEthernet, info

Select Results (<number>|all|none|quit|submit): submit
response: submit
Traceback (most recent call last):
  File "/usr/bin/hwcert-backend", line 45, in <module>
    success = hwcertBackend.do(args)
  File "/usr/share/hwcert/lib/hwcert/backend.py", line 183, in do
    result = self.commands[self.command]()
  File "/usr/share/hwcert/lib/hwcert/backend.py", line 334, in doSubmit
    self.__submitFilesToCatalog(files, selection)
  File "/usr/share/hwcert/lib/hwcert/backend.py", line 444, in __submitFilesToCatalog
    for (root, file) in files:
ValueError: too many values to unpack

$ echo $?
1
Comment 1 Greg Nichols 2013-09-30 20:05:52 EDT
Created attachment 805644 [details]
batch fixing traceback
Comment 2 Greg Nichols 2013-09-30 20:12:06 EDT
committed to R18
Comment 6 errata-xmlrpc 2013-11-13 04:59:05 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1515.html

Note You need to log in before you can comment on or make changes to this bug.