Bug 1013828 - extlinux missing when running livecd-iso-to-disk
extlinux missing when running livecd-iso-to-disk
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.4
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: Joey Boggs
Virtualization Bugs
: TestOnly
Depends On: 1013823
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-30 17:13 EDT by Joey Boggs
Modified: 2014-02-17 09:55 EST (History)
18 users (show)

See Also:
Fixed In Version: ovirt-node-3.0.1-14.el6
Doc Type: Bug Fix
Doc Text:
Previously, a syslinux-extlinux package was missing from the RHEV-H channel. This meant edit-node couldn't be used to edit RHEV-H, because syslinux failed to complete. The package has been added to the RHEV-H channel so edit-node now works as expected.
Story Points: ---
Clone Of: 1013823
Environment:
Last Closed: 2014-02-17 09:55:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joey Boggs 2013-09-30 17:13:40 EDT
+++ This bug was initially created as a clone of Bug #1013823 +++

Wehn running livecd-iso-to-disk on a rhevh iso an error message for extlinux missing is seen on screen. As a result the usb drive is unbootable.

livecd-tools-13.4.3-1.el6.x86_64

livecd-iso-to-disk --format --reset-mbr rhev-hypervisor6-6.5-20130725.0.el6.iso /dev/sdc 
Verifying image...
/root/rhev-hypervisor6-6.5-20130725.0.auto1836.el6.iso:   f9de10756f93f35e3c07242a6aed54e6
Fragment sums: aa6ed5aabec5e5227d6e5846bc9191c2cdb6a1dd9a324cf5d41fc5d5fa63
Fragment count: 20
Press [Esc] to abort check.
Checking: 100.0%

The media check is complete, the result is: PASS.

It is OK to use this media.
WARNING: THIS WILL DESTROY ANY DATA ON /dev/sdc!!!
Press Enter to continue or ctrl-c to abort

wipefs: WARNING: /dev/sdc: appears to contain 'dos' partition table
Waiting for devices to settle...
mke2fs 1.41.12 (17-May-2010)
Filesystem label=LIVE
OS type: Linux
Block size=4096 (log=2)
Fragment size=4096 (log=2)
Stride=0 blocks, Stripe width=0 blocks
245280 inodes, 979968 blocks
48998 blocks (5.00%) reserved for the super user
First data block=0
Maximum filesystem blocks=1006632960
30 block groups
32768 blocks per group, 32768 fragments per group
8176 inodes per group
Superblock backups stored on blocks: 
	32768, 98304, 163840, 229376, 294912, 819200, 884736

Writing inode tables: done                            
Creating journal (16384 blocks): done
Writing superblocks and filesystem accounting information: done

This filesystem will be automatically checked every 39 mounts or
180 days, whichever comes first.  Use tune2fs -c or -i to override.
Copying live image to USB stick
squashfs.img
   154726400 100%  119.26MB/s    0:00:01 (xfer#1, to-check=0/1)

sent 154745361 bytes  received 31 bytes  61898156.80 bytes/sec
total size is 154726400  speedup is 1.00
osmin.img
        4096 100%    0.00kB/s    0:00:00 (xfer#1, to-check=0/1)

sent 4169 bytes  received 31 bytes  8400.00 bytes/sec
total size is 4096  speedup is 0.98
Updating boot config file
Installing boot loader
/usr/bin/livecd-iso-to-disk: line 970: extlinux: command not found
USB stick set up as live image!
Comment 2 cshao 2013-10-09 01:41:21 EDT
Test version:
livecd-tools-13.4.3-1.el6.x86_64

RHEV-H QE can reproduce this bug.

#livecd-iso-to-disk --format --reset-mbr /tmp/rhevh-6.5-20130725.0.el6.iso /dev/sdb

......
Updating boot config file
Installing boot loader
/usr/bin/livecd-iso-to-disk: line 970: extlinux: command not found
USB stick set up as live image!
Comment 5 cshao 2013-11-27 05:39:24 EST
Test version:
rhev-hypervisor6-6.5-20131126.0.3.2.el6_5
livecd-tools-13.4.1-3.el6
syslinux-extlinux-4.02-8.el6.x86_64

Test steps:
#livecd-iso-to-disk --format --reset-mbr rhevh-6.5-20131126.0.3.2.el6_5.iso /dev/sdb
......
sent 4169 bytes  received 31 bytes  8400.00 bytes/sec
total size is 4096  speedup is 0.98
Updating boot config file
Installing boot loader
/media/usbdev.wxaJcr/syslinux is device /dev/sdb1
USB stick set up as live image!

Test result:
No extlinux error pop-up.

So the bug is fixed, change bug status to VERIFIED.
Comment 6 Ying Cui 2013-11-27 06:05:49 EST
This bug need to be added into ovirt-node 6.5 erratum with TestOnly.
We will check this bug again with RHEV-H 6.5 base image build, after verification with rhevh 6.5 base image build, we will change it to 'Verified' status. 

Now, change it back to ON_QA.
Comment 7 Fabian Deutsch 2014-01-09 07:05:28 EST
Setting to modifed, will be back to ON_QA once it is added to the erratum.
Comment 8 cshao 2014-01-13 02:06:09 EST
Test version:
rhevh-6.5-20140110.1
ovirt-node-3.0.1-16.el6_5

Test steps:
# ./livecd-iso-to-disk --format --reset-mbr /home/samba/RHEV-H/iso/6.5/rhevh-6.5-20140110.1.iso /dev/sde
------
------
sent 4169 bytes  received 31 bytes  8400.00 bytes/sec
total size is 4096  speedup is 0.98
Updating boot config file
Installing boot loader
/media/usbdev.fgP6ZJ/syslinux is device /dev/sde1
USB stick set up as live image!

Test result:
No extlinux error pop-up.

So the bug is fixed, change bug status to VERIFIED.
Comment 15 Ying Cui 2014-02-13 23:06:30 EST
Here needinfo Pavel, this bug is blocked by syslinux errata, so can you please push syslinux errata RHBA-2013:16255 ASAP?
Comment 16 cshao 2014-02-14 01:00:39 EST
Test version:
livecd-tools-13.4.4-1.el6_5.x86_64
syslinux-4.02-8.el6.x86_64
syslinux-extlinux-4.02-8.el6.x86_64
rhevh-6.5-20140212.0.iso

Test steps:
# livecd-iso-to-disk --format --resetmbr rhevh-6.5-20140212.0.iso /dev/sdb
Verifying image...
......
......
sent 4169 bytes  received 31 bytes  8400.00 bytes/sec
total size is 4096  speedup is 0.98
Updating boot config file
Installing boot loader
/media/usbdev.GWwkfn/syslinux is device /dev/sdb1
USB stick set up as live image!

Test result:
1. No extlinux error pop-up.
2. Boot from usb drive successful.
Comment 18 Ying Cui 2014-02-14 02:21:27 EST
Hi Pavel,
   ah...I checked your errata just now, you can change it to REL PREP, If errata has been request Docs, not yet approved, we still can change it to REL PREP, no need to wait doc approved yet.

FYI: http://wiki.test.redhat.com/ErrataWorkflow/ClosingErrata#FinalState


Thanks
Ying
Comment 20 Ying Cui 2014-02-14 02:57:48 EST
syslinux errata RHBA-2013:16255 is REL_PREP now.

syslinux packages will be shipped live into RHEVH channel directly.

So this Testonly ovirt-node bug is fixed, and verified according to comment 16.
Comment 21 cshao 2014-02-16 21:47:50 EST
Double confirm for this bug.

Syslinux errata RHBA-2013:16255 is SHIPPED LIVE - Closed now.

Result: 
syslinux-4.02-8.el6.x86_64 & syslinux-extlinux-4.02-8.el6.x86_64 & livecd-tools-13.4.4-1.el6_5:1.x86_64 get shipped in RHEV-H channel.
So the bug is fixed.
Comment 23 errata-xmlrpc 2014-02-17 09:55:50 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0182.html

Note You need to log in before you can comment on or make changes to this bug.