Bug 1013873 - unable to handle kernel NULL pointer dereference at (null)
unable to handle kernel NULL pointer dereference at (null)
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
19
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-30 21:18 EDT by knightsk@outlook.com
Modified: 2013-10-15 10:50 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-15 10:50:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
messages_log_login_failed (41.06 KB, text/plain)
2013-09-30 21:18 EDT, knightsk@outlook.com
no flags Details
yum.log (19.21 KB, application/x-bzip)
2013-10-15 10:30 EDT, knightsk@outlook.com
no flags Details

  None (edit)
Description knightsk@outlook.com 2013-09-30 21:18:23 EDT
Created attachment 805670 [details]
messages_log_login_failed

Description of problem:

after been updated to 3.11.1,allways log in failed.(3.10.x  no problem...)
part of /var/log/messages:


Oct  1 08:23:06 knight dbus[599]: [system] Activating via systemd: service name='org.freedesktop.nm_dispatcher' unit='dbus-org.freedesktop        .nm-dispatcher.service'
      2 Oct  1 08:23:06 knight systemd[1]: Starting Network Manager Script Dispatcher Service...
      3 Oct  1 08:23:06 knight dbus-daemon[599]: dbus[599]: [system] Successfully activated service 'org.freedesktop.nm_dispatcher'
      4 Oct  1 08:23:06 knight dbus[599]: [system] Successfully activated service 'org.freedesktop.nm_dispatcher'
      5 Oct  1 08:23:06 knight systemd[1]: Started Network Manager Script Dispatcher Service.
      6 Oct  1 08:23:06 knight systemd[1]: Stopping Sendmail Mail Transport Agent...
      7 Oct  1 08:23:06 knight systemd[1]: Starting Sendmail Mail Transport Agent...
      8 Oct  1 08:23:07 knight kernel: [   69.654351] nouveau E[   PFIFO][0000:01:00.0] playlist 0 update timeout
      9 Oct  1 08:23:07 knight kernel: [   69.655545] BUG: unable to handle kernel NULL pointer dereference at           (null)
     10 Oct  1 08:23:07 knight kernel: [   69.656770] IP: [<ffffffffa0183ddd>] _nouveau_gpuobj_wr32+0xd/0x30 [nouveau]
     11 Oct  1 08:23:07 knight kernel: [   69.657866] PGD 208f1f067 PUD 215ece067 PMD 0
     12 Oct  1 08:23:07 knight kernel: [   69.658945] Oops: 0000 [#3] SMP
     13 Oct  1 08:23:07 knight kernel: [   69.660014] Modules linked in: ebtable_nat nf_conntrack_netbios_ns nf_conntrack_broadcast ipt_MASQUERADE         ip6table_nat nf_nat_ipv6 ip6table_mangle ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 iptable_nat nf_nat_ipv4 nf_nat iptable_mangle nf_co        nntrack_ipv4 nf_defrag_ipv4 xt_conntrack nf_conntrack ebtable_filter rfcomm ebtables ip6table_filter ip6_tables bnep snd_hda_codec_via snd        _hda_codec_hdmi arc4 snd_hda_intel rtl8723ae snd_hda_codec rtl_pci rtlwifi mac80211 x86_pkg_temp_thermal cfg80211 coretemp snd_hwdep kvm_i        ntel kvm iTCO_wdt iTCO_vendor_support snd_seq snd_seq_device rtsx_pci_ms r8169 memstick rtsx_pci_sdmmc mii mmc_core rtsx_pci snd_pcm crc32        _pclmul uvcvideo videobuf2_vmalloc videobuf2_memops joydev videobuf2_core snd_page_alloc lpc_ich videodev media crc32c_intel ghash_clmulni        _intel shpchp btusb bluetooth mfd_core snd_timer snd rfkill soundcore mei_me mei microcode i2c_i801 serio_raw acpi_cpufreq mperf uinput no        uveau i915 mxm_wmi ttm i2c_algo_bit drm_kms_helper drm i2c_core video wmi
     14 Oct  1 08:23:07 knight kernel: [   69.666279] CPU: 1 PID: 1337 Comm: Xorg Tainted: G      D   I  3.11.1-200.fc19.x86_64 #1
     15 Oct  1 08:23:07 knight kernel: [   69.667592] Hardware name: Hasee Computer CW35S/W350STQ/W370ST            , BIOS 4.6.5 05/20/2013
     16 Oct  1 08:23:07 knight kernel: [   69.668915] task: ffff880208f43560 ti: ffff880201556000 task.ti: ffff880201556000
     17 Oct  1 08:23:07 knight kernel: [   69.670260] RIP: 0010:[<ffffffffa0183ddd>]  [<ffffffffa0183ddd>] _nouveau_gpuobj_wr32+0xd/0x30 [nouveau]
     18 Oct  1 08:23:07 knight kernel: [   69.671496] RSP: 0018:ffff880201557c70  EFLAGS: 00010246
     19 Oct  1 08:23:07 knight kernel: [   69.672837] RAX: 0000000000000000 RBX: 0000000000000000 RCX: ffffffffa023a1e0
     20 Oct  1 08:23:07 knight kernel: [   69.674221] RDX: 0000000000000000 RSI: 0000000000000000 RDI: ffff880224387800
     21 Oct  1 08:23:07 knight kernel: [   69.675532] RBP: ffff880201557c70 R08: 0000000000000000 R09: 00000009d902c543
     22 Oct  1 08:23:07 knight kernel: [   69.676772] R10: ffff8802206b0400 R11: 000009d902c54000 R12: ffff8802200c8000
     23 Oct  1 08:23:07 knight kernel: [   69.678083] R13: ffff8802200ca150 R14: ffffffffa023a1e0 R15: 0000000000000000
     24 Oct  1 08:23:07 knight kernel: [   69.679403] FS:  00007f13786c6980(0000) GS:ffff88022fa40000(0000) knlGS:0000000000000000
     25 Oct  1 08:23:07 knight kernel: [   69.680666] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
     26 Oct  1 08:23:07 knight kernel: [   69.681833] CR2: 0000000000000000 CR3: 0000000219fa2000 CR4: 00000000001407e0
     27 Oct  1 08:23:07 knight kernel: [   69.683062] Stack:
     28 Oct  1 08:23:07 knight kernel: [   69.684358]  ffff880201557cd0 ffffffffa01d82f8 ffffffff00000001 ffffea0000000210
     29 Oct  1 08:23:07 knight kernel: [   69.685647]  ffff880201557ca0 000000003e83ae31 ffff880224387800 ffffffffa023a180
     30 Oct  1 08:23:07 knight kernel: [   69.686930]  0000000000000000 ffff880201557d30 ffffffffa023a1e0 ffff88022126c540



Version-Release number of selected component (if applicable):
3.11.1

How reproducible:
version-release 3.11.1 allways

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 knightsk@outlook.com 2013-10-15 10:30:44 EDT
Created attachment 812559 [details]
yum.log
Comment 2 knightsk@outlook.com 2013-10-15 10:50:29 EDT
I don't know why, since the kernel upgrade to 3.11.4-201.fc19.x86_64,no longer appear this problem.

since 3.10.11 ~ 3.11.3 always had problems.

xorg-x11 been updated at 9/19, and  later no longer updated.
I think it is necessary to contact about this problem.


yum.log
-------
1473 Sep 17 21:10:37 Erased: kernel-3.10.10-200.fc19.x86_64
1474 Sep 17 21:10:42 Erased: kernel-devel-3.10.10-200.fc19.x86_64
1475 Sep 19 18:10:26 Updated: xorg-x11-server-common-1.14.3-1.fc19.x86_64
1476 Sep 19 18:10:31 Updated: 1:java-1.7.0-openjdk-1.7.0.60-2.4.2.1.fc19.x86_64
1477 Sep 19 18:10:33 Updated: 1:java-1.7.0-openjdk-devel-1.7.0.60-2.4.2.1.fc19.x     86_64
1478 Sep 19 18:10:35 Updated: xorg-x11-server-Xorg-1.14.3-1.fc19.x86_64
1479 Sep 19 18:10:36 Updated: 1:smartmontools-6.2-2.fc19.x86_64
1480 Sep 19 18:10:56 Installed: kernel-devel-3.11.1-200.fc19.x86_64
-------

Note You need to log in before you can comment on or make changes to this bug.