Bug 1013881 - installing numpy
installing numpy
Status: CLOSED DUPLICATE of bug 1015722
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Jhon Honce
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-30 21:42 EDT by Jdash
Modified: 2015-05-14 19:29 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-11 14:35:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jdash 2013-09-30 21:42:00 EDT
Description of problem:

Can't install numpy with setup.py configuration

I'm doing something like this to install numpy:

from setuptools import setup
 
setup(name='InvSim',
      version='1.0',
      description='Inventory Simulation App',
      author='Jdash99',
      author_email='',
      url='http://www.python.org/sigs/distutils-sig/',
      install_requires=['numpy'],
      )

Version-Release number of selected component (if applicable):


How reproducible:

Steps to Reproduce:
1. Add numpy dependency in setup.py
2. push changes
3. 

Actual results:

remote: Installed /var/lib/openshift/523f9b0a500446bb97000046/app-root/runtime/repo
remote: Processing dependencies for InvSim==1.0
remote: Searching for numpy
remote: Reading http://mirror1.ops.rhcloud.com/mirror/python/web/simple/numpy/
remote: Best match: numpy 1.7.1
remote: Downloading http://mirror1.ops.rhcloud.com/mirror/python/web/packages/source/n/numpy/numpy-1.7.1.zip#md5=9a72db3cad7a6286c0d22ee43ad9bc6c
remote: Processing numpy-1.7.1.zip
remote: Writing /tmp/easy_install-2oQi9s/numpy-1.7.1/setup.cfg
remote: Running numpy-1.7.1/setup.py -q bdist_egg --dist-dir /tmp/easy_install-2oQi9s/numpy-1.7.1/egg-dist-tmp-LdzwMP
remote: Running from numpy source directory.
remote: Warning: distutils distribution has been initialized, it may be too late to add a subpackage commandWarning: distutils distribution has been initialized, it may be too late to add a subpackage fcompilerWarning: distutils distribution has been initialized, it may be too late to add a subpackage distutilsWarning: distutils distribution has been initialized, it may be too late to add a subpackage testing/bin/sh: svnversion: command not found
remote: Warning: distutils distribution has been initialized, it may be too late to add a subpackage f2pyWarning: distutils distribution has been initialized, it may be too late to add an extension _dummyWarning: distutils distribution has been initialized, it may be too late to add a library npysortWarning: distutils distribution has been initialized, it may be too late to add an extension multiarrayWarning: distutils distribution has been initialized, it may be too late to add an extension umathWarning: distutils distribution has been initialized, it may be too late to add an extension scalarmathnon-existing path in 'numpy/distutils': 'site.cfg'

Expected results:
Numpy installed and working


Additional info:

I'm using numpy and pandas without problem in my local machine and also the example in the tutorial https://www.openshift.com/blogs/build-your-app-on-openshift-using-flask-sqlalchemy-and-postgresql-92 worked well.
Comment 1 Jdash 2013-09-30 21:46:10 EDT
I also posted this problem in the openshift forum https://www.openshift.com/forums/openshift/installing-numpy-and-pandas-with-openshift#comment-form
Comment 2 thomas.belahi 2013-10-02 09:08:24 EDT
I tried the workaround proposed there https://www.openshift.com/forums/openshift/installing-numpy-and-pandas-with-openshift#comment-form

It does not work. There are so many error messages and warnings that it can be reproduced here.
Comment 3 Jhon Honce 2013-10-11 14:35:56 EDT

*** This bug has been marked as a duplicate of bug 1015722 ***

Note You need to log in before you can comment on or make changes to this bug.