Bug 101393 - ntp-4.1.2-1.rc3.4 crashes on linux-2.6.0-test1 kernel
ntp-4.1.2-1.rc3.4 crashes on linux-2.6.0-test1 kernel
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: ntp (Show other bugs)
1.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-31 13:24 EDT by Need Real Name
Modified: 2007-04-18 12:56 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-29 09:01:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace -f ntpd -U ntp -p /var/run/ntpd.pid -g -dd >ntpstrace.txt 2>&1 (14.34 KB, text/plain)
2003-09-09 15:59 EDT, Need Real Name
no flags Details
strace -f ntpd -p /var/run/ntpd.pid -g -dd >ntpstrace2.txt 2>&1 (17.25 KB, text/plain)
2003-09-09 16:00 EDT, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2003-07-31 13:24:24 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
ntpd doesn't run for more than 2 seconds on linux 2.6.0-test1 kernel

Don't know if it's the kernel that is faulty or the ntp package

Version-Release number of selected component (if applicable):
ntp-4.1.2-1.rc3.4

How reproducible:
Always

Steps to Reproduce:
1.boot on a 2.6-test1 kernel
2.start  ntpd -U ntp -p /var/run/ntpd.pid -g
3.
    

Actual Results:  ntpd dies after some seconds

Expected Results:  ntpd running correcting the time

Additional info:
Comment 1 Harald Hoyer 2003-08-05 03:54:44 EDT
messages, logs, strace, coredump?
maybe you should report this upstream to the ntp bugzilla...
Comment 2 Need Real Name 2003-09-09 15:59:59 EDT
Created attachment 94335 [details]
strace -f ntpd -U ntp -p /var/run/ntpd.pid -g -dd >ntpstrace.txt 2>&1
Comment 3 Need Real Name 2003-09-09 16:00:31 EDT
Created attachment 94336 [details]
strace -f ntpd -p /var/run/ntpd.pid -g -dd >ntpstrace2.txt 2>&1
Comment 4 Need Real Name 2003-09-09 16:04:41 EDT
it seems the trigger is the -U parameter, but when i compiled ntp-4.1.80rc, i
haven't seen this option, was it added by redhat?

So the -U code doesn't work correctly with the 2.6.0 kernels, i don't know if
it's ntp that should be tweaked, ok the kernel himself. Also i don't have the
sources for the ntp-redhat version.


Here are the results from:
]# ntpd -U ntp -p /var/run/ntpd.pid -g -dd
create_sockets(123)
interface <lo> OK
interface <eth0> OK
bind() fd 4, family 2, port 123, addr 0.0.0.0, flags=1
flags for fd 4: 04002
bind() fd 5, family 2, port 123, addr 127.0.0.1, flags=0
flags for fd 5: 04002
bind() fd 6, family 2, port 123, addr 10.0.1.2, flags=1
flags for fd 6: 04002
create_sockets: ninterfaces=3
interface 0:  fd=4,  bfd=0,  name=wildcard,  flags=0x1
              sin=0.0.0.0  bcast=0.0.0.0,  mask=255.255.255.255
interface 1:  fd=5,  bfd=0,  name=lo,  flags=0x4
              sin=127.0.0.1  mask=255.0.0.0
interface 2:  fd=6,  bfd=0,  name=eth0,  flags=0x1
              sin=10.0.1.2  bcast=10.0.1.255,  mask=255.255.255.0
init_io: maxactivefd 6
getnetnum given 127.0.0.1, got 127.0.0.1 (7f000001)
getnetnum given 10.0.1.1, got 10.0.1.1 (a000101)
getnetnum given 10.0.1.1, got 10.0.1.1 (a000101)
peer_clear: at 0 assoc ID 0
newpeer: 10.0.1.2->10.0.1.1 mode 3 vers 4 poll 6 10 flags 1 1 ttl 0 key 00000000
[root@little root]#   (no ^C)



]# ntpd -p /var/run/ntpd.pid -g -dd
create_sockets(123)
interface <lo> OK
interface <eth0> OK
bind() fd 4, family 2, port 123, addr 0.0.0.0, flags=1
flags for fd 4: 04002
bind() fd 5, family 2, port 123, addr 127.0.0.1, flags=0
flags for fd 5: 04002
bind() fd 6, family 2, port 123, addr 10.0.1.2, flags=1
flags for fd 6: 04002
create_sockets: ninterfaces=3
interface 0:  fd=4,  bfd=0,  name=wildcard,  flags=0x1
              sin=0.0.0.0  bcast=0.0.0.0,  mask=255.255.255.255
interface 1:  fd=5,  bfd=0,  name=lo,  flags=0x4
              sin=127.0.0.1  mask=255.0.0.0
interface 2:  fd=6,  bfd=0,  name=eth0,  flags=0x1
              sin=10.0.1.2  bcast=10.0.1.255,  mask=255.255.255.0
init_io: maxactivefd 6
getnetnum given 127.0.0.1, got 127.0.0.1 (7f000001)
getnetnum given 10.0.1.1, got 10.0.1.1 (a000101)
getnetnum given 10.0.1.1, got 10.0.1.1 (a000101)
peer_clear: at 0 assoc ID 0
newpeer: 10.0.1.2->10.0.1.1 mode 3 vers 4 poll 6 10 flags 1 1 ttl 0 key 00000000
report_event: system event 'event_restart' (0x01) status 'sync_alarm,
sync_unspec, 1 event, event_unspec' (0xc010)
auth_agekeys: at 1 keys 1 expired 0
poll_update: at 4 10.0.1.1 flags 0001 poll 6 burst 0 last 4 next 70
        MCAST   *****sendpkt(fd=6 dst=10.0.1.1, src=10.0.1.2, ttl=0, len=48)
transmit: at 4 10.0.1.2->10.0.1.1 mode 3
receive: at 4 10.0.1.2<-10.0.1.1 mode 4 code 1
peer 10.0.1.1 event 'event_reach' (0x84) status 'unreach, conf, 1 event,
event_reach' (0x8014)
poll_update: at 4 10.0.1.1 flags 0001 poll 6 burst 0 last 4 next 70
clock_filter: n 1 off 2.713834 del 0.000587 dsp 7.937508 jit 0.000008, age 0
... ^C

Comment 5 Harald Hoyer 2003-09-10 08:17:02 EDT
hmm...

capset(0x19980330, 0, {CAP_SYS_TIME, CAP_SYS_TIME, CAP_SYS_TIME}) = -1 EPERM
(Operation not permitted)
Comment 6 Need Real Name 2003-09-10 18:06:26 EDT
i've looked through the kernel 2.6 documentation for the capset function, it
appears it needs the module 'capability' (security related module) to be loaded
to work. Once i've modprobed it, ntpd -U worked

i think ntpd -U ... -d could have print some error msg ;)

But since it works, i suppose this can be closed as 'notabug'

Note You need to log in before you can comment on or make changes to this bug.