Bug 1013934 - Debian installation documentation is out of date, and dangerous
Debian installation documentation is out of date, and dangerous
Status: CLOSED CURRENTRELEASE
Product: Publican
Classification: Community
Component: Publican Users Guide (Show other bugs)
3.2
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Ruediger Landmann
tools-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-01 01:15 EDT by Sven Dowideit
Modified: 2013-12-18 21:46 EST (History)
4 users (show)

See Also:
Fixed In Version: 4.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-18 21:46:29 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
update debian install to use apt pinning (11.35 KB, patch)
2013-10-05 19:42 EDT, Sven Dowideit
no flags Details | Diff

  None (edit)
Description Sven Dowideit 2013-10-01 01:15:33 EDT
Description of problem:

publican 2.8 is in debian stable, and the desciption of how to install the unstable version (3.2) can leave you with a broken system.

Version-Release number of selected component (if applicable):

all?

How reproducible:

often :)

Additional info:

since debian Squeeze, You're supposed to use the backports system, but sadly, there is no backport of publican (and the massive number of dependencies)

I am currently testing a vm installing using apt-pinning.

The Debian documentation is at http://www.debian.org/doc/manuals/apt-howto/ch-apt-get.en.html#s-default-version

I'm also moving the Debian install proceedure out to a separate file ala the openSuse one. 

Sven
Comment 2 Jeff Fearn 2013-10-01 01:49:08 EDT
Now I wish I'd used github so I could get pull requests!

Adding Raphaël to CC in case he wants to chime in.
Comment 3 Raphaël Hertzog 2013-10-01 05:45:45 EDT
I'm sorry I don't have the time to update that section. Basically you should just advise to use the publican version available in the release of choice of the user.

For stable users, they might want verify if there's a backports. They can do this on http://packages.debian.org/stable/publican or http://packages.qa.debian.org/publican (currently there's no backport because it really means backporting a lot of perl modules).

Alternatively they can use a chroot or a VM running "testing" to have the latest version of publican.
Comment 4 Sven Dowideit 2013-10-01 07:05:54 EDT
I'm writing as fast as I can test, but my DSL is slow, so I'm not expecting to be finished today :)

Sven
Comment 5 Sven Dowideit 2013-10-01 08:14:49 EDT
ok, I'm pushing my changes to https://github.com/SvenDowideit/publican feel free to tell me where I'm going wrong :)

Sven
Comment 6 Jeff Fearn 2013-10-01 22:33:53 EDT
(In reply to Raphaël Hertzog from comment #3)
> I'm sorry I don't have the time to update that section. 

Just to be clear, I thought there might be a chance you could provide some editorial oversight given there aren't many other people around to give this section a real review :}

Cheers, Jeff.
Comment 7 Anthony Towns 2013-10-02 00:13:14 EDT
(In reply to Sven Dowideit from comment #5)
> ok, I'm pushing my changes to https://github.com/SvenDowideit/publican feel
> free to tell me where I'm going wrong :)

Looks pretty reasonable to me; I've sent a couple of minor changes through as a pull request on github.
Comment 8 Sven Dowideit 2013-10-02 02:28:42 EDT
merged, thank you Anthony.

Jeff, would you prefer a patch file, or can you pull from the github branch I made?

Sven
PS. Should I raise a new bug for the Copyright year being 2010?
Comment 9 Jeff Fearn 2013-10-03 23:49:17 EDT
Hi Sven, can you supply a patch please?

I update the copyright year to 2013.
Comment 10 Sven Dowideit 2013-10-05 19:42:51 EDT
Created attachment 808332 [details]
update debian install to use apt pinning
Comment 11 Ruediger Landmann 2013-11-14 00:48:04 EST
Thanks so much for the help Sven!

Fix checked in:
e8164b2..204eb8d  devel -> devel

Note You need to log in before you can comment on or make changes to this bug.