Bug 101397 - Installer crashes on missing CD
Installer crashes on missing CD
Status: CLOSED NOTABUG
Product: Red Hat Linux Beta
Classification: Retired
Component: anaconda (Show other bugs)
beta1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-31 13:48 EDT by Charles Hixson
Modified: 2007-04-18 12:56 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-14 12:43:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Fulbright 2003-08-04 15:27:57 EDT
Please give as many details as possible on the problem you are experiencing.
Comment 1 Charles Hixson 2003-08-04 17:17:46 EDT
There isn't much, but since what I posted seems lost...

While installing the Severn CD at home, as the third CD came up, I discovered
that I had left that CD at the office.  So I cancelled.  The system hung hard. 
No reaction to key presses of any sort.  Eventually I resorted to power cycling
the system.  I had expected it to result in a system with not all features
installed.  A less desireable, but also acceptable choice, would be to post a
dialog box saying: "The third CD is required.  Without it installation cannot
complete.  Please install an operating system.  <<REBOOT NOW>>", and then reboot
the computer.

At this point, since I had wiped the disk, and I couldn't install Severn, I
installed a different distribution.  So beyond this point I can't comment.

(However, this weekend I got a notice that Red Hat had deactivated my "demo"
account..so I won't be able to even continue with the copy that I got installed.
 Pretty good for a first public beta.  But that *is* my work computer, so Severn
can't stay on it, esp. since I can't get the upgrades anymore.)
Comment 2 Michael Fulbright 2003-08-11 17:39:45 EDT
How did you 'cancel' the install - as far as I know there is no option to do this.
Comment 3 Charles Hixson 2003-08-12 10:57:42 EDT
You are correct.  As I said the only way to cancel was to power cycle the
computer.  Vile, but it was the only choice.
Comment 4 Michael Fulbright 2003-08-14 12:43:30 EDT
There really is no other alternative at that point of an install. If we have
gone partially through the package transaction set and you have to reboot its
going to probably cause issues.  It was discussed extensively a couple of years
ago and we agreed adding a 'Skip' or 'Abort' button was not the correct
solution.  We added the mediacheck to help people verify they had a complete CD
set before starting the install, which has helped alot of people.

Note You need to log in before you can comment on or make changes to this bug.