Bug 101398 - iptables modules loading error
Summary: iptables modules loading error
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: distribution (Show other bugs)
(Show other bugs)
Version: 3.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: dff
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-07-31 17:48 UTC by Josep M.
Modified: 2007-11-30 22:06 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-02 19:19:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Charles Hixson 2003-07-31 17:48:12 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5b) Gecko/20030728

Description of problem:
When I went to install Severn on my home computer, I had left the third CD at
the office.  The installation hung the computer so hard that it required a power
cycle to recover.

The expected reaction is to either abort the install (and offer to reboot) or to
proceed with the install, but having some packages/features missing.


Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1.Attempt installation of Severn
2.Discover that third CD is missing
3.
    

Actual Results:  Computer hangs seriously.  ctrl-alt-delete doesn't reboot. 
Shift-ctrl-backspace doesn't cancel X.  (Actually, I believe that almost
immediately I started getting the beep that indicated that keypress events
aren't being cleared from the queue.)


Expected Results:  Installer should either:
1) have informed me that this was a non-recoverable error, and offered to reboot
the computer
or (preferably)
2) have offered to continue with an install that was missing some of the
requested features.

Additional info:

This was a dual processor AMD system.

Comment 1 Josep M. 2003-07-31 17:48:12 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:

When loading at startup my firewall script some modules can´t load

Steps to Reproduce:
1.
These is myload modules section:

/sbin/depmod -a
/sbin/modprobe ip_tables
/sbin/modprobe ip_conntrack
/sbin/modprobe ipt_LOG
/sbin/modprobe ipt_REJECT
/sbin/modprobe ip_nat_ftp
/sbin/modprobe ip_nat_irc
/sbin/modprobe ipt_owner
/sbin/modprobe ip_conntrack_ftp
/sbin/modprobe ip_conntrack_irc
/sbin/modprobe ipt_tcpmss

2.
3.
    
Actual results:
These are the errors:

/lib/modules/2.4.21-1.1931.2.349.2.2.ent/kernel/net/ipv4/netfilter/ipchains.o:
init_module: Device or resource busy
Hint: insmod errors can be caused by incorrect module parameters, including
invalid IO or IRQ parameters.
      You may find more information in syslog or the output from dmesg
/lib/modules/2.4.21-1.1931.2.349.2.2.ent/kernel/net/ipv4/netfilter/ipchains.o:
insmod
/lib/modules/2.4.21-1.1931.2.349.2.2.ent/kernel/net/ipv4/netfilter/ipchains.o failed
/lib/modules/2.4.21-1.1931.2.349.2.2.ent/kernel/net/ipv4/netfilter/ipchains.o:
insmod ip_nat_ftp failed
/lib/modules/2.4.21-1.1931.2.349.2.2.ent/kernel/net/ipv4/netfilter/ipchains.o:
init_module: Device or resource busy
Hint: insmod errors can be caused by incorrect module parameters, including
invalid IO or IRQ parameters.
      You may find more information in syslog or the output from dmesg
/lib/modules/2.4.21-1.1931.2.349.2.2.ent/kernel/net/ipv4/netfilter/ipchains.o:
insmod
/lib/modules/2.4.21-1.1931.2.349.2.2.ent/kernel/net/ipv4/netfilter/ipchains.o failed
/lib/modules/2.4.21-1.1931.2.349.2.2.ent/kernel/net/ipv4/netfilter/ipchains.o:
insmod ip_nat_irc failed



Expected results:


Additional info:

I use iptables with the iptables updated package,I have my own firewal script
for the machine,no NAT used,is only for these machine,this script runs very well
for time in 
RedHat9 and AS2.1 but now i get these errors  when my machine starts,seeme than
some modules 
don´t load well.What can I do for try that this will run ok?


[root@mail fetchmail]# rpm -qa |grep iptables
iptables-ipv6-1.2.8-9
iptables-1.2.8-9


I haven´t any ipchains file installed:
[root@mail fetchmail]# rpm -qa |grep ipchains
[root@mail fetchmail]# chkconfig --list ipchains
error al leer la información del servicio ipchains: No existe el fichero o el
directorio

Was running well under Redhat9 and AS2.1.

Comment 2 Michael K. Johnson 2003-08-08 20:20:55 UTC
This is a bug in our build tools, and should be fixed in our next build
if our fix is correct...

Comment 3 Thomas Woerner 2003-08-13 09:17:23 UTC
The problem still occurs:

$ rpm -q kernel
kernel-2.4.21-1.1931.2.389.ent

$ modprobe ipt_MASQUERADE
/lib/modules/2.4.21-1.1931.2.389.ent/kernel/net/ipv4/netfilter/ipchains.o:
init_module: Device or resource busy
Hint: insmod errors can be caused by incorrect module parameters, including
invalid IO or IRQ parameters.
      You may find more information in syslog or the output from dmesg
/lib/modules/2.4.21-1.1931.2.389.ent/kernel/net/ipv4/netfilter/ipchains.o:
insmod /lib/modules/2.4.21-1.1931.2.389.ent/kernel/net/ipv4/netfilter/ipchains.o
failed
/lib/modules/2.4.21-1.1931.2.389.ent/kernel/net/ipv4/netfilter/ipchains.o:
insmod ipt_MASQUERADE failed


Comment 4 Dave Jones 2004-08-25 16:05:12 UTC
did this get fixed in later kernels ?

Comment 5 Ernie Petrides 2004-08-25 23:50:03 UTC
DaveJ, I don't know.  DaveM, can you shed any light on this?
In particular, do have the same bug in RHEL3 at this point?

Thanks in advance.  -ernie


Comment 6 David Miller 2004-08-25 23:55:41 UTC
If you load iptables you cannot load the ipchains modules,
and vice versa.  You have to choose to use one or the other.

Something in his messed up half-install has created a situation
whereby both ipchains and iptables is trying to be used at
the same time.

I don't understand why this bug report is even being seriously
considered, the install died so just about any kind of garbage
can be on the system causing who knows what kinds of problems.


Comment 7 David Miller 2004-08-25 23:56:08 UTC
Please assign this to someone else, it's not a kernel bug.


Comment 8 Ernie Petrides 2004-08-26 00:27:24 UTC
Jeremy, could you please reassign this bug appropriately?

Thanks.  -ernie


Comment 9 Bill Nottingham 2005-03-02 19:19:15 UTC
Closing, please reopen if this persists on current Red Hat Enterprise
Linux update releases.


Note You need to log in before you can comment on or make changes to this bug.