Bug 1014021 - SELinux is preventing tuned from 'write' accesses on the directory /dev/mqueue.
SELinux is preventing tuned from 'write' accesses on the directory /dev/mqueue.
Status: CLOSED DUPLICATE of bug 1014017
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
20
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:1dd6bd8f4ea66a3400e41d56311...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-01 05:31 EDT by Heiko Adams
Modified: 2013-10-04 10:37 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-04 10:37:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Heiko Adams 2013-10-01 05:31:07 EDT
Description of problem:
Just booted my system and logged into my Xfce session
SELinux is preventing tuned from 'write' accesses on the directory /dev/mqueue.

*****  Plugin catchall (100. confidence) suggests   **************************

If sie denken, dass es tuned standardmässig erlaubt sein sollte, write Zugriff auf mqueue directory zu erhalten.
Then sie sollten dies als Fehler melden.
Um diesen Zugriff zu erlauben, können Sie ein lokales Richtlinien-Modul erstellen.
Do
zugriff jetzt erlauben, indem Sie die nachfolgenden Befehle ausführen:
# grep tuned /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:tuned_t:s0
Target Context                system_u:object_r:tmpfs_t:s0
Target Objects                /dev/mqueue [ dir ]
Source                        tuned
Source Path                   tuned
Port                          <Unbekannt>
Host                          (removed)
Source RPM Packages           python-2.7.5-7.fc20.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-84.fc20.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.11.2-301.fc20.x86_64 #1 SMP Fri
                              Sep 27 19:45:03 UTC 2013 x86_64 x86_64
Alert Count                   7
First Seen                    2013-10-01 06:34:23 CEST
Last Seen                     2013-10-01 11:27:33 CEST
Local ID                      f7cfb0b8-68de-4252-8a7a-0c803c4c07f0

Raw Audit Messages
type=AVC msg=audit(1380619653.579:183): avc:  denied  { write } for  pid=575 comm="tuned" name="/" dev="mqueue" ino=6593 scontext=system_u:system_r:tuned_t:s0 tcontext=system_u:object_r:tmpfs_t:s0 tclass=dir


type=SYSCALL msg=audit(1380619653.579:183): arch=x86_64 syscall=access success=no exit=EACCES a0=7fff45649767 a1=2 a2=0 a3=0 items=0 ppid=1 pid=575 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 ses=4294967295 tty=(none) comm=tuned exe=/usr/bin/python2.7 subj=system_u:system_r:tuned_t:s0 key=(null)

Hash: tuned,tuned_t,tmpfs_t,dir,write

Additional info:
reporter:       libreport-2.1.7
hashmarkername: setroubleshoot
kernel:         3.11.2-301.fc20.x86_64
type:           libreport
Comment 1 Daniel Walsh 2013-10-04 10:37:30 EDT

*** This bug has been marked as a duplicate of bug 1014017 ***

Note You need to log in before you can comment on or make changes to this bug.