Bug 1014042 - SY quickstarts cannot be executed
SY quickstarts cannot be executed
Status: CLOSED CURRENTRELEASE
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: Build Process (Show other bugs)
6.0.0 GA
Unspecified Unspecified
unspecified Severity urgent
: ER4
: ---
Assigned To: Nick Cross
Jiri Sedlacek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-01 06:02 EDT by Jiri Pechanec
Modified: 2015-08-02 19:45 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiri Pechanec 2013-10-01 06:02:29 EDT
A lot of SY QS needs tests to be compiled to execute steps according to Readme files. With ER4 tests no longer compiles because quickstarts/switchyard/pom.xml no longer contains lines

    <properties>
        <maven.test.skip>false</maven.test.skip>
    </properties>
Comment 2 Jiri Pechanec 2013-10-02 01:09:12 EDT
So far I am using ER3 repo to get the QS build and executed to save some time before getting ER4 repo. This means that I needed to modify version in QS pom.xml and in QS parent pom.xml.

The problem is right now (if it is fixed in ER4 repo then it is ok), that if you tru for example bean-service QS there are two issues
1) Running mvn install does not compile and execute tests
2) Running mvn exec:java fails beacuse it uses class from src/test/java that is/was not compiled in step 1

The problem is that in ER3 repo in one of paranet paraent parent poms the test execution is disabled by setting <maven.test.skip>true</maven.test.skip>.
This setting was overriden in QS parent pom using <maven.test.skip>false</maven.test.skip>.

As this line has disappeared in ER4 the net result is that tests are not executed.

I will verify the issue when ER4 repo arrives.
Comment 3 Nick Cross 2013-10-02 11:33:03 EDT
Using latest ER4 installer and the test maven repo the quickstart does compile. There is no longer any need to set maven.test.skip
Comment 4 Len DiMaggio 2013-10-04 14:29:44 EDT
We are able to run quickstarts with the Oct 4 ER4 respin #2 build.

Separate bz's will be logged for individual quickstart failures.


[INFO] ------------------------------------------------------------------------
[INFO] Reactor Summary:
[INFO] 
[INFO] SwitchYard: Quickstarts ........................... SUCCESS [1.166s]
[INFO] Quickstart : Bean Service ......................... SUCCESS [24.166s]
[INFO] Quickstart : BPEL Service ......................... SUCCESS [1:23.350s]
[INFO] Quickstart : BPEL Service : Say Hello ............. SUCCESS [24.329s]
[INFO] Quickstart : BPEL Service : JMS Binding ........... SUCCESS [21.999s]
[INFO] Quickstart : BPEL Service : Loan Approval ......... SUCCESS [20.912s]
[INFO] Quickstart : BPEL Service : Simple Correlation .... SUCCESS [14.044s]
[INFO] Quickstart : BPEL Service : XTS Subordinate WSBA .. SUCCESS [0.274s]
[INFO] Quickstart : BPEL Service : XTS Subordinate WSBA : Business Travel Process  SUCCESS [0.951s]
[INFO] Quickstart : BPEL Service : XTS Subordinate WSBA : Airport Web Service  SUCCESS [1.659s]
[INFO] Quickstart : BPEL Service : XTS WSAT .............. SUCCESS [0.257s]
[INFO] Quickstart : BPEL Service : XTS WSAT : Business Travel Process  SUCCESS [0.760s]
[INFO] Quickstart : BPEL Service : XTS WSAT : Airport Web Service  SUCCESS [1.312s]
[INFO] Quickstart : BPM Service .......................... SUCCESS [2:00.027s]
[INFO] Quickstart : Camel Binding ........................ SUCCESS [14.211s]
[INFO] Quickstart : Camel JAXB ........................... FAILURE [5.716s]
[INFO] Quickstart : Camel AMQP Binding ................... SKIPPED
[INFO] Quickstart : Camel FTP Binding .................... SKIPPED
.
.
.
.

Note You need to log in before you can comment on or make changes to this bug.