Bug 1014072 - Schema tool does not configure datasource for BPEL
Schema tool does not configure datasource for BPEL
Status: CLOSED DUPLICATE of bug 969008
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: Configuration (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Julian Coleman
Jiri Sedlacek
:
Depends On: 969008
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-01 07:31 EDT by Jiri Pechanec
Modified: 2015-08-02 19:45 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-15 10:25:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiri Pechanec 2013-10-01 07:31:12 EDT
Installer no configures DS for all components using db save BPEL. This has to be added too.
Comment 2 Jiri Pechanec 2013-10-02 01:16:35 EDT
See
jpechane@jpechane:~/releases/er4$ grep -ir 'datasource jndi' full/jboss-eap-6.1/standalone/configuration/standalone.xml 
                <datasource jndi-name="java:jboss/datasources/ExampleDS" pool-name="ExampleDS" enabled="true" use-java-context="true">
                <datasource jndi-name="java:jboss/datasources/jbpmDS" pool-name="jbpmDS" enabled="true" use-java-context="true">
                <datasource jndi-name="java:jboss/GadgetServer" pool-name="GadgetServer" enabled="true" use-java-context="true">
                <datasource jndi-name="java:jboss/datasource/OverlordRTGov" pool-name="OverlordRTGov" enabled="true" use-java-context="true">

I'd expect there will be also a datasource named bpelDS and the BPEL component will use it.

As it was decided that bz969008 is no longer a beta blocker and we are happy to deliver a product to customer that will
 1) allow him to install and configure FSW for some of the databases
 2) require him to manually modify BPEL component to use the database he is using for the other components

then I am removing the beta blocker form this one too.
Comment 3 Alan Santos 2013-10-02 01:28:51 EDT
(In reply to Jiri Pechanec from comment #2)
> As it was decided that bz969008 is no longer a beta blocker and we are happy
> to deliver a product to customer that will
...
>  2) require him to manually modify BPEL component to use the database he is
> using for the other components


As it was explained yesterday, I did not leave the PM discussion with the understanding that one must manually modify a BPEL component.  If that's the case this should still be considered a beta blocker.
Comment 4 Julian Coleman 2013-11-15 10:25:27 EST
The fix has been done as part of 969008.

*** This bug has been marked as a duplicate of bug 969008 ***

Note You need to log in before you can comment on or make changes to this bug.