Bug 1014146 - Database Configuration screen guiding text update
Database Configuration screen guiding text update
Status: CLOSED CURRENTRELEASE
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: Installer (Show other bugs)
6.0.0 GA
Unspecified Unspecified
unspecified Severity high
: ER7
: 6.0.0
Assigned To: Thomas Hauser
Stefan Bunciak
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-01 09:08 EDT by Stefan Bunciak
Modified: 2014-02-06 10:29 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stefan Bunciak 2013-10-01 09:08:49 EDT
Description of problem:

On Database Configuration screen (post-installation steps):
We should explicitly say that users needs to modify the default Url:
jdbc:mysql://SERVER_NAME:PORT/DATABASE_NAME

and replace SERVER_NAME, PORT and DATABASE_NAME with appropriate values. Since the header text just states 'Please enter the following information...' and the Url is prefilled, users can assume that default values could be injected.

Version-Release number of selected component (if applicable):
* 6.0.0.ER4

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Thomas Hauser 2013-10-01 10:28:31 EDT
I have made the following change, let me know if this is sufficient or not: 

Old String:
Please enter the following information for your database. The driver used will be the one specified by the JDBC driver installation step.

New String:
Please provide the following information, replacing SERVER_NAME, PORT, and DATABASE_NAME in the Database url field with the appropriate values for your database. The driver used will be the one specified by the JDBC driver installation step.
Comment 2 Stefan Bunciak 2013-10-01 11:09:59 EDT
I think it's ok.
Comment 3 Pavol Srna 2013-12-16 06:36:41 EST
The Text was removed completely and all required fields are placed on the same installer page. I believe this is what we want. Verified in ER7 build.

Note You need to log in before you can comment on or make changes to this bug.