Bug 1014163 - qpid::Exception thrown from qpid::messaging API
qpid::Exception thrown from qpid::messaging API
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp (Show other bugs)
Development
Unspecified Unspecified
unspecified Severity unspecified
: 3.0
: ---
Assigned To: Gordon Sim
Zdenek Kraus
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-01 09:29 EDT by Gordon Sim
Modified: 2015-01-21 07:57 EST (History)
4 users (show)

See Also:
Fixed In Version: qpid-cpp-0.22-19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Apache JIRA QPID-5198 None None None Never

  None (edit)
Description Gordon Sim 2013-10-01 09:29:10 EDT
Description of problem:

The qpid::messaging API can throw qpid::Exception whereas it should only throw subtypes of qpid::types::Exception.

Version-Release number of selected component (if applicable):

Since qpid-0.20 (my AMQP 1.0 work introduced the problem)

How reproducible:

100%

Steps to Reproduce:
1. try to set connection options to include 'protocol:wrong'

Actual results:

Get an qpid::Exception thrown

Expected results:

Get some subclass of qpid::types::Exception thrown, e.g. qpid::messaging::MessagingException.

Additional info:
Comment 1 Gordon Sim 2013-10-01 09:31:48 EDT
Fixed upstream: https://svn.apache.org/r1528082
Comment 3 Zdenek Kraus 2014-01-16 10:20:57 EST
This issue was tested on RHEL 6.5 i686 and x86_64 with packages:

perl-qpid-0.22-7.el6
python-qpid-0.22-10.el6
python-qpid-qmf-0.22-26.el6
qpid-cpp-client-0.22-33.el6
qpid-cpp-client-devel-0.22-33.el6
qpid-cpp-client-devel-docs-0.22-33.el6
qpid-cpp-client-ssl-0.22-33.el6
qpid-cpp-server-0.22-33.el6
qpid-cpp-server-devel-0.22-33.el6
qpid-cpp-server-ha-0.22-33.el6
qpid-cpp-server-ssl-0.22-33.el6
qpid-cpp-server-store-0.22-33.el6
qpid-cpp-server-xml-0.22-33.el6
qpid-java-client-0.22-5.el6
qpid-java-common-0.22-5.el6
qpid-java-example-0.22-5.el6
qpid-jca-0.22-1.el6
qpid-jca-xarecovery-0.22-1.el6
qpid-proton-c-0.6-1.el6
qpid-proton-c-devel-0.6-1.el6
qpid-qmf-0.22-26.el6
qpid-snmpd-1.0.0-15.el6
qpid-tools-0.22-7.el6
ruby-qpid-qmf-0.22-26.el6

fix works as expected.

Note You need to log in before you can comment on or make changes to this bug.