Bug 1014176 - Maven Guide: Update versions of BOMs used in examples
Maven Guide: Update versions of BOMs used in examples
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Documentation (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity medium
: ER5
: EAP 6.2.0
Assigned To: sgilda
Russell Dickenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-01 09:41 EDT by Nikoleta Ziakova
Modified: 2014-09-29 14:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-15 11:55:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nikoleta Ziakova 2013-10-01 09:41:13 EDT
Document URL: 
http://documentation-devel.engineering.redhat.com/docs/en-US/JBoss_Enterprise_Application_Platform/6.2/html/Development_Guide/Maven_BOM_Usage.html

Section Number and Name: 
2.3.4. Manage Project Dependencies

Describe the issue: 
Versions of all the BOMs used in examples have changed:
  jboss-javaee-6.0
    3.0.2.Final-redhat-4 --> 3.0.2.Final-redhat-5

  jboss-javaee-6.0-with-hibernate
    1.0.4.Final-redhat-9 --> 6.2.0.Beta1

  jboss-as-ejb-client-bom
    7.2.1.Final-redhat-10 --> 7.3.0.Final-redhat-6

  jboss-as-jms-client-bom
    7.2.1.Final-redhat-10 --> 7.3.0.Final-redhat-6

Suggestions for improvement: 
Update versions of these BOMs. It would be better to use versions 3.0.2.Final-redhat-X and 7.3.0.Final-redhat-X instead of the exact numbers because these may change.
Comment 2 Paul Gier 2013-10-16 16:10:56 EDT
Marking as ON_QA because updated docs are now on staging.
Comment 3 Nikoleta Ziakova 2013-10-22 02:39:56 EDT
The text is OK for Beta, but the version of jboss-javaee-6.0-with-hibernate BOM will have to be updated to 6.2.0.GA -- it will be done within BZ 1018843.

Note You need to log in before you can comment on or make changes to this bug.