Bug 1014179 - [redhat-support-plugin-rhev] During login failure the dialog shows me wrong URL (hardcoded?)
[redhat-support-plugin-rhev] During login failure the dialog shows me wrong U...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: redhat-support-plugin-rhev (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity high
: ---
: 3.3.0
Assigned To: Spenser Shumaker
Jiri Belka
subeng
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-01 09:44 EDT by Jiri Belka
Modified: 2014-01-21 11:58 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
During a login failure the dialog showed the wrong URL - 'URL=https://api.access.qa.redhat.com' in conf file but ui plugin shows 'Unable to reach access.redhat.com...' The real URL is now shown.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 11:58:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
cboyle: needinfo+


Attachments (Terms of Use)
screenshot (32.45 KB, image/png)
2013-10-01 09:44 EDT, Jiri Belka
no flags Details

  None (edit)
Description Jiri Belka 2013-10-01 09:44:59 EDT
Created attachment 805982 [details]
screenshot

Description of problem:
During login failure the dialog shows me wrong URL - I have 'URL=https://api.access.qa.redhat.com' in conf file but ui plugin show 'Unable to reach access.redhat.com...'

See screenshot.

# cat /etc/ovirt-engine/redhatsupportplugin.conf 
sessionTimeout=82800000
isBrokered=true
URL=https://api.access.qa.redhat.com
isProxy=false
proxyUser=username
proxyPassword=password
proxyURL=http://localhost
proxyPort=3128
version=com.redhat.gss-redhat-support-plugin-rhev-3.3.0-0.scratch

Version-Release number of selected component (if applicable):
is17

How reproducible:
100%

Steps to Reproduce:
1. change URL in conf
2. try to login
3.

Actual results:
error dialog seems to have hardcoded URL

Expected results:
show real used URL

Additional info:
Comment 2 Jiri Belka 2013-10-07 05:18:14 EDT
OK, redhat-support-plugin-rhev-3.3.0-8.el6ev.noarch.
Comment 3 Charlie 2013-11-27 20:34:30 EST
This bug is currently attached to errata RHBA-2013:15513. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to 
minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 4 errata-xmlrpc 2014-01-21 11:58:41 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0082.html

Note You need to log in before you can comment on or make changes to this bug.