Bug 1014186 - Document usage of Maven BOM containing all supported artifacts
Document usage of Maven BOM containing all supported artifacts
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Documentation (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity medium
: DR4
: EAP 6.3.0
Assigned To: sgilda
Russell Dickenson
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-01 09:48 EDT by Nikoleta Ziakova
Modified: 2014-08-14 11:20 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-28 11:29:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nikoleta Ziakova 2013-10-01 09:48:54 EDT
Document URL: 
http://documentation-devel.engineering.redhat.com/docs/en-US/JBoss_Enterprise_Application_Platform/6.2/html/Development_Guide/Maven_BOM_Usage.html

Section Number and Name: 
2.3.4. Manage Project Dependencies

Describe the issue: 
Maven BOM containing all supported artifacts is missing from this section.

Additional information: 
See BZ 1008080
Comment 1 sgilda 2014-02-12 16:01:43 EST
I'll take this one.

There is no way we can list all of the supported artifacts as there are quite a few. This is intended only to provide an example.

Should we point them to the quickstarts for examples of supported artifacts?
Comment 2 sgilda 2014-02-19 11:40:44 EST
Adding Paul Gier.

@pgier: What do you think? The list of supported artifacts is extremely large. Is there a list maintained somewhere that we can point them to?
Comment 3 Paul Gier 2014-03-13 14:50:37 EDT
I believe this was complete for EAP 6.2.0.  The supported artifacts BOM is documented in the "Manage Project Dependencies" section.

Is there additional information that needs to be added?
Comment 4 sgilda 2014-03-13 16:47:01 EDT
@pgier: We only give an example of hibernate. We don't list all of them. Aren't there a ton of supported artifacts? Is the list available anywhere?
Comment 5 Nikoleta Ziakova 2014-03-14 03:19:44 EDT
@Paul, 
yes, this was done for EAP 6.2.0 and I beleive no additional info is needed. I haven't verified this BZ only because it never got ON_QA.

@Sande,
we don't have to list all supported artifacts in documentation. It is sufficient that devel guide tells that eap6-supported-artifacts BOM specifies all supoprted artifacts and shows an example how to use it.
Comment 6 sgilda 2014-03-14 07:52:43 EDT
@Nikoleta: Sorry, I misunderstood your request. 

Is the section 'Dependency Management' here what you are looking for?
http://documentation-devel.engineering.redhat.com/site/documentation/en-US/JBoss_Enterprise_Application_Platform/6.2/html-single/Development_Guide/index.html#Maven_BOM_Usage
Comment 7 Nikoleta Ziakova 2014-03-14 08:58:47 EDT
Yes, the Dependency Management section missed from devel guide but it was fixed in EAP 6.2.0 and is OK in 6.3 docs too.

Verified.

Note You need to log in before you can comment on or make changes to this bug.