Bug 1014187 - FSW 6.0.0 ER4 Post install step vault - Password vault configuration fails
FSW 6.0.0 ER4 Post install step vault - Password vault configuration fails
Status: CLOSED CURRENTRELEASE
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: Installer (Show other bugs)
6.0.0 GA
Unspecified Unspecified
unspecified Severity urgent
: ER7
: 6.0.0
Assigned To: Thomas Hauser
ppecka
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-01 09:51 EDT by ppecka
Modified: 2014-02-06 10:32 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ppecka 2013-10-01 09:51:20 EDT
Description of problem:
java -jar jboss-eap-6.0.0.fsw.ci-installer.jar

In post install step "Password vault configuration"

after filling keystore password

Hitting "Next" button pops "Invalid File - The file you have chosen either does not exist or is not valid."

tried setting various paths - wont work
Comment 1 Thomas Hauser 2013-10-01 13:33:46 EDT
The feature works if the fields all contain valid information. However, it is not good for us to assume the user knows how to complete this part of the installation. I'm all ears for suggestions to improve this part of the installer. 

The first path must point to a keystore. The second path must point to a directory in which the user wants to store the vault files. 

See this documentation for details:
https://access.redhat.com/site/documentation/en-US/JBoss_Enterprise_Application_Platform/6/html/Administration_and_Configuration_Guide/Create_a_Java_Keystore_to_Store_Sensitive_Strings.html

Summary:
This panel needs some UX passes. The current information is not sufficient for a user without prior knowledge to know how to fill in the required information. However, the feature works when the fields are filled with valid information.
Comment 2 Thomas Hauser 2013-10-01 14:40:39 EDT
The feature works if the fields all contain valid information. However, it is not good for us to assume the user knows how to complete this part of the installation. I'm all ears for suggestions to improve this part of the installer. 

The first path must point to a keystore. The second path must point to a directory in which the user wants to store the vault files. 

See this documentation for details:
https://access.redhat.com/site/documentation/en-US/JBoss_Enterprise_Application_Platform/6/html/Administration_and_Configuration_Guide/Create_a_Java_Keystore_to_Store_Sensitive_Strings.html

Summary:
This panel needs some UX passes. The current information is not sufficient for a user without prior knowledge to know how to fill in the required information. However, the feature works when the fields are filled with valid information.
Comment 7 Thomas Hauser 2013-10-21 11:20:53 EDT
This feature works correctly when all required information is provided. However, it should probably be decided which fields should be affected by the vault (which fields should have their provided values replaced by a vaulted value)
Comment 8 Thomas Hauser 2013-11-13 12:17:43 EST
Because of new SRAMP changes
https://bugzilla.redhat.com/show_bug.cgi?id=1019983
https://bugzilla.redhat.com/show_bug.cgi?id=1019989
https://bugzilla.redhat.com/show_bug.cgi?id=1019990
https://bugzilla.redhat.com/show_bug.cgi?id=1017212
The functionality of this feature has changed. A keystore will now be generated at the given location, and validation of this location has changed accordingly. The location must now be a non-existent, writable location, and the default values will work out of the box with as a valid password vault.
Comment 9 Pavol Srna 2013-12-13 08:44:52 EST
Verified in ER7.

Note You need to log in before you can comment on or make changes to this bug.