Bug 1014218 - RFE: more intelligent scheduling
RFE: more intelligent scheduling
Status: CLOSED DUPLICATE of bug 709012
Product: Beaker
Classification: Community
Component: scheduler (Show other bugs)
0.11
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ---
: ---
Assigned To: beaker-dev-list
tools-bugs
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-01 10:24 EDT by Jaroslav Kortus
Modified: 2018-02-05 19:41 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 21:29:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaroslav Kortus 2013-10-01 10:24:11 EDT
Description of problem:
I'm periodically seeing a non-wise selection of nodes. I have several LC with many hosts and when the utilization of one goes high, following happens:

RS:
node-1 - scheduled
node-2 - scheduled
node-3 - scheduled
node-4 - queued

This is not wise, as there are other LCs that would be suitable for the job and have free resources. So while I've plenty of resources available, the job is delayed until one particular LC is free.

Version-Release number of selected component (if applicable):
0.11.3

How reproducible:
always

Steps to Reproduce:
1. schedule recipeset with more recipes than nodes available on one LC, while having another LC with enough resources to run it too
2. wait for it to happen :)
3.

Actual results:
job delayed, resources not used effectively

Expected results:
job scheduled on first free LC that could host it, if none is found, queue it

Additional info:
Comment 2 Dan Callaghan 2013-10-01 21:29:59 EDT

*** This bug has been marked as a duplicate of bug 709012 ***

Note You need to log in before you can comment on or make changes to this bug.