Bug 1014222 - rhts policy module not loading on RHEL-7.0-20130926.0
rhts policy module not loading on RHEL-7.0-20130926.0
Status: CLOSED NOTABUG
Product: Beaker
Classification: Community
Component: beah (Show other bugs)
0.14
All Linux
unspecified Severity high (vote)
: ---
: ---
Assigned To: beaker-dev-list
tools-bugs
: TestBlocker
Depends On: 1012810
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-01 10:27 EDT by Juraj Marko
Modified: 2015-08-31 23:39 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-25 21:40:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 Dan Callaghan 2013-10-01 21:21:18 EDT
Did the rhts selinux module fail to load, as in bug 849568? I'm fairly sure it should allow anything to write to /mnt/testarea.
Comment 3 Milos Malik 2013-10-02 09:18:25 EDT
The rhts policy module is not loaded on fresh machines provided by beaker.
Comment 4 Milos Malik 2013-10-03 02:11:01 EDT
Maybe related to BZ#1012810.
Comment 5 Dalibor Pospíšil 2013-10-03 04:46:56 EDT
(In reply to Milos Malik from comment #4)
> Maybe related to BZ#1012810.

This bug prevent rths module to be loaded so it is most probably the root cause.
Comment 6 Dalibor Pospíšil 2013-10-03 04:47:52 EDT
(In reply to Dalibor Pospíšil from comment #5)
> (In reply to Milos Malik from comment #4)
> > Maybe related to BZ#1012810.
> 
> This bug prevent rths module to be loaded so it is most probably the root
> cause.

I mean BZ#1012810 is the root cause.
Comment 7 Nick Coghlan 2013-10-03 05:06:19 EDT
Marking BZ#1012810 as a dependency - if that policy doesn't load, the SELinux default settings and the test harness really don't get along.
Comment 8 Dan Callaghan 2014-03-25 21:40:06 EDT
Bug 1012810 was fixed in RHEL7 quite some time ago. The rhts selinux policy is successfully loaded on recent RHEL7 snapshots. So I guess this is no longer an issue.

Note You need to log in before you can comment on or make changes to this bug.