Bug 1014301 - javapackages-tools: Improve error messages for command line tools
javapackages-tools: Improve error messages for command line tools
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: javapackages-tools (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mikolaj Izdebski
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-01 12:57 EDT by Mikolaj Izdebski
Modified: 2013-10-08 14:19 EDT (History)
4 users (show)

See Also:
Fixed In Version: 3.3.1-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-08 14:19:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mikolaj Izdebski 2013-10-01 12:57:59 EDT
Description of problem:
It looks like %mvn_*  macros perform too strict argument checking.

Version-Release number of selected component (if applicable):
3.3.0-1

Steps to Reproduce:
1. python /usr/share/java-utils/mvn_alias.py ':{woodstox-core}-asl' @1-lgpl

Actual results:
Usage: mvn_alias.py [options] <MVN spec> <MVN spec> [MVN spec ...]
mvn_alias.py: error: Unable to create Artifact from supplied arguments (@1-lgpl): Provided artifact strings were invalid. Please see help  and check your arguments

Expected results:
Command succeeds and config file is created.
Comment 1 Mikolaj Izdebski 2013-10-02 12:17:29 EDT
Test case added upstream in 25d9587.
Comment 2 Mikolaj Izdebski 2013-10-08 14:02:37 EDT
Fixed in javapackages-tools-3.3.1-1
Comment 3 Mikolaj Izdebski 2013-10-08 14:19:18 EDT
I believe that this bug is fixed in javapackages-tools-3.3.1-1,
which is available in Fedora Rawhide, so I am closing this bug now.

The build containing the fix can be found at Koji:
http://koji.fedoraproject.org/koji/buildinfo?buildID=469008

Note You need to log in before you can comment on or make changes to this bug.