Bug 1014335 - Installer needs to report errors more directly to the user - and not continue the installation to the end
Installer needs to report errors more directly to the user - and not continue...
Status: CLOSED CURRENTRELEASE
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: Installer (Show other bugs)
6.0.0 GA
Unspecified Unspecified
unspecified Severity urgent
: ER7
: 6.0.0
Assigned To: Thomas Hauser
Len DiMaggio
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-01 14:24 EDT by Len DiMaggio
Modified: 2014-02-06 10:26 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-06 10:26:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot #1 (208.12 KB, image/png)
2013-10-01 14:24 EDT, Len DiMaggio
no flags Details
Screenshot #2 (98.39 KB, image/png)
2013-10-01 14:25 EDT, Len DiMaggio
no flags Details
Screenshot #3 (88.00 KB, image/png)
2013-10-01 14:25 EDT, Len DiMaggio
no flags Details

  None (edit)
Description Len DiMaggio 2013-10-01 14:24:22 EDT
Description of problem:

If an error is encountered during an installation, the installer reports the error to the user in the stdout stream displayed in the installer dialog. The installation, however is not aborted. The user is told that the installation failed on the last screen displayed by the installer.

See the sequence of attached screenshots.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Len DiMaggio 2013-10-01 14:24:56 EDT
Created attachment 806123 [details]
Screenshot #1
Comment 2 Len DiMaggio 2013-10-01 14:25:28 EDT
Created attachment 806124 [details]
Screenshot #2
Comment 3 Len DiMaggio 2013-10-01 14:25:54 EDT
Created attachment 806125 [details]
Screenshot #3
Comment 4 Thomas Hauser 2013-10-01 15:26:36 EDT
This is due to the way IzPack functions in this panel. Will modify IzPack to have this behaviour.
Comment 6 Thomas Hauser 2013-10-07 11:02:13 EDT
The panel which runs the jobs has been changed to display errors in bright red text, rather than having no colors at all previously.
Comment 9 Pavol Srna 2013-12-13 08:35:03 EST
Verified in ER7.

Note You need to log in before you can comment on or make changes to this bug.