Bug 1014355 - xmvn errors out with missing /usr/share/xmvn/conf/logging
xmvn errors out with missing /usr/share/xmvn/conf/logging
Product: Fedora
Classification: Fedora
Component: xmvn (Show other bugs)
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Mikolaj Izdebski
Fedora Extras Quality Assurance
: Reopened
Depends On:
  Show dependency treegraph
Reported: 2013-10-01 15:23 EDT by Robert Rati
Modified: 2013-11-25 01:36 EST (History)
5 users (show)

See Also:
Fixed In Version: 1.3.0-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2013-11-25 01:36:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Robert Rati 2013-10-01 15:23:39 EDT
Description of problem:
Attempting to build with newest xmvn in F20 results in the following error:
Executing(%build): /bin/sh -e /var/tmp/rpm-tmp.0GXgTS
+ umask 022
+ cd /home/fedora/rpmbuild/BUILD
+ cd hadoop-common-b92d9bcf559cc2e62fc166e09bd2852766b27bec
+ python /usr/share/java-utils/mvn_build.py -- -Drequire.snappy=true -Dcontainer-executor.conf.dir=/etc/hadoop -Pdist,native -DskipTests -DskipTest -DskipIT
java.io.FileNotFoundException: /usr/share/xmvn/conf/logging
	at org.codehaus.plexus.classworlds.launcher.ConfigurationParser.parse(ConfigurationParser.java:264)
	at org.codehaus.plexus.classworlds.launcher.Configurator.configure(Configurator.java:133)
	at org.codehaus.plexus.classworlds.launcher.Launcher.configure(Launcher.java:131)
	at org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:409)
	at org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:356)
error: Bad exit status from /var/tmp/rpm-tmp.0GXgTS (%build)

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:

Actual results:

Expected results:

Additional info:
Comment 1 Michal Srb 2013-10-09 04:39:36 EDT
Are you still able to reproduce this problem? I can see from output that you tried to build hadoop locally, without mock. I tried to install xmvn-1.1.0-1 in F20 mock and it failed from different reason (ClassNotFoundException: com.google.inject.Module), but current combination of javapackages-tools-3.3.1-1 and xmvn-1.1.0-2 seems to work.

Comment 2 Robert Rati 2013-10-10 11:02:40 EDT
xmvn-1.1.0-2 doesn't seem to exhibit the problem.
Comment 3 Mikolaj Izdebski 2013-10-10 11:05:02 EDT
Thanks. Marking as fixed.
Comment 4 Timothy St. Clair 2013-10-10 14:31:21 EDT
Just to note, a full reinstall of the package is required.  

a `yum update` still fails.
Comment 5 Stanislav Ochotnicky 2013-10-11 03:16:05 EDT
Reopening for investigation. This is most likely a %pretrans scriptlet problem
Comment 6 Michal Srb 2013-10-14 02:43:33 EDT
Hi Timothy,

could you please paste the error message from `yum update` here? Thanks.
Comment 7 Timothy St. Clair 2013-10-14 09:51:38 EDT
There is no error in 'yum update', it's an upgrade of a package has a missing directory structure.  

It complains about the same missing directory structure: /usr/share/xmvn/conf/logging

which only appears to be created on a fresh install.
Comment 8 Michal Srb 2013-11-05 08:58:59 EST
OK, here's how to reproduce it:

$ rpm -q maven xmvn

# rpm -e --nodeps maven
# yum install maven-3.1.0-3.fc20.noarch.rpm xmvn-1.1.0-2.fc20.noarch.rpm

$ rpm -V xmvn
missing     /usr/share/xmvn/conf/logging/simplelogger.properties
Comment 9 Mikolaj Izdebski 2013-11-05 09:51:24 EST
Another reproducer that does not need removing maven:

# rpm -q maven xmvn

# rpm -V maven xmvn

# rpm -U maven-3.1.0-3.fc20.noarch.rpm xmvn-1.1.0-2.fc20.noarch.rpm --force

# rpm -V maven xmvn
missing     /usr/share/xmvn/conf/logging/simplelogger.properties
Comment 10 Mikolaj Izdebski 2013-11-05 09:55:03 EST
This is urgent as it breaks upgrade path from Fedora 19 to Fedora 20.

We are working on developing a proper fix.
For now users reinstall xmvn to workaround this bug.

# rpm -V xmvn
missing     /usr/share/xmvn/conf/logging/simplelogger.properties
# rpm -U xmvn-1.1.0-2.fc20.noarch.rpm --force
# rpm -V xmvn
Comment 11 Mikolaj Izdebski 2013-11-05 11:31:08 EST
Fixed in xmvn-1.2.0-5
Comment 12 Mikolaj Izdebski 2013-11-25 01:36:18 EST
I believe that this bug is fixed in xmvn-1.3.0-2,
which is available in Fedora 20, so I am closing this bug now.

The build containing the fix can be found at Koji:

Note You need to log in before you can comment on or make changes to this bug.