This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1014362 - Versioned requires without spaces around operator causes strange traceback
Versioned requires without spaces around operator causes strange traceback
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: fedora-review (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Stanislav Ochotnicky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-01 15:52 EDT by Ian Weller
Modified: 2013-10-04 00:54 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-04 00:54:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Relevant section of log (5.03 KB, text/plain)
2013-10-01 15:52 EDT, Ian Weller
no flags Details

  None (edit)
Description Ian Weller 2013-10-01 15:52:10 EDT
Created attachment 806159 [details]
Relevant section of log

Including a Requires line such as:

> Requires:       php>=5.1.2

causes fedora-review to traceback after running an invalid repoquery command.

Putting spaces around the operator fixes the issue.

Attached is the relevant part of the log.
Comment 1 Alec Leamas 2013-10-03 08:54:02 EDT
Hi!

Thanks for reporting this. Could you please provide info on what package you were reviewing when this happened? Preferably, the complete command line when invoking fedora-review?
Comment 2 Ian Weller 2013-10-03 14:18:52 EDT
The review in question was bug 1014353. (Fortunately because the package needed to be renamed, the bug-inducing spec is still there!)

http://puiterwijk.fedorapeople.org//lightopenid.spec

The command line was fedora-review -P PHP -b 1014353, but to cause the bug you'll have to specify the older spec/SRPM, I think.
Comment 3 Alec Leamas 2013-10-04 00:54:45 EDT
Thanks again for report and swift feedback. This is now fixed [2] in devel, should it become a problem for you once again before next release please refer  to [1] for using the devel version.

--alec


[1] https://fedorahosted.org/FedoraReview/wiki/UseDevelopmentVersion
[2] http://git.fedorahosted.org/cgit/FedoraReview.git/commit/?id=fbf7e8e

Note You need to log in before you can comment on or make changes to this bug.