Bug 1014410 - [origin] can't create scaleable apps of any type in Origin.
[origin] can't create scaleable apps of any type in Origin.
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Kubernetes (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Krishna Raman
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-01 19:13 EDT by Peter Ruan
Modified: 2015-05-14 22:21 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-23 22:21:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Ruan 2013-10-01 19:13:24 EDT
Description of problem:
  Can't seem to create scalable apps of any kind in the latest Origin build.  Get the following error during app creation process.

The target_update option specified but no old configuration:

Version-Release number of selected component (if applicable):
latest

How reproducible:
always.

Steps to Reproduce:
1. rhc app create appx php-5.5 -s -d
2.
3.

Actual results:

DEBUG: SSL Verification failed -- Using self signed cert
DEBUG:    code 422 15857 ms
Unexpected error: The target_update option specified but no old configuration: : appx-origin.example.com

Expected results:
success.

Additional info:
Comment 1 Abhishek Gupta 2013-11-13 13:40:40 EST
This seems to be fixed now.
Comment 2 Jianwei Hou 2013-11-15 03:39:00 EST
Verified with latest build, the scalable apps can be created now.

[root@broker ~]# rhc create-app rs ruby-2.0 -s
Application Options
-------------------
  Domain:     bmeng
  Cartridges: ruby-2.0
  Gear Size:  default
  Scaling:    yes

Creating application 'rs' ... done


Waiting for your DNS name to be available ... done

正克隆到 'rs'...
The authenticity of host 'rs-bmeng.example.com (10.66.8.145)' can't be established.
RSA key fingerprint is be:4e:bb:46:0a:73:0e:09:d9:c5:fb:5c:57:b3:2b:15.
Are you sure you want to continue connecting (yes/no)? yes
Warning: Permanently added 'rs-bmeng.example.com' (RSA) to the list of known hosts.

Your application 'rs' is now available.

  URL:        http://rs-bmeng.example.com/
  SSH to:     5285dd3b6892df3f9b000024@rs-bmeng.example.com
  Git remote: ssh://5285dd3b6892df3f9b000024@rs-bmeng.example.com/~/git/rs.git/
  Cloned to:  /root/rs

Run 'rhc show-app rs' for more details about your app.

Note You need to log in before you can comment on or make changes to this bug.