Bug 1014416 - Access denied during storage install
Access denied during storage install
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Documentation (Show other bugs)
JON 3.2
x86_64 Windows
high Severity high
: GA
: JON 3.2.0
Assigned To: Deon Ballard
Mike Foley
: Reopened
Depends On:
Blocks: 1012435
  Show dependency treegraph
 
Reported: 2013-10-01 19:35 EDT by Viet Nguyen
Modified: 2014-09-05 11:38 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-24 12:47:04 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
storage-installer.log (3.22 KB, text/plain)
2013-10-01 19:35 EDT, Viet Nguyen
no flags Details
rhqctl.log (556 bytes, text/plain)
2013-10-01 19:39 EDT, Viet Nguyen
no flags Details

  None (edit)
Description Viet Nguyen 2013-10-01 19:35:37 EDT
Created attachment 806194 [details]
storage-installer.log

Description of problem:

rhqctrl --server --storage

----rhq-storage-installer.log------

16:21:53,252 INFO  [org.rhq.storage.installer.StorageInstaller] Updating rhq-server.properties...
16:21:53,267 INFO  [org.rhq.storage.installer.StorageInstaller] Starting RHQ Storage Node
16:21:53,377 WARN  [org.rhq.storage.installer.StorageInstaller] The storage node reported the following errors while trying to start:

Access is denied.
-------------

Version-Release number of selected component (if applicable):
ER2

How reproducible:


Steps to Reproduce:
1.  Windows 2008 R2 64bit.  Log in as Administrator
2.  unzip build. run rhqctrl --server --storage
3.  Server won't to start

See attachment
Comment 1 Viet Nguyen 2013-10-01 19:39:49 EDT
Created attachment 806196 [details]
rhqctl.log
Comment 3 Simeon Pinder 2013-10-08 03:52:43 EDT
Moving into ER04 as not completed in ER03.
Comment 4 Jay Shaughnessy 2013-10-14 13:40:16 EDT
I'm not sure but this looks like it may have been due to running rhqctl from a non-administrator command window on Windows. Even if logged in as a user with Admin privileges you still need to start the command window "Run as Administrator"  (at least on Win7).

Viet, could this be the issue?
Comment 5 Simeon Pinder 2013-10-24 00:16:20 EDT
Moving to ER05 as missed the cutoff for ER04.
Comment 6 Viet Nguyen 2013-10-25 10:49:24 EDT
Indeed that's the issue. I wasn't aware of the Run as Administrator step.
Comment 7 Jay Shaughnessy 2013-10-25 11:44:36 EDT
OK, great.  Closing as NOTABUG.  We already have doco for this so we should be good to go.
Comment 8 Mike Foley 2013-10-25 13:19:51 EDT
re-purposing this as a doc bug for sunny-dee based on jay's comments.
Comment 9 Heiko W. Rupp 2013-10-26 07:27:23 EDT
Now with being a doc bug, we don't need it in the ER5 payload.
Comment 10 Deon Ballard 2014-01-24 12:47:04 EST
This is now step #1 for installing the server on Windows:
https://access.redhat.com/site/documentation/en-US/Red_Hat_JBoss_Operations_Network/3.2/html/Installation_Guide/install-windows-jar.html

Note You need to log in before you can comment on or make changes to this bug.