Bug 1014417 - fscache / cachefilesd responsible for crash
fscache / cachefilesd responsible for crash
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: cachefilesd (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Steve Dickson
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-01 19:36 EDT by Leon Fauster
Modified: 2014-04-08 10:25 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-08 10:25:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot at console via idrac (123.77 KB, image/png)
2013-10-01 19:36 EDT, Leon Fauster
no flags Details
2nd screenshot at console via idrac (34.33 KB, image/png)
2013-10-30 18:30 EDT, Leon Fauster
no flags Details
kernel panic screen shot (177.53 KB, image/jpeg)
2014-03-24 04:25 EDT, ranjith
no flags Details

  None (edit)
Description Leon Fauster 2013-10-01 19:36:42 EDT
Created attachment 806195 [details]
screenshot at console via idrac

# Description of problem:

System crashed. I have only a screenshot (attached).

The system has two nfs resources mounted. cachefilesd is used to optimize.   
The data in that mounted dirs is used by the webserver (htdocs).


# Version-Release number of selected component (if applicable):

$ rpm -qa | grep cachef
cachefilesd-0.10.2-1.el6.x86_64

$ uname -a
Linux srv-sl0a.ccds.de 2.6.32-358.18.1.el6.x86_64 #1 SMP Wed Aug 28 17:19:38 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

rpm -qa | grep nfs
nfs-utils-lib-1.1.5-6.el6.x86_64
nfs-utils-1.2.3-36.el6.x86_64


# How reproducible:
I can not reproduce it - it just happens today the first time. 
The cachefilesd is setup since 5 days. I hope the screenshot helps.


# Actual results:
Crash

# Expected results:
No crash


# Additional info:
du -h -s /var/cache/fscache/
21G	/var/cache/fscache/

# nfs mount options
cat /etc/fstab | grep nfs |cut -f4
rw,noexec,nosuid,acl,nosharecache,fsc,rsize=8192,wsize=8192,nfsvers=3,tcp,intr,soft,timeo=60 0 0
rw,noexec,nosuid,acl,nosharecache,fsc=lib,rsize=8192,wsize=8192,nfsvers=3,tcp,intr,soft,timeo=60 0 0
Comment 2 RHEL Product and Program Management 2013-10-13 19:05:02 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 3 Leon Fauster 2013-10-30 18:30:56 EDT
Created attachment 817652 [details]
2nd screenshot at console via idrac

2nd time that the system crashed
Comment 4 ranjith 2014-03-24 04:24:32 EDT
Hello 

We were testing fs-cache for last 1 week. It paniched with similar traces. 

kernel based on  

Red Hat Enterprise Linux 6.5
kernel (2.6.32-431.1.2.el6)


Attaching a screen shot as i was not able to capture vmcore. 

Regards
Ranjith
Comment 5 ranjith 2014-03-24 04:25:20 EDT
Created attachment 877955 [details]
kernel panic  screen shot
Comment 6 Ranjith Rajaram 2014-03-25 13:11:25 EDT
Leon

Fix is included in RHEL 6.5
https://access.redhat.com/site/solutions/374553

Please check whether you notice this problem with RHEL 6.5

Ranjith

With reference to your email in linux-cachefs list.. Can you confirm whether you notice the panic when you use the standard RH kernel ?
Comment 7 Leon Fauster 2014-04-04 12:34:54 EDT
So far no problems with EL6.5. Thank you for your input!

Note You need to log in before you can comment on or make changes to this bug.