Bug 1014458 - Program does not start
Program does not start
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: slic3r (Show other bugs)
19
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Miro Hrončok
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-02 02:10 EDT by Dario Faggioli
Modified: 2013-10-08 05:42 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-07 10:27:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dario Faggioli 2013-10-02 02:10:19 EDT
Description of problem:
Click on the program icon in gnome-shell, or invoke it on a terminal. It should start but it actually does not.

Version-Release number of selected component (if applicable):
$ yum info slic3r
Installed Packages
Name        : slic3r
Arch        : noarch
Version     : 0.9.10b
Release     : 2.fc19

How reproducible:
100%, at least here.

Steps to Reproduce:
1. open a terminal
2. invoke the program by typing `slic3r'

Actual results:
The program does not start.

Expected results:
The program should start.

Additional info:
Here's what I get on the terminal output:

$ slic3r 
Math::Clipper version 1.22 required--this is only version 1.17 at /usr/share/perl5/vendor_perl/Slic3r/Geometry/Clipper.pm line 12.
BEGIN failed--compilation aborted at /usr/share/perl5/vendor_perl/Slic3r/Geometry/Clipper.pm line 12.
Compilation failed in require at /usr/share/perl5/vendor_perl/Slic3r/ExPolygon.pm line 11.
BEGIN failed--compilation aborted at /usr/share/perl5/vendor_perl/Slic3r/ExPolygon.pm line 11.
Compilation failed in require at /usr/share/perl5/vendor_perl/Slic3r.pm line 32.
BEGIN failed--compilation aborted at /usr/share/perl5/vendor_perl/Slic3r.pm line 32.
Compilation failed in require at /usr/bin/slic3r line 17.
BEGIN failed--compilation aborted at /usr/bin/slic3r line 17.
Comment 1 Miro Hrončok 2013-10-02 06:24:39 EDT
Uaaa. The thing is, you need Math-Clipper 1.22, as it says.

Should be fixed by `yum update perl-Math-Clipper`.

I should have added >= 1.22 to requires, but I forgot and now I cannot, because slic3r fails to build in rawhide and Fedora 20.
Comment 2 Dario Faggioli 2013-10-03 02:54:17 EDT
(In reply to Miro Hrončok from comment #1)
> Uaaa. The thing is, you need Math-Clipper 1.22, as it says.
> 
> Should be fixed by `yum update perl-Math-Clipper`.
> 
Mmm... Does not look like so (or am I doing something wrong?):

$ sudo yum install perl-Math-Clipper
...
Package perl-Math-Clipper-1.22-4.fc19.x86_64 already installed and latest version
Nothing to do

$ yum info perl-Math-Clipper
...
Installed Packages
Name        : perl-Math-Clipper
Arch        : x86_64
Version     : 1.22
Release     : 4.fc19

$ slic3r 
Math::Clipper version 1.22 required--this is only version 1.17 at /usr/share/perl5/vendor_perl/Slic3r/Geometry/Clipper.pm line 12.
BEGIN failed--compilation aborted at /usr/share/perl5/vendor_perl/Slic3r/Geometry/Clipper.pm line 12.
Compilation failed in require at /usr/share/perl5/vendor_perl/Slic3r/ExPolygon.pm line 11.
BEGIN failed--compilation aborted at /usr/share/perl5/vendor_perl/Slic3r/ExPolygon.pm line 11.
Compilation failed in require at /usr/share/perl5/vendor_perl/Slic3r.pm line 32.
BEGIN failed--compilation aborted at /usr/share/perl5/vendor_perl/Slic3r.pm line 32.
Compilation failed in require at /usr/bin/slic3r line 17.
BEGIN failed--compilation aborted at /usr/bin/slic3r line 17.

> I should have added >= 1.22 to requires, but I forgot and now I cannot,
> because slic3r fails to build in rawhide and Fedora 20.
>
Yep, I noticed that on F19 too (talking about the .tar and the git, I haven't tried the SRPM).

Thanks and Regards,
Dario
Comment 3 Paul Howarth 2013-10-03 06:04:06 EDT
Perhaps you have another version of the Math::Clipper module installed as well as the perl-Math-Clipper rpm?

What happens if you do:
$ perl -MMath::Clipper -e 'print "$Math::Clipper::VERSION\n";'

I get "1.22".
Comment 4 Dario Faggioli 2013-10-04 03:51:07 EDT
Looks like I do:

$ perl -MMath::Clipper -e 'print "$Math::Clipper::VERSION\n";'
1.17

Now the question is who installed that (I certainly did not, I know nothing about perl!). Perhaps a manual attempt to build Slic3r from sources some months ago?

Also, is that normal that installing the perl-Math-Clipper rpm does not identify that and update it, or at least report it, or something like that (again, sorry, 0% perl here :-( )?

I'll see if I can remove it, and  if Slic3r turns back tu functioning after that...

Thanks.
Comment 5 Paul Howarth 2013-10-04 04:50:58 EDT
This should find it for you:

$ perl -MMath::Clipper -e 'print $INC{"Math/Clipper.pm"} . "\n"'
/usr/lib64/perl5/vendor_perl/Math/Clipper.pm

Installing / updating the perl-Math-Clipper rpm package would update an existing perl-Math-Clipper rpm package, but it can know nothing about any other versions you've installed by other means.
Comment 6 Dario Faggioli 2013-10-07 10:27:46 EDT
(In reply to Paul Howarth from comment #5)
> This should find it for you:
> 
> $ perl -MMath::Clipper -e 'print $INC{"Math/Clipper.pm"} . "\n"'
> /usr/lib64/perl5/vendor_perl/Math/Clipper.pm
> 
I use some other way to achieve the same, but I think I did it, thanks.

> Installing / updating the perl-Math-Clipper rpm package would update an
> existing perl-Math-Clipper rpm package, but it can know nothing about any
> other versions you've installed by other means.
>
Yes, it worked. Great.

I think I can close the bug now... It probably wasn't a bug in the first place (sorry for that).

Note You need to log in before you can comment on or make changes to this bug.